#koha: Development IRC meeting 11 July 2018

Meeting started by kidclamp at 15:01:10 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 15:01:16)
    1. Katrin Fischer, BSZ, Germany (cait, 15:01:22)
    2. Nick Clemens, ByWater Solutions (kidclamp, 15:01:28)
    3. Martin Renvoize (ashimema, 15:01:40)
    4. Colin Campbell, PTFS-Europe (cc_, 15:01:45)
    5. Barton Chittenden, , ByWater Solutions (barton, 15:01:49)
    6. Thomas Dukleth, Agogme, New York City (thd, 15:02:44)
    7. Jonathan Druart (Joubu, 15:05:30)
    8. RM pushign bugs and working towards SCSS patches (kidclamp, 15:09:35)
    9. ES bugs need 18316 for attention (kidclamp, 15:16:38)
    10. Next Elasticsearch bug for QA is bug 18316 (cait, 15:17:52)

  2. Updates from the Release Maintainers (kidclamp, 15:17:53)
    1. string freezes for current release on 15th, and releases as normal (kidclamp, 15:20:05)
    2. 18.05.x - Lots of bugfixes pushed already, cookie related gdpr enhancements and marc framework updates backported too. (ashimema, 15:20:15)

  3. Updates from the QA team (kidclamp, 15:22:28)
    1. the QA team are much loved and praised, we thank them for their efforts and look forward to more :-) (kidclamp, 15:23:57)
    2. nots in the queues and some big things to get moving early in release cycle (kidclamp, 15:26:03)
    3. lots in the queues and some big things to get moving early in release cycle (kidclamp, 15:26:10)

  4. General development discussion (trends, ideas, ...) (kidclamp, 15:29:24)
    1. dicsussion: Bug 19893 - Drop dependancy on catmandu for elastic search (kidclamp, 15:29:59)
    2. ACTION: ashimema will send a mail about bug 19893 for discussion and vote at next dev meeting (kidclamp, 15:41:37)
    3. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20935 (cait, 15:42:08)
    4. librarians please look at bug 20935 (kidclamp, 15:43:56)

  5. Review of coding guidelines (kidclamp, 15:44:39)
    1. ACTION: kidclamp will send a note out about bug 20935 (kidclamp, 15:47:57)
    2. Next meeting July 25 2018, 20 UTC (kidclamp, 15:50:13)


Meeting ended at 15:50:17 UTC (full logs).

Action items

  1. ashimema will send a mail about bug 19893 for discussion and vote at next dev meeting
  2. kidclamp will send a note out about bug 20935


Action items, by person

  1. ashimema
    1. ashimema will send a mail about bug 19893 for discussion and vote at next dev meeting
  2. kidclamp
    1. kidclamp will send a note out about bug 20935


People present (lines said)

  1. kidclamp (60)
  2. cait (51)
  3. ashimema (40)
  4. huginn (15)
  5. thd (9)
  6. beatsforthemind (8)
  7. Joubu (5)
  8. jenkins (3)
  9. barton (2)
  10. cc_ (1)
  11. reiveune (1)
  12. Cait (0)


Generated by MeetBot 0.1.4.