#koha: Development IRC meeting 21 November 2018

Meeting started by kidclamp at 14:05:31 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 14:05:38)
    1. Nick Clemens, ByWaterSolutions (kidclamp, 14:05:47)
    2. Barton Chittenden, ByWaterSolutions (barton, 14:06:09)
    3. Marcel de Rooy, Rijksmuseum NL (marcelr, 14:06:13)
    4. Jon Knight, Loughborough University (greenjimll, 14:06:20)

  2. Announcements (kidclamp, 14:07:21)
    1. Tomas Cohen Arazi (tcohen, 14:08:21)

  3. Update from the Release Manager (kidclamp, 14:08:58)
    1. Release is coming along - combing through the release notes and the majors and above in bugzilla to fix whatever we can (kidclamp, 14:09:23)
    2. possibly considering 21826/19365 - would be nice to fix this, but don't want to cause issues this close to release (kidclamp, 14:10:16)
    3. Martin Renvoize - PTFS Europe (ashimema, 14:10:48)

  4. Updates from the Release Maintainers (kidclamp, 14:12:18)
    1. Fridolin Somers, Biblibre, France (fridolin, 14:13:49)
    2. 18.05.x branch has one current failing test.. I believe it's the test rather than the feature that's failing (ashimema, 14:14:24)
    3. 18.05.x is currently 50 commits begind master, but the majority of those are enhancements and as such won't be backported (ashimema, 14:14:58)
    4. 18.05.x is otherwise on target for release next week (ashimema, 14:15:17)
    5. Thomas Dukleth, Agogme, New York City (thd, 14:15:45)

  5. Updates from the QA team (kidclamp, 14:17:16)
    1. The QA team is awesome, bugs get QAed, things get fixed, the people are happy (kidclamp, 14:18:51)

  6. General development discussion (trends, ideas, ...) (kidclamp, 14:19:07)
    1. bug 21336 could use attention GDPR (kidclamp, 14:20:38)
    2. splitter is an amazing tool, could use some attention to keep it running (kidclamp, 14:20:58)
    3. bug 20028 is a good candidate for 19.05 too (kidclamp, 14:24:17)

  7. Review of coding guidelines (kidclamp, 14:24:26)
    1. Katrin Fischer, BSZ, Germany (cait, 14:26:02)
    2. ACTION: Barton will see about getting a guideline for manual patches drafted and send to community (kidclamp, 14:44:15)
    3. AGREED: bug 21858 will be converted a patch for manual, barton will get a guideline for manual submissions drafted (kidclamp, 14:48:05)

  8. Set time of next meeting (kidclamp, 14:49:27)
    1. Next meeting: 12 December 2018, 20 UTC (kidclamp, 14:52:41)


Meeting ended at 14:52:45 UTC (full logs).

Action items

  1. Barton will see about getting a guideline for manual patches drafted and send to community


Action items, by person

  1. barton
    1. Barton will see about getting a guideline for manual patches drafted and send to community


People present (lines said)

  1. kidclamp (55)
  2. ashimema (39)
  3. cait (22)
  4. barton (18)
  5. greenjimll (17)
  6. marcelr (9)
  7. huginn (9)
  8. fridolin (5)
  9. koha-jenkins (3)
  10. tcohen (2)
  11. thd (2)
  12. wahanui (1)


Generated by MeetBot 0.1.4.