#koha: Development IRC meeting 24 January 2018

Meeting started by kidclamp at 20:00:23 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 20:00:33)
    1. wahanui, a bot that has become sentient (wahanui, 20:00:34)
    2. Nick Clemens, byWater Solutions (kidclamp, 20:00:43)
    3. liz rea, Catalyst IT (wizzyrea, 20:00:48)
    4. Aleisha Amohia, Catalyst IT (aleisha, 20:00:55)
    5. Kyle M Hall, ByWater Solutions (khall, 20:02:29)

  2. Announcements (kidclamp, 20:05:39)
    1. Thomas Dukleth, Agogme, New York City (thd, 20:06:36)
    2. https://wiki.koha-community.org/wiki/Development_IRC_meeting_24_January_2018 Agenda (kidclamp, 20:07:13)
    3. kudos for work on not storing BZ passwords in plain text (kidclamp, 20:07:32)

  3. Update from the Release manager (18.05) (kidclamp, 20:09:01)
    1. Joubu could not make meeting, no updates (kidclamp, 20:10:00)

  4. Updates from the Release Maintainers (kidclamp, 20:10:10)
    1. Academy was awesome and the community was a huge help (kidclamp, 20:10:28)
    2. 17.11.02 and 17.05.08 released today (kidclamp, 20:10:45)

  5. Updates from the QA team (kidclamp, 20:11:27)
    1. every day rhymes with QA day: e.g. Monday is QA day, Tuesday is QA day.... (kidclamp, 20:12:05)

  6. General development discussion (trends, ideas, ...) (kidclamp, 20:12:39)
  7. REST api (kidclamp, 20:26:49)
    1. Vote: PATCH implementation. Proposal to implement JSON-merge (https://tools.ietf.org/html/rfc7386) as a start. Then implement JSON-patch (http://jsonpatch.com/ https://tools.ietf.org/html/rfc6902). This could be done in two steps taking advantage of Content/Type application/json-patch+json to choose between implementations). (kidclamp, 20:26:59)
    2. Lee Jamison, Marywood University (LeeJ, 20:28:19)
    3. waiting for next meeting and tomas to explain (kidclamp, 20:29:08)
    4. VOTE: Voted on "Shall we implement PATCH using JSON-merge and JSON-patch as described in the agenda?" Results are, Yes: 3, Abstain: 2 (kidclamp, 20:38:01)

  8. Bug 20086 (kidclamp, 20:38:32)
  9. Review of coding guidelines (kidclamp, 20:43:31)
    1. Stop using "type" attribute on <script> and <style> tags. See Bug 20053 and Bug 20054 (kidclamp, 20:43:47)
    2. ACTION: indradg please write up a guideline for submission for removing 'type' attributes (kidclamp, 20:46:46)
    3. New rule Coding_Guidelines#SQL12: Booleans (DRAFT) (kidclamp, 20:47:01)
    4. VOTE: Voted on "Should we adopt SQL12 as drafted in the coding guidelines?" Results are, Yes: 4 (kidclamp, 20:53:48)
    5. ACTION: tomas please finalize SQL12 (kidclamp, 20:55:05)

  10. Set time of next meeting (kidclamp, 20:55:12)
    1. Next meeting: 14 February 2018, 13 UTC (kidclamp, 20:58:21)


Meeting ended at 20:58:25 UTC (full logs).

Action items

  1. indradg please write up a guideline for submission for removing 'type' attributes
  2. tomas please finalize SQL12


People present (lines said)

  1. kidclamp (80)
  2. khall (37)
  3. wizzyrea (27)
  4. huginn (17)
  5. thd (16)
  6. LeeJ (6)
  7. aleisha (5)
  8. wahanui (3)
  9. notarock (1)


Generated by MeetBot 0.1.4.