#koha: Development IRC meeting 12 August 2020

Meeting started by Joubu at 14:00:05 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 14:00:10)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_12_August_2020 (Joubu, 14:00:15)
    2. Jonathan Druart (Joubu, 14:00:20)
    3. Marcel de Rooy (marcelr, 14:00:24)
    4. Martin Renvoize, PTFS Europe, UK (ashimema, 14:00:53)
    5. Nick Clemens (kidclamp, 14:01:55)
    6. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:02:10)

  2. Announcements (Joubu, 14:02:27)
    1. Owen Leonard, Athens County Public Library, Ohio, USA (oleonard, 14:04:26)
    2. Marcel sent an email about 24544 on the dev ML - more feedback welcome! (Joubu, 14:06:23)
    3. Update from the Release manager (20.11) (Joubu, 14:06:55)
    4. Focus must be on bug 20168, bug 22417 and bug 20271 for the next couple of weeks (Joubu, 14:09:12)
    5. Bookmark https://frama.link/koha_bz_RM_priority (Joubu, 14:09:30)
    6. Updates from the Release Maintainers (Joubu, 14:15:44)
    7. ACTION: ashimema is going to add his stamp on 20168 (Joubu, 14:16:39)

  3. Updates from the QA team (Joubu, 14:19:17)
    1. There is a bunch a major waiting for SO or QA, would be good to prioritize them (Joubu, 14:22:04)

  4. Actions from last meeting (Joubu, 14:23:05)
  5. ashimema will get back to qa bug 15522 (Joubu, 14:23:17)
    1. I've left a note on the bug.. I'm generally happy with the way it all works from an end user perspective.. We had the PTFS-E educators have a chat with the ByWater educators to work through it.. they're all happy. (ashimema, 14:24:28)
    2. My next move is to start digging into the code.. I'd love to see a vue alternative submitted somewhere so we could do a comparison for code clarity between the two frameworks... (ashimema, 14:25:11)
    3. This bug shouldn't be blocked by a lack of decision on framework.. but also feels like if it gets pushed as is, it makes the implicit decision for us. (ashimema, 14:25:44)
    4. ACTION: ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (Joubu, 14:28:24)

  6. ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed) (Joubu, 14:28:48)
    1. ACTION: ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed) (Joubu, 14:29:12)

  7. tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (Joubu, 14:29:21)
    1. ACTION: tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed) (Joubu, 14:30:15)

  8. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (Joubu, 14:30:34)
    1. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed) (Joubu, 14:31:00)

  9. General development discussion (trends, ideas, ...) (Joubu, 14:31:11)
  10. Set time of next meeting (Joubu, 14:32:20)
    1. Next meeting: 26 August 2020, 14 UTC (Joubu, 14:33:14)
    2. If you prefer another hour of the meeting, like 19, 20, 21, please contact Joubu on IRC and we will modify it (Joubu, 14:35:10)


Meeting ended at 14:35:16 UTC (full logs).

Action items

  1. ashimema is going to add his stamp on 20168
  2. ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code
  3. ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)
  4. tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
  5. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed)


Action items, by person

  1. ashimema
    1. ashimema is going to add his stamp on 20168
    2. ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code
    3. ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)
  2. UNASSIGNED
    1. tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
    2. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed)


People present (lines said)

  1. Joubu (82)
  2. ashimema (30)
  3. marcelr (15)
  4. huginn (13)
  5. tcohen (9)
  6. wahanui (6)
  7. oleonard (3)
  8. kidclamp (1)


Generated by MeetBot 0.1.4.