#koha: Development IRC meeting 18 March 2020

Meeting started by ashimema at 14:00:58 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_18_March_2020#Agenda Agenda (ashimema, 14:01:28)

  1. Introductions (ashimema, 14:01:40)
    1. Katrin Fischer, BSZ, Germany (cait2, 14:01:46)
    2. Martin Renvoize, PTFS Europe (ashimema, 14:01:56)
    3. Owen Leonard, Athens County Public Libraries in Exile, Ohio, USA (oleonard, 14:02:06)
    4. Nick Clemens, ByWater Solutions (kidclamp, 14:02:56)
    5. Jonathan Druart (Joubu, 14:03:20)
    6. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:04:20)

  2. Announcements (ashimema, 14:07:17)
    1. Sadly the Hackfest has had to be cancelled next week due to COVID-19 (ashimema, 14:07:22)
    2. We do however hope to run a virtual hackfest in it's place (ashimema, 14:07:31)
    3. https://wiki.koha-community.org/wiki/Virtual_Hackfest_2020 Virtual Hackfest (ashimema, 14:08:44)
    4. As part of the virtual hackfest Bywater Solutions are hosting a couple of virtual meetings (ashimema, 14:09:14)
    5. Jon Knight (greenjimll, 14:09:41)
    6. I hope to do the same at PTFS-Europe but am a little behind on organising them.. mine will focus on using sandboxes for signoff and how to pick bugs to test for begginers (ashimema, 14:10:07)
    7. Joubu has been working on making koha-testing-docker and koha-sandboxes-docker work with UNIMARC (ashimema, 14:12:06)
    8. https://gitlab.com/koha-community/koha-misc4dev/-/merge_requests/39 (Joubu, 14:12:27)
    9. Things have progressed quickly the past few weeks, but we still need help reducing the queues. (ashimema[m], 14:16:22)
    10. ACTION: Ashimema to send out a reminder about virtual hackfest (ashimema[m], 14:18:11)
    11. https://trello.com/b/8PHH9gJ2/virtual-hackfest2020bugzilla (kidclamp, 14:20:51)
    12. https://trello.com/kohadevel/ (tcohen, 14:21:00)
    13. I intend to start getting much more vigilent about what code I push once the hackfest is complete.. i.e. this is your last change this cycle to try and push bigger enhancements and new features over the line.. I will be getting the team to focus on bugfixes and polishing come April. (ashimema[m], 14:21:27)
    14. ACTION: Joubu will send an email to the French ml (Joubu, 14:26:39)
    15. We are currently in string freeze for the next maintanence releases (ashimema[m], 14:28:46)
    16. We are still attempting to have bug 24846 ready and pushed for this maintanence release but we need a final QA on it. (ashimema[m], 14:29:57)
    17. Consider advocating the use of `<input type=”text” inputmode=”numeric” pattern="[0-9]*">` instead of `<input type="number">` (ashimema[m], 14:31:45)
    18. ACTION: ashimema to write up a guideline to be ratified at the next meeting. (ashimema[m], 14:39:41)
    19. Drop or Update `JS5: Enabling translation of language strings in linked JavaScript` now we have bug 21156 pushed (ashimema[m], 14:43:10)
    20. ACTION: ashimema to update the guidelines with examples of how we now expect this to be done. (ashimema[m], 14:46:37)
    21. Next meeting: 01 April 2020, 14 UTC (ashimema[m], 14:55:39)


Meeting ended at 15:10:23 UTC (full logs).

Action items

  1. Ashimema to send out a reminder about virtual hackfest
  2. Joubu will send an email to the French ml
  3. ashimema to write up a guideline to be ratified at the next meeting.
  4. ashimema to update the guidelines with examples of how we now expect this to be done.


Action items, by person

  1. ashimema
    1. Ashimema to send out a reminder about virtual hackfest
    2. ashimema to write up a guideline to be ratified at the next meeting.
    3. ashimema to update the guidelines with examples of how we now expect this to be done.
  2. Joubu
    1. Joubu will send an email to the French ml


People present (lines said)

  1. cait2 (80)
  2. ashimema[m] (68)
  3. Joubu (31)
  4. ashimema (23)
  5. tcohen (16)
  6. oleonard (15)
  7. kidclamp (12)
  8. huginn (9)
  9. greenjimll (3)
  10. corilynn (3)
  11. jzairo (3)
  12. koha-jenkins (3)
  13. lukeG (1)
  14. magnuse (1)
  15. gmcharlt (1)
  16. caroline (1)


Generated by MeetBot 0.1.4.