#koha: Development IRC meeting 1 April 2020

Meeting started by ashimema at 14:07:23 UTC (full logs).

Meeting summary

  1. Introductions (ashimema, 14:08:02)
    1. Jonathan Druart (Joubu, 14:08:21)
    2. Martin Renvoize, PTFS Europe (ashimema, 14:08:22)
    3. Marcel de Rooy, Rijksmuseum, Netherlands (marcelr, 14:08:24)

  2. Announcements (ashimema, 14:09:31)
    1. Thomas Dukleth, Agogme, New York City [capital of bad viruses and hour long queues to see empty shelves] (thd, 14:10:40)
    2. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:11:00)
    3. https://wiki.koha-community.org/wiki/Development_IRC_meeting_1_April_2020 (Joubu, 14:11:30)
    4. The virtual hackfest was a reasonable success.. lots of bugs pushed and a huge amount of movement in bugzilla. Thankyou to everyone who contributed and got involved. (ashimema, 14:11:39)
    5. https://wiki.koha-community.org/wiki/Development_IRC_meeting_1_April_2020 (marcelr, 14:11:49)
    6. Nick Clemens, ByWaterSolutions (kidclamp, 14:11:50)

  3. Update from the Release manager (ashimema, 14:13:47)
    1. We are moving into the bugfix and polishing stage of the cycle now. I will be going through the rel_20_05_target and rm_priority lists and tidying it up... I will make some exceptions, but generally we should not be focusing on cleaning up for the release, finding and fixing bugs and polishing enhancements and new features. (ashimema, 14:15:39)

  4. Update from the Release maintainers (ashimema, 14:16:08)
    1. Kyle M Hall, ByWater Solutions (khall, 14:16:52)
    2. Joy Nelson Bywater Solutions (tallerjoy, 14:17:01)
    3. Lucas Gass, ByWater Solutions (lukeG1, 14:17:12)
    4. Katrin Fischer, BSZ, Germany (cait, 14:19:15)
    5. Joy is catching 19.11 up with master that the moment.. fast moving master. (ashimema, 14:19:20)
    6. releases went out last week and included 2 new features (ashimema, 14:19:48)
    7. https://koha-community.org/koha-19-05-09-release/ (Joubu, 14:20:11)

  5. Updates from the QA team (Joubu, 14:23:33)
    1. ACTION: Joubu add an email to koha-devel about 22001 (RaiseError) (Joubu, 14:26:09)

  6. General development discussion (ashimema, 14:29:00)
    1. We should start thinking about the next cycle and the next team (ashimema, 14:29:15)
    2. https://wiki.koha-community.org/wiki/Advanced_editor_macros_endpoint_RFC (kidclamp, 14:29:30)
    3. ACTION: Martin will send out an email (ashimema, 14:29:31)
    4. Nick has an RFC we need to look at (ashimema, 14:30:00)
    5. https://wiki.koha-community.org/wiki/Advanced_editor_macros_endpoint_RFC (ashimema, 14:30:08)
    6. VOTE: Voted on ""Do you agree with the RFC for advanced editor macros as wirtten on the wiki including suggested path change by tcohen?" Results are, yes: 9 (cait, 14:35:49)
    7. ACTION: kidclamp to update wiki with changes, vote date etc. (cait, 14:36:08)

  7. Review of coding guidelines (ashimema, 14:45:16)
    1. https://softwareengineering.stackexchange.com/questions/290566/is-localstorage-under-the-cookie-law (probably not best source) claims local storage is also eccected by cookies (cait, 14:58:41)

  8. Set time of next meeting (Joubu, 15:13:18)
    1. Next meeting: 15 April 2020, 20 UTC (Joubu, 15:14:13)


Meeting ended at 15:15:09 UTC (full logs).

Action items

  1. Joubu add an email to koha-devel about 22001 (RaiseError)
  2. Martin will send out an email
  3. kidclamp to update wiki with changes, vote date etc.


Action items, by person

  1. Joubu
    1. Joubu add an email to koha-devel about 22001 (RaiseError)
  2. kidclamp
    1. kidclamp to update wiki with changes, vote date etc.


People present (lines said)

  1. Joubu (72)
  2. cait (68)
  3. ashimema (50)
  4. oleonard (35)
  5. marcelr (18)
  6. wahanui (14)
  7. huginn (14)
  8. tcohen (13)
  9. kidclamp (8)
  10. tallerjoy (4)
  11. lukeG1 (3)
  12. khall (2)
  13. thd (2)


Generated by MeetBot 0.1.4.