#koha: Development IRC meeting 1 July 2020

Meeting started by davidnind at 20:03:53 UTC (full logs).

Meeting summary

    1. Agenda: https://wiki.koha-community.org/wiki/Development_IRC_meeting_1_July_2020 (davidnind, 20:04:33)
    2. Katrin Fischer, BSZ, Germany (cait, 20:04:39)

  1. Introductions (davidnind, 20:04:49)
    1. Joy Nelson Bywater Solutions (tallerjoy, 20:04:58)
    2. David Nind, Wellington, New Zealand (davidnind, 20:05:11)
    3. Lucas Gass ByWater Solutions (lukeG1, 20:05:25)
    4. Tomas Cohen Arazi, Theke Solutions (tcohen, 20:05:39)
    5. Brendan Gallagher ByWater (bag, 20:06:31)
    6. Nick Clemens ByWater (kidclamp, 20:06:58)
    7. tuxayo/Victor Grousset, France (tuxayo, 20:07:13)

  2. Announcements (davidnind, 20:08:02)
    1. Please help testing BugĀ 20271 - Merge deleted biblio, biblioitems, biblio_metadata, and items tables! (also see Call for Testing on koha-devel) (cait, 20:10:04)
    2. Update on Kohacon20 https://www.catalyst.net.nz/blog/keeping-kohacon20-%E2%80%93-episode-1 (davidnind, 20:10:32)

  3. Update from the Release manager (20.11) (davidnind, 20:10:56)
    1. https://lists.koha-community.org/pipermail/koha-devel/2020-June/045810.html (tuxayo, 20:11:36)

  4. Updates from the Release Maintainers (davidnind, 20:11:50)
    1. Martin Renvoize, PTFS-E (ashimema, 20:12:33)
    2. Congratulations to the release maintainers aleisha and tuxayo for their first releases (davidnind, 20:13:38)

  5. Updates from the QA team (davidnind, 20:15:35)
    1. QA team is bigger, list is too! :) (cait, 20:16:14)

  6. Actions from last meeting (davidnind, 20:19:16)
    1. testing day turned into a 2 week thing, maybe will try a different approach next time :) (cait, 20:21:05)
    2. ACTION: tuxayo - write a proposal for handing over stable branches (davidnind, 20:22:40)
    3. ACTION: ashimema - open a bug report to introduce the idea of having a "skeleton" template we could copy for new pages (davidnind, 20:23:18)
    4. ACTION: ashimema - to draft the first 'Accessibility' guideline; All OPAC pages require a single 'maincontent' classed block. (davidnind, 20:23:52)
    5. ACTION: ashimema - write a guideline about mandatory 'maincontent' class (OPAC) (davidnind, 20:24:11)
    6. "skeleton" template we could copy for new pages - deferred until Boostrap update merged (davidnind, 20:26:34)
    7. https://wiki.koha-community.org/wiki/Terminology (tallerjoy, 20:28:54)
    8. Terminology list updated for more inclusive language for https://wiki.koha-community.org/wiki/Terminology (davidnind, 20:29:14)
    9. https://wiki.koha-community.org/wiki/Coding_Guidelines#TERM1:_The_agreed_set_of_library_terms_must_be_used (tuxayo, 20:29:17)
    10. ACTION: tallerjoy - Draft TERM3 for for inclusive language (davidnind, 20:33:43)

  7. General development discussion (trends, ideas, ...) (davidnind, 20:37:18)
    1. start removing 'indirect object notation' calls - bug 25898 and add as a coding guideline (davidnind, 20:42:30)
    2. ACTION: ashimema - add a draft coding guideline for direct notation rather than indirect object notation calls (davidnind, 20:44:06)
    3. Thomas Dukleth, Agogme, New York City (thd, 20:44:41)
    4. https://wiki.koha-community.org/wiki/Development_IRC_meeting_1_July_2020 (tuxayo, 20:48:36)
    5. https://wiki.koha-community.org/wiki/Coding_Guidelines#SQL11:_All_fields_added_to_the_database_must_be_documented_in_kohastructure.sql (cait, 20:51:17)
    6. https://gitlab.com/koha-community/Koha/-/blob/master/installer/data/mysql/kohastructure.sql (tuxayo, 20:52:07)
    7. https://gitlab.com/koha-community/Koha/-/blob/master/installer/data/mysql/kohastructure.sql (tuxayo, 20:53:56)
    8. http://schema.koha-community.org/master/tables/collections_tracking.html (cait, 20:56:26)
    9. http://schema.koha-community.org/master/tables/search_field.html (tuxayo, 20:57:25)
    10. ACTION: tuxayo - prepare draft update to SQL11 to improve consistency for descriptions in kohastructure files (davidnind, 21:02:32)
    11. https://koha-community.org/download-koha/ (cait, 21:08:09)
    12. Minimum recommended Perl version is 5.14 (until need to use a more recent version is identified) (davidnind, 21:08:22)
    13. ACTION: ashimema to update requirements on website (cait, 21:09:02)
    14. https://koha-community.org/manual/20.05/en/html/intro.html#koha-recommendations (cait, 21:11:40)
    15. ACTION: cait to propose discussion about supported browsers at next meeting (IE especially) (cait, 21:12:18)
    16. davidnind Find and update relevant places to record Perl version required, including manual and wiki (one source of the truth) (davidnind, 21:12:41)
    17. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (davidnind, 21:13:27)

  8. Set time of next meeting (davidnind, 21:13:49)
    1. davidnind has been an excellent chairperson, thankyou (ashimema, 21:15:47)
    2. Next meeting: 15 July 2020, 14:00 UTC (davidnind, 21:16:26)


Meeting ended at 21:16:31 UTC (full logs).

Action items

  1. tuxayo - write a proposal for handing over stable branches
  2. ashimema - open a bug report to introduce the idea of having a "skeleton" template we could copy for new pages
  3. ashimema - to draft the first 'Accessibility' guideline; All OPAC pages require a single 'maincontent' classed block.
  4. ashimema - write a guideline about mandatory 'maincontent' class (OPAC)
  5. tallerjoy - Draft TERM3 for for inclusive language
  6. ashimema - add a draft coding guideline for direct notation rather than indirect object notation calls
  7. tuxayo - prepare draft update to SQL11 to improve consistency for descriptions in kohastructure files
  8. ashimema to update requirements on website
  9. cait to propose discussion about supported browsers at next meeting (IE especially)
  10. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth)


Action items, by person

  1. ashimema
    1. ashimema - open a bug report to introduce the idea of having a "skeleton" template we could copy for new pages
    2. ashimema - to draft the first 'Accessibility' guideline; All OPAC pages require a single 'maincontent' classed block.
    3. ashimema - write a guideline about mandatory 'maincontent' class (OPAC)
    4. ashimema - add a draft coding guideline for direct notation rather than indirect object notation calls
    5. ashimema to update requirements on website
  2. cait
    1. cait to propose discussion about supported browsers at next meeting (IE especially)
  3. davidnind
    1. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth)
  4. tallerjoy
    1. tallerjoy - Draft TERM3 for for inclusive language
  5. tuxayo
    1. tuxayo - write a proposal for handing over stable branches
    2. tuxayo - prepare draft update to SQL11 to improve consistency for descriptions in kohastructure files


People present (lines said)

  1. cait (83)
  2. davidnind (72)
  3. tuxayo (65)
  4. ashimema (57)
  5. tallerjoy (19)
  6. tcohen (10)
  7. huginn (6)
  8. wahanui (5)
  9. koha-jenkins (5)
  10. thd (3)
  11. bag (2)
  12. kidclamp (2)
  13. lukeG1 (2)


Generated by MeetBot 0.1.4.