#koha: Development IRC meeting 3 June 2020

Meeting started by ashimema at 20:04:36 UTC (full logs).

Meeting summary

    1. Katrin Fischer, BSZ, Germany (cait, 20:04:39)
    2. Tomas Cohen Arazi, Theke Solutions (tcohen, 20:04:57)
    3. Magnus Enger, Libriotech, Norway (magnuse, 20:04:57)
    4. Mengü Yazıcıoğlu, Devinim, Turkey (enkidu, 20:04:58)
    5. https://wiki.koha-community.org/wiki/Development_IRC_meeting_3_June_2020 Agenda (ashimema, 20:05:09)

  1. Introductions (ashimema, 20:05:14)
    1. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 20:05:19)
    2. David Nind, Wellington, New Zealand (davidnind, 20:05:25)
    3. Chris Cormack, Catalyst iT (rangi, 20:05:27)
    4. Martin Renvoize, PTFS-Europe, UK (ashimema, 20:05:36)
    5. tuxayo/Victor Grousset, France (tuxayo, 20:05:40)
    6. Liz Rea (wizzyrea, 20:05:43)

  2. Announcements (ashimema, 20:07:07)
    1. The 20.05 release happened, just in time to get into May.. delays were caused by some hurdles to get over with packaging. (ashimema, 20:07:43)
    2. Packages should be available very soon, transfering them from the staging repository to live is in progress. (ashimema, 20:08:25)
    3. koha-gitify has been forked into the koha-community gitlab organisation (ashimema, 20:10:33)
    4. koha-testing-docker now utilises the community maintained version hosted on gitlab (ashimema, 20:11:09)
    5. https://github.com/chrisosaurus/koha-gitify (tcohen, 20:13:24)
    6. Many thanks should be passed to the original maintainers of koha-gitify and their diligent eforts keeping it up to date when pull requests were submitted :) (ashimema, 20:13:42)

  3. Update from the Release manager (ashimema, 20:18:51)
    1. Joubu brewed 20L of IPA, don't count on him for the rest of the week (tcohen, 20:19:17)
    2. Jonthan is missing this evening, but expressed he has great trust in the team around him (ashimema, 20:19:59)

  4. Updates from the Release Maintainers (ashimema, 20:21:48)
    1. tuxayo (for 19.05) is learning the RMaint workflow and how to interpret CI results (tuxayo, 20:24:43)
    2. rmaints are all setup and ready to go.. handover complete :) (ashimema, 20:25:55)

  5. Updates from the QA team (ashimema, 20:26:24)
    1. QA ALL THE THINGS :) (ashimema, 20:28:20)
    2. bugs are priority for the first month, but there's also a few 20_11_target bugs in the queue I believe which didn't make it end of last cycle and would be nice to do early this cycle. (ashimema, 20:29:14)
    3. We need to get the test suits passing again... (ashimema, 20:29:46)

  6. General development discussion (trends, ideas, ...) (ashimema, 20:31:05)
    1. Test suite, proper environment to test stable branches (ashimema, 20:31:28)
    2. https://github.com/perl5-dbi/DBD-mysql/issues/212 (tcohen, 20:42:46)
    3. rmaints contact tcohen about jenkins and environments their branches should be tested against (tcohen, 20:47:10)
    4. Can we/Should we deprecate MySQL 5.5 support? (ashimema, 20:49:42)
    5. https://wiki.debian.org/DebianReleases (tcohen, 20:52:23)
    6. VOTE: Voted on "Should we officially deprecate MySQL5.5 support (upping minimum SQL versions to MariaDB 10.1/MySQL 5.7?" Results are, Yes: 6 (ashimema, 21:04:59)
    7. Joubu volunteers to announce MySQL 5.5 deprecation (tcohen, 21:06:40)
    8. ACTION: davidnind will update the manual with new minimum requirements updates (ashimema, 21:07:45)

  7. Review of coding guidelines (ashimema, 21:07:56)
  8. Set time of next meeting (ashimema, 21:08:25)
    1. Next meeting: 17 June 2020, 13 UTC (ashimema, 21:21:16)


Meeting ended at 21:21:18 UTC (full logs).

Action items

  1. davidnind will update the manual with new minimum requirements updates


Action items, by person

  1. davidnind
    1. davidnind will update the manual with new minimum requirements updates


People present (lines said)

  1. ashimema (143)
  2. tcohen (107)
  3. tuxayo (77)
  4. cait (20)
  5. enkidu (16)
  6. wizzyrea (15)
  7. magnuse (11)
  8. huginn (11)
  9. wahanui (9)
  10. rangi (8)
  11. oleonard (4)
  12. davidnind (3)


Generated by MeetBot 0.1.4.