#koha: Development IRC meeting 5 February 2020

Meeting started by ashimema at 20:00:28 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_5_February_2020#Agenda Agenda (ashimema, 20:00:38)

  1. Introductions (ashimema, 20:00:59)
    1. Martin Renvoize, PTFS Europe, UK (ashimema, 20:01:14)
    2. Jesse Maseto, BWS, USA (JesseM, 20:01:29)
    3. David Nind, New Zealand (davidnind, 20:01:51)
    4. Lisette Scheer, Latah County Library District, USA (lisettelatah, 20:01:55)
    5. Josef Moravec (josef_moravec, 20:02:06)
    6. Liz Rea (wizzyrea, 20:02:19)
    7. Kyle M Hall, ByWater Solutions (khall, 20:02:21)

  2. Announcements (ashimema, 20:02:44)
    1. GBSD 14th February, Valentine's Edition (ashimema, 20:03:07)
    2. https://wiki.koha-community.org/wiki/2020-02-14_Global_bug_squashing_day GBSD Details (ashimema, 20:03:45)
    3. ByWater Solutions will be hosting a YouTube Live Session on Friday 14th from 11am EST to 1pm EST in support of GBSD (ashimema, 20:05:56)
    4. https://www.youtube.com/user/bywatersolutions/live Join in (ashimema, 20:06:16)
    5. brendan bywater (bag, 20:06:28)

  3. Update from the Release Team (ashimema, 20:07:31)
    1. Release is moving along nicely, lots of bugfixes and enhancements getting pushed.. Thanks everyone for the consistent level of SO and QA. (ashimema, 20:08:05)
    2. Bug 18936 - Circulation Rules Ratification has been pushed, thanks to all involved, and sorry for the rebases it may have created for people.. its a big step in the right direction for koha's codebase modernisation and maintainability wise. (ashimema, 20:09:38)

  4. General development discussion (trends, ideas, ...) (ashimema, 20:10:14)
    1. Deprecate/remove QueryParser (see Bug 12742) (ashimema, 20:10:41)
    2. https://hea.koha-community.org/systempreferences HEA stats (ashimema, 20:14:20)
    3. ACTION: Add vote for QueryParser removal to next meeting agenda (ashimema, 20:18:19)

  5. Review of coding guidelines (ashimema, 20:18:47)
    1. Vote for SWAGGER1.3.4: mapping (ashimema, 20:19:09)
    2. https://wiki.koha-community.org/wiki/Coding_Guidelines_-_API#SWAGGER1.3.4: mapping-_DRAFT Guideline (ashimema, 20:19:47)
    3. VOTE: Voted on "Do you agree with adding the proposed new coding guideline as phrased (First 2 points only)?" Results are, Yes: 6 (ashimema, 20:28:20)

  6. Set date and time for next meeting (ashimema, 20:29:30)
    1. Next meeting: 19 February 2020, 14 UTC (ashimema, 20:31:23)


Meeting ended at 20:31:26 UTC (full logs).

Action items

  1. Add vote for QueryParser removal to next meeting agenda


People present (lines said)

  1. ashimema (60)
  2. huginn (9)
  3. JesseM (6)
  4. josef_moravec (6)
  5. wizzyrea (4)
  6. davidnind (2)
  7. lisettelatah (2)
  8. khall (2)
  9. bag (1)


Generated by MeetBot 0.1.4.