#koha: solr meeting

Meeting started by hdl at 10:00:17 UTC (full logs).

Meeting summary

  1. Why taking on solr (hdl, 10:04:36)
    1. http://librarypolice.com/koha-meetings/2010/koha.2010-12-07-20.00.log.html (clrh, 10:06:46)
    2. http://wiki.koha-community.org/wiki/Switch_to_Solr_RFC (clrh, 10:07:20)
    3. http://www.biblibre.com/en/blog/entry/solr-developments-for-koha (clrh, 10:07:45)

  2. what is done (hdl, 10:08:08)
    1. https://github.com/eiro/rg-z3950-rpn/ wip about rpn grammar and z3950 server development (clrh, 10:11:33)
    2. HELP: on building Data::SearchEngine::ZOOM and Data::SearchEngine::Query::PQF via ZOOM wrappers (hdl, 10:11:59)
    3. ACTION: Z3950 support on top of solr (hdl, 10:21:33)
    4. ACTION: improving the indexing time. (hdl, 10:22:06)
    5. http://www.indexdata.com/yaz/doc/tools.html (clrh, 10:22:59)
    6. http://lucene.472066.n3.nabble.com/Getting-started-with-DIH-td504691.html (clrh, 10:23:41)
    7. http://www.nntp.perl.org/group/perl.perl4lib/2010/12/msg2836.html about another idea for improving => multi-threaded call (clrh, 10:25:31)
    8. ACTION: work in pairs with CILEA for zebra as an option implementation (hdl, 10:51:06)
    9. HELP: new ideas for plugins to add so that the indexing could be better. (hdl, 10:53:13)
    10. https://spreadsheets.google.com/pub?key=0AuZF5Y_c4pIxdEVzTjUtUGFoQnFpSkpfbTU5Ykc3b2c&hl=en&output=html (clrh, 11:00:46)
    11. HELP: please try and contribute yours (hdl, 11:01:11)
    12. ACTION: josepedro send a mail with code reviews. (hdl, 11:06:18)
    13. ACTION: provide a comparison of RAM requirements between zebra and solr (hdl, 11:10:43)
    14. ACTION: irmaB build an adaptation of MARC21 for solr (hdl, 11:13:53)
    15. ACTION: BibLibre make a solr instance for MARC21 and publicise that to Irma (hdl, 11:14:23)


Meeting ended at 11:28:19 UTC (full logs).

Action items

  1. Z3950 support on top of solr
  2. improving the indexing time.
  3. work in pairs with CILEA for zebra as an option implementation
  4. josepedro send a mail with code reviews.
  5. provide a comparison of RAM requirements between zebra and solr
  6. irmaB build an adaptation of MARC21 for solr
  7. BibLibre make a solr instance for MARC21 and publicise that to Irma


Action items, by person

  1. irmaB
    1. irmaB build an adaptation of MARC21 for solr
  2. josepedro
    1. josepedro send a mail with code reviews.
  3. UNASSIGNED
    1. Z3950 support on top of solr
    2. improving the indexing time.
    3. work in pairs with CILEA for zebra as an option implementation
    4. provide a comparison of RAM requirements between zebra and solr
    5. BibLibre make a solr instance for MARC21 and publicise that to Irma


People present (lines said)

  1. hdl (149)
  2. tajoli (49)
  3. thd (44)
  4. josepedro (17)
  5. clrh (16)
  6. slef (15)
  7. magnus (14)
  8. reed (11)
  9. irmaB (10)
  10. munin (3)
  11. ibot (3)
  12. miguelxer (2)
  13. fredericd (2)
  14. Joubu (1)


Generated by MeetBot 0.1.4.