#koha Meeting

Meeting started by rangi at 02:00:25 UTC (full logs).

Meeting summary

  1. Introductions (rangi, 02:00:34)
    1. wahanui, a bot that has become sentient (wahanui, 02:00:35)
    2. Owen Leonard, Athens County Public Libraries (oleonard, 02:00:44)
    3. Elliott Davis, ByWater Solutions (libsysguy, 02:00:48)
    4. Chris Cormack, Catalyst IT, Rmaint 3.8.x and 3.10.x (rangi, 02:00:55)
    5. Bob Birchall, Calyx information essentials (BobB, 02:01:10)
    6. Chris Hall, Catalyst IT (cjh, 02:01:11)
    7. NancyK Reno (nancyk, 02:01:11)
    8. rhcl = Greg - Rolling Hills Consolidated Library (rhcl, 02:01:12)
    9. Jane Wagner, LibLime/PTFS (jwagner, 02:01:14)
    10. Jared Camins-Esakov, C & P Bibliography Services, Release Manager for 3.12 and RMaint emeritus for 3.6.x (jcamins, 02:01:19)
    11. Robin Sheat, Catalyst IT (eythian, 02:01:24)
    12. Clint Deckard, Anact (clintD, 02:01:30)
    13. Mason James, NZ (mtj, 02:02:17)

  2. Announcements (rangi, 02:03:04)
    1. Kathryn Tyree, Catalyst IT NZ (kathryn, 02:03:07)
    2. Liz Rea (wizzyrea, 02:03:25)
    3. ACTION: libsysguy to publish repo of his mechanized testing suite (rangi, 02:04:48)
    4. We now have a repository for a version of git-bz customized for Koha at http://git.koha-community.org/gitweb/?p=git-bz.git;a=summary (jcamins, 02:05:11)
    5. i've just eaten waaay too many samosas :/ (mtj, 02:05:16)

  3. update on 3.8 (rangi, 02:05:46)
  4. update on 3.10 (rangi, 02:07:19)
    1. http://koha-community.org/koha-release-manager-newsletter-11-12-2012-10/ (rangi, 02:08:12)
    2. ACTION: everyone test bug fixes (rangi, 02:11:23)

  5. 3.12 (rangi, 02:11:29)
    1. ACTION: Test and sign off on the bugfixes that are already in Bugzilla, and test 3.10.x/master and fix any bugs you find. (jcamins, 02:11:31)
    2. only qa team should mark patches passed qa, unless there are some crazy circumstances like security and everyone is on holiday in tahiti or something (rangi, 02:16:05)
    3. ACTION: Find out if we can set Bugzilla permissions so that only the QA team can mark things "Passed QA" (jcamins, 02:16:17)
    4. During the 3.12 release cycle, the RM will assign the QAM as QA contact to bugs where he is concerned about a conflict of interest, and the QAM can delegate as appropriate. (jcamins, 02:20:47)
    5. The RM will prepare a "roadmap" for 3.12 after 3.10.0 is released, but since the focus is on "stability," don't expect a detailed plan for exactly what we're going to be working on at any given point. (jcamins, 02:21:55)

  6. kohacon13 (rangi, 02:22:23)
    1. kohacon13 dates are looking like mid october (rangi, 02:24:12)
    2. http://wiki.koha-community.org/wiki/KohaCon13_Summary (rangi, 02:25:17)
    3. http://koha-community.org/kohacon/kohacon13-2/ (rangi, 02:25:37)
    4. Thomas Dukleth, Agogme , New York City, survived the blackout and heatout (thd, 02:25:41)

  7. actions from the last meeting (rangi, 02:27:10)
  8. Miscellaneous (rangi, 02:27:55)
    1. http://wiki.koha-community.org/wiki/2012-09-14_Global_bug_squashing_day Next date? (Irma, 02:29:07)
    2. IDEA: bug squashing day on the 9th of november (rangi, 02:32:22)
    3. ACTION: jcamins will mark candidates for 3.10 that are in "Needs signoff" assuming he has power this week. (jcamins, 02:40:26)
    4. AGREED: Global bug squashing weekend starting november 9th (rangi, 02:44:09)
    5. http://wiki.koha-community.org/wiki/RDA (rangi, 02:46:49)

  9. date for next meeting (rangi, 02:49:59)
    1. AGREED: Next meeting is Decmber 5 18:00 UTC (rangi, 02:53:08)


Meeting ended at 02:53:43 UTC (full logs).

Action items

  1. libsysguy to publish repo of his mechanized testing suite
  2. everyone test bug fixes
  3. Test and sign off on the bugfixes that are already in Bugzilla, and test 3.10.x/master and fix any bugs you find.
  4. Find out if we can set Bugzilla permissions so that only the QA team can mark things "Passed QA"
  5. jcamins will mark candidates for 3.10 that are in "Needs signoff" assuming he has power this week.


Action items, by person

  1. jcamins
    1. jcamins will mark candidates for 3.10 that are in "Needs signoff" assuming he has power this week.
  2. libsysguy
    1. libsysguy to publish repo of his mechanized testing suite
  3. UNASSIGNED
    1. everyone test bug fixes
    2. Test and sign off on the bugfixes that are already in Bugzilla, and test 3.10.x/master and fix any bugs you find.
    3. Find out if we can set Bugzilla permissions so that only the QA team can mark things "Passed QA"


People present (lines said)

  1. rangi (114)
  2. jcamins (61)
  3. wizzyrea (31)
  4. Irma (18)
  5. libsysguy (18)
  6. oleonard (14)
  7. mtj (14)
  8. cjh (12)
  9. BobB (11)
  10. thd (10)
  11. nancyk (9)
  12. davidnind (5)
  13. eythian (5)
  14. kathryn (3)
  15. rhcl (3)
  16. JDatTeTakere (3)
  17. wahanui (3)
  18. huginn (2)
  19. jwagner (2)
  20. stefan-l (2)
  21. clintD (1)
  22. tweetbot` (1)


Generated by MeetBot 0.1.4.