#koha: Dev IRC Meeting, part 1

Meeting started by cait at 15:03:12 UTC (full logs).

Meeting summary

    1. Zeno Tajoli, CINECA (tajoli, 15:03:13)

  1. Introductions (cait, 15:03:25)
    1. wahanui, a bot that has become sentient (wahanui, 15:03:26)
    2. Marcel (marcelr, 15:03:26)
    3. Jesse Maseto - ByWater (JesseM, 15:03:36)
    4. Tomas Cohen Arazi, Universidad Nacional de Cordoba (tcohen, 15:03:39)
    5. Joy Nelson - ByWater Solutions (talljoy, 15:03:47)
    6. Katrin Fischer, BSZ Germany (cait, 15:03:50)
    7. Martin Renvoize, PTFS Europe (ashimema, 15:03:55)
    8. Thomas Dukleth, Agogme, New York City (thd, 15:04:03)
    9. Zeno Tajoli, CINECA (Italy) (tajoli, 15:04:08)
    10. Bernardo Gonzalez Kriegel, UNCordoba (bgkriegel, 15:04:15)
    11. Owen Leonard, Athens County Public Libraries (oleonard, 15:05:12)

  2. Elections - Release Team 3.18 (cait, 15:05:36)
    1. http://wiki.koha-community.org/wiki/Roles_for_3.18 (cait, 15:05:50)
    2. Nicole Engard, ByWater Solutions (nengard, 15:07:33)
    3. Barton Chittenden, Bywater Solutions, Louisville KY, USA (barton, 15:07:42)
    4. Jane Wagner, LibLime/PTFS (jwagner, 15:08:15)
    5. Jonathan Druart, BibLibre, France (Joubu, 15:08:24)
    6. http://wiki.koha-community.org/wiki/Development_IRC_meeting,_23_April_2014 (cait, 15:08:27)

  3. Vote on RM (cait, 15:09:36)
    1. Candidate: Tomas Cohen Arazi (cait, 15:09:55)
    2. Rocio Jordan ByWater Solutions (rocio, 15:09:59)
    3. Brendan Gallagher ByWater (bag_confcall, 15:10:47)
    4. AGREED: Release manager for 3.18 is: Tomas Cohen Arazi (tcohen) (cait, 15:10:52)
    5. Mario Guilin ByWater Solutions (mario, 15:10:53)

  4. Vote on Release Maintainers (cait, 15:11:31)
    1. Candidates are: 3.16: Galen Charlton, 3.14 Fridolin Somers, 3.12 Kyle Hall (cait, 15:11:54)
    2. Chris Nighswonger FBC (chris_n, 15:11:56)
    3. AGREED: Release maintainers are Galen Charlton (gmcharlt, 3.14), Fridolin Somers (3.14) and Kyle Hall (khall, 3.12) (cait, 15:13:14)

  5. Vote on Module maintainers (cait, 15:13:30)
    1. Candidates are...on the wiki (cait, 15:13:38)
    2. AGREED: .. and that would be Galen Charlton for 3.16! (cait, 15:14:01)
    3. AGREED: All module maintainers elected (see wiki) (cait, 15:19:43)

  6. Vote on Translation manager (cait, 15:19:55)
    1. candidate is Bernardo Gonzalez Kriegel (cait, 15:20:11)
    2. AGREED: New old translation manager is Bernardo Gonzalez Kriegel (bgkriegel) (cait, 15:21:53)

  7. Documentation manager (cait, 15:21:59)
    1. candidate is Nicole Engard (nengard) (cait, 15:22:15)
    2. AGREED: New Documentation manager - Nicole Engard (nengard) (cait, 15:23:32)

  8. Quality Assurance Manager (cait, 15:23:41)
    1. edveal ByWater (edveal, 15:23:43)
    2. candidate: Katrin Fischer (cait) (cait, 15:24:00)
    3. AGREED: Katrin Fischer will be Quality Assurance Manager (cait, 15:25:57)

  9. Quality Asssurance Team (cait, 15:26:21)
    1. Candidates are: Martin Renvoize, Marcel de Rooy, Brendan Gallagher, Paul Poulain, Julian Maurice, Jonathan Druart, Galen Charlton, Kyle M Hall (cait, 15:27:31)
    2. AGREED: QA team: Martin Renvoize, Marcel de Rooy, Brendan Gallagher, Paul Poulain, Julian Maurice, Jonathan Druart, Galen Charlton, Kyle M Hall (cait, 15:28:46)

  10. Database documentation manager (cait, 15:29:25)
    1. candidate is Zeno Tajoli (cait, 15:29:32)
    2. AGREED: Database documentation manager is Zeno Tajoli (cait, 15:30:37)

  11. Packaging manager (cait, 15:30:43)
    1. candidate is Robin Sheat (eythian) (cait, 15:30:51)
    2. AGREED: Packaging manager is Robin Sheat (cait, 15:31:42)

  12. Bug Wranglers (cait, 15:31:47)
    1. AGREED: Bug wranglers... Zeno Tajoli (cait, 15:33:41)

  13. Discussion: Role of Module Maintainrs (cait, 15:35:35)
    1. http://wiki.koha-community.org/wiki/Talk:What_does_a_module_maintainer_do (cait, 15:36:11)

  14. Discussion: Role of Release maintainers (cait, 15:50:12)
    1. http://lists.koha-community.org/pipermail/koha-devel/2014-April/040420.html (cait, 15:50:44)
    2. http://lists.koha-community.org/pipermail/koha-devel/2014-April/040430.html (ashimema, 16:04:48)

  15. Additions to Coding guidelines (ashimema, 16:06:17)
  16. Big stuff we are working on (ashimema, 16:08:26)
    1. AGREED: Add 'Deprecate C4/Dates.pm to coding guidlines' (ashimema, 16:10:45)

  17. Date of next meeting. (ashimema, 16:13:16)
    1. AGREED: 21st May for next meeting(s) (ashimema, 16:18:59)


Meeting ended at 16:19:45 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. cait (130)
  2. ashimema (100)
  3. tcohen (37)
  4. thd (35)
  5. oleonard (20)
  6. paul_p (17)
  7. tajoli (17)
  8. nengard (16)
  9. talljoy (15)
  10. bag (14)
  11. Joubu (14)
  12. barton (14)
  13. JesseM (13)
  14. marcelr (13)
  15. chris_n (13)
  16. khall (8)
  17. bgkriegel (8)
  18. wahanui (6)
  19. gmcharlt (5)
  20. edveal (5)
  21. rocio (5)
  22. liw (4)
  23. huginn (4)
  24. bag_confcall (2)
  25. mario (2)
  26. pastebot (1)
  27. gaetan_B (1)
  28. jwagner (1)


Generated by MeetBot 0.1.4.