#koha: Development IRC meeting, 11 June 2014, part 2

Meeting started by gmcharlt at 22:01:03 UTC (full logs).

Meeting summary

    1. Agenda is http://wiki.koha-community.org/wiki/Development_IRC_meeting,_11_June_2014 (gmcharlt, 22:01:17)

  1. Introductions (gmcharlt, 22:01:23)
    1. wahanui, a bot that has become sentient (wahanui, 22:01:24)
    2. Galen Charlton, ESI (gmcharlt, 22:01:30)
    3. Robin Sheat, Catalyst IT, NZ (eythian_, 22:01:51)
    4. Katrin Fischer, BSZ (cait, 22:01:52)
    5. Thomas Dukleth, Agogme, New York City (thd, 22:02:21)
    6. Chris Cormack, Catalyst NZ (rangi, 22:03:37)

  2. Deprecate the OPAC prog theme officially (gmcharlt, 22:04:30)
    1. Liz Rea, Catalyst NZ (wizzyrea, 22:04:52)
    2. Current proposal for wording in the coding guidelines: (http://paste.lisp.org/display/142855 (gmcharlt, 22:04:53)
    3. Mark Tompsett (mtompset, 22:08:43)
    4. VOTE: Voted on "Shall the change to the coding guidelines to deprecate OPAC and CCSR be approved (http://paste.lisp.org/display/142855)?" Results are, Yes: 4 (gmcharlt, 22:10:33)
    5. AGREED: the coding guidelines will be updated per http://paste.lisp.org/display/142855 to discourage future patches from updating the prog and CCSR OPAC themes (gmcharlt, 22:10:58)

  3. UTF-8 Clean-up - Bug 11944 (gmcharlt, 22:11:15)
    1. (from part 1) gmcharlt has action items to review patches and redy them for signoff by end of June (gmcharlt, 22:11:43)
    2. also action item to schedule a GBSD dedicated to it in early July (gmcharlt, 22:12:04)
    3. Joubu has action item to look at bug 11811 and look at adjusting on or more sandboxes to use the utf8_unicode_ci collation in their mysql databases (gmcharlt, 22:12:34)

  4. Big stuff we are working on (gmcharlt, 22:17:20)
    1. BibLibre is working on an RFC for revamping how taxes are handled in acquisitions (gmcharlt, 22:17:38)
    2. rangi is working on support for multiple sources of book covers (gmcharlt, 22:20:13)
    3. prog/CCSR deprecation now the HTML5 guideline: http://wiki.koha-community.org/wiki/Coding_Guidelines#HTML5:_Deprecation_of_the_.27prog.27_and_.27CCSR.27_OPAC_themes (gmcharlt, 22:27:03)
    4. http://osswatch.jiscinvolve.org/wp/2014/05/23/vals-semester-of-code-foss-projects-wanted/ (rangi, 22:32:31)
    5. http://paste.koha-community.org/40 (rangi, 22:37:49)
    6. https://linux.conf.au/miniconf-cfp (rangi, 22:38:05)
    7. rangi mentioned the VALS summer of code (http://osswatch.jiscinvolve.org/wp/2014/05/23/vals-semester-of-code-foss-projects-wanted/) as a possible project for Koha to cnosider (gmcharlt, 22:38:16)
    8. rangi is proposing a cultural hertiage and FLOSS miniconference for the lca2015 in Auckland (https://linux.conf.au/) (gmcharlt, 22:39:59)


Meeting ended at 22:43:45 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. gmcharlt (52)
  2. cait (20)
  3. rangi (20)
  4. eythian (18)
  5. pianohacker (16)
  6. huginn (12)
  7. thd (11)
  8. wizzyrea (10)
  9. mtompset (4)
  10. eythian_ (2)
  11. wahanui (1)


Generated by MeetBot 0.1.4.