#koha: Deveopment meeting, 23 July 2014, part 2

Meeting started by gmcharlt at 22:00:43 UTC (full logs).

Meeting summary

    1. Agenda http://wiki.koha-community.org/wiki/Development_IRC_meeting,_23_July_2014 (gmcharlt, 22:00:52)
    2. Part 1 minutes: http://meetings.koha-community.org/2014/koha_irc_developer_meeting__july_23rd__part_1.2014-07-23-15.00.html (gmcharlt, 22:01:15)
    3. Part 1 logs: http://meetings.koha-community.org/2014/koha_irc_developer_meeting__july_23rd__part_1.2014-07-23-15.00.html (gmcharlt, 22:01:26)

  1. Introductions (gmcharlt, 22:01:36)
    1. wahanui, a bot that has become sentient (wahanui, 22:01:36)
    2. Galen Charlton, Equinox (gmcharlt, 22:01:42)
    3. Bernardo Gonzalez Kriegel (bgkriegel, 22:01:52)
    4. Brendan Gallagher, ByWater (bag, 22:02:04)
    5. Tomas Cohen Arazi, Universidad Nacional de Cordoba (tcohen, 22:03:12)

  2. RM 3.18 comments (gmcharlt, 22:05:41)
    1. bug 11586 might serve as input for having better UNIMARC search tests (tcohen, 22:09:58)

  3. Coding guidelines: Move towards deprecating GRS-1 in favor of DOM indexing (gmcharlt, 22:11:26)
    1. The omnibus bug for deprecation of the GRS-1 indexing mode is 12641 (gmcharlt, 22:19:24)
    2. AGREED: Koha adopts a new coding guideline per http://paste.lisp.org/display/14321 to deprecate the GRS-1 indexing mode (gmcharlt, 22:23:53)
    3. The new DEPR2 coding guideilne can be found at The DOM Zebra indexing mode is now the standard supported method for Koha. The GRS-1 indexing mode is deprecated for all record types and MARC flavours. (gmcharlt, 22:26:35)
    4. The new DEPR2 coding guideline can be found at http://wiki.koha-community.org/wiki/Coding_Guidelines#DEPR2:_The_GRS-1_Zebra_indexing_mode_is_deprecated (gmcharlt, 22:26:55)

  4. Coding guidelines - indentation in templates (gmcharlt, 22:27:54)
    1. AGREED: further discussion about new or revised guidelines for whitespace to occur on the mailing list (gmcharlt, 22:31:30)
    2. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12545 (gmcharlt, 22:33:07)

  5. DBIC (gmcharlt, 22:34:04)
    1. http://wiki.koha-community.org/wiki/Examples_of_DBIC_in_Koha (gmcharlt, 22:34:07)

  6. Bugs (gmcharlt, 22:37:36)
    1. UTF-8 cleanup - bug 11944 (gmcharlt, 22:37:46)
    2. Test builder - bug 12603 (gmcharlt, 22:40:52)
    3. renewing lost items - bug 9805 (gmcharlt, 22:42:17)
    4. Input requested for bug 12477 (better management of MARC frameworks) (gmcharlt, 22:47:15)

  7. "Big stuff we are working on" (gmcharlt, 22:49:28)
    1. Feedback on GST RFC requested by end of August http://wiki.koha-community.org/wiki/GST_Rewrite_RFC (gmcharlt, 22:52:19)

  8. Set time of next meeting (gmcharlt, 22:54:33)
    1. AGREED: The next development meeting will be August, 5th, 15:00 + 22:00 UTC (gmcharlt, 22:57:10)


Meeting ended at 22:57:27 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. gmcharlt (82)
  2. tcohen (45)
  3. huginn (12)
  4. bgkriegel (11)
  5. pianohacker (8)
  6. wahanui (5)
  7. eythian (3)
  8. bag (2)
  9. eternalsword (1)


Generated by MeetBot 0.1.4.