#koha: Koha IRC Developer Meeting, July 2nd, part 1

Meeting started by cait at 15:00:47 UTC (full logs).

Meeting summary

  1. Introductions (cait, 15:00:54)
    1. wahanui, a bot that has become sentient (wahanui, 15:00:55)
    2. Katrin Fischer, BSZ, Germany, QAM (cait, 15:01:17)
    3. Owen Leonard, Athens County Public Libraries (oleonard, 15:01:17)
    4. Jonathan Druart, BibLibre (Joubu, 15:01:19)
    5. Yohann Dufour, BibLibre (yohann1, 15:01:20)
    6. Galen Charlton, Equinox (gmcharlt, 15:01:21)
    7. Tomas Cohen Arazi, Universidad Nacional de Córdoba (tcohen, 15:01:32)
    8. Jane Wagner, LibLime/PTFS (jwagner, 15:01:37)
    9. Bernardo Gonzalez Kriegel, Córdoba Argentina (bgkriegel, 15:01:42)
    10. http://wiki.koha-community.org/wiki/Development_IRC_meeting,_2_July_2014 (cait, 15:02:17)

  2. RM 3.18 comments (cait, 15:02:48)
    1. Jenkins tasks have been changed/updated (cait, 15:04:35)
    2. Jesse Maseto, ByWater (JesseM, 15:05:04)
    3. barton, bywater (barton, 15:06:27)
    4. Christopher - about to implement koha (newbie, 15:07:25)
    5. Kyle M Hall, ByWater Solutions (khall, 15:08:31)
    6. Koha Community org on Trello can be found at https://trello.com/kohadevel (gmcharlt, 15:08:54)
    7. Let tcohen know if you want to take a look at the Trello board for Koha Release Management (cait, 15:09:11)

  3. Additions to coding guidelines (cait, 15:11:53)
    1. http://lists.koha-community.org/pipermail/koha-devel/2014-April/040456.html (cait, 15:12:07)
    2. IDEA: add a deprecation warning - non-XSLT officially no longer maintained, new features will only be added to XSLT (cait, 15:18:03)
    3. ACTION: identify XSLT-only features and file bugs for those (cait, 15:19:07)
    4. AGREED: add a deprecation warning to coding guidelines (cait, 15:20:34)
    5. suggested coding guideline http://paste.lisp.org/display/143068 (cait, 15:23:00)

  4. Bugs (cait, 15:23:53)
    1. AGREED: C4/Maintanance will be removed (bug 12456) (cait, 15:26:35)
    2. ACTION: tcohen will ask on the mailing list if someone still uses misc/cronjobs/rss/rss.pl (bug 9000) (cait, 15:29:33)
    3. ACTION: gmcharlt to call a date in July for a GBSD focused on UTF-8 clean-up (bug 11944) (cait, 15:32:10)
    4. gmcharlt is also currently reviewing the feature and remaining issues (cait, 15:32:35)
    5. ACTION: cait to put UTF-8 GBSD on next weeks meeting agenda (cait, 15:35:23)
    6. Removal of prog/CCSR themes (bug 11346) - looking for volunteers (cait, 15:37:30)
    7. ACTION: oleonard is going to send patches for removing the deprecated prog/CCSR themes (cait, 15:38:58)
    8. some patches for removing SQLHelper from the code base are ready for testing/feedback, see http://lists.koha-community.org/pipermail/koha-devel/2014-June/040594.html (cait, 15:44:22)
    9. ACTION: khall to give yohann feedback on his patches (cait, 15:47:57)
    10. ACTION: all comment on bug 12477 with ideas about improving our MARC framework management (cait, 15:54:48)

  5. Testig of APIs, CAS... (cait, 15:55:23)
    1. ACTION: all if you can, test LDAP, SIP and CAS patches or give them a second sign off! :) (cait, 15:58:22)

  6. Big stuff we are working on (cait, 15:59:46)
    1. tcohen working on TemaTres integration soon (cait, 16:01:35)
    2. Joubu still waiting for a signoff on batch modification records - bug 11395 (cait, 16:02:05)
    3. http://www.vocabularyserver.com/ (cait, 16:04:38)

  7. Set date of next meeting (cait, 16:07:35)
    1. AGREED: next meeting, pending confirmation from second meeting today, will be 23rd July, 15 + 22 UTC (cait, 16:08:35)


Meeting ended at 16:09:25 UTC (full logs).

Action items

  1. identify XSLT-only features and file bugs for those
  2. tcohen will ask on the mailing list if someone still uses misc/cronjobs/rss/rss.pl (bug 9000)
  3. gmcharlt to call a date in July for a GBSD focused on UTF-8 clean-up (bug 11944)
  4. cait to put UTF-8 GBSD on next weeks meeting agenda
  5. oleonard is going to send patches for removing the deprecated prog/CCSR themes
  6. khall to give yohann feedback on his patches
  7. all comment on bug 12477 with ideas about improving our MARC framework management
  8. all if you can, test LDAP, SIP and CAS patches or give them a second sign off! :)


Action items, by person

  1. cait
    1. cait to put UTF-8 GBSD on next weeks meeting agenda
  2. gmcharlt
    1. gmcharlt to call a date in July for a GBSD focused on UTF-8 clean-up (bug 11944)
  3. khall
    1. khall to give yohann feedback on his patches
  4. oleonard
    1. oleonard is going to send patches for removing the deprecated prog/CCSR themes
  5. tcohen
    1. tcohen will ask on the mailing list if someone still uses misc/cronjobs/rss/rss.pl (bug 9000)
  6. UNASSIGNED
    1. identify XSLT-only features and file bugs for those
    2. all comment on bug 12477 with ideas about improving our MARC framework management
    3. all if you can, test LDAP, SIP and CAS patches or give them a second sign off! :)


People present (lines said)

  1. cait (140)
  2. tcohen (87)
  3. gmcharlt (42)
  4. ashimema (18)
  5. khall (16)
  6. huginn (13)
  7. Joubu (12)
  8. oleonard (12)
  9. bgkriegel (10)
  10. ztajoli (9)
  11. wahanui (6)
  12. yohann1 (3)
  13. barton (2)
  14. gaetan_B (1)
  15. JesseM (1)
  16. fridolin2 (1)
  17. reiveune (1)
  18. newbie (1)
  19. jwagner (1)


Generated by MeetBot 0.1.4.