#koha: Development IRC meeting 14 October 2015 - part 1

Meeting started by tcohen at 14:08:29 UTC (full logs).

Meeting summary

  1. Introductions (tcohen, 14:08:39)
    1. wahanui, a bot that has become sentient (wahanui, 14:08:40)
    2. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:08:45)
    3. Nicole C Engard, ByWater Solutions (nengard, 14:08:49)
    4. Julian Maurice, BibLibre (jajm, 14:09:03)
    5. Colin Campbell PTFS-Europe (ColinC, 14:09:08)
    6. Kyle Hall, ByWater Solutions (khall, 14:09:15)
    7. Andreas Hedström Mace, Stockholm University Library (andreashm, 14:09:23)
    8. Barton Chittenden, ByWater Solutions (barton, 14:09:28)
    9. Brendan Gallagher ByWater (brendan-bag, 14:10:46)
    10. Katrin Fischer, BSZ (cait, 14:10:59)

  2. RM 3.22 comments (tcohen, 14:11:50)
    1. Jonathan Druart (Joubu, 14:12:25)
    2. Marcel de Rooy (marcelr, 14:18:26)
    3. tcohen asks patch authors to take care of things being broken on jenkins, might be your fault! (tcohen, 14:20:22)
    4. http://wiki.koha-community.org/wiki/Development_IRC_meeting_14_October_2015 (cait, 14:21:36)
    5. bug 15005 is really tricky to solve, with possible integration issues, and requires expert eyes (tcohen, 14:23:17)
    6. ACTION: tcohen volunteers to help people set a suitable test environment for anywant willing to spend a couple minutes testing plack (tcohen, 14:24:51)
    7. ByWater has provided a VM with external access, in which we will set a Koha+plack install so we can do stress tests on it (tcohen, 14:25:45)
    8. ACTION: tcohen will send an email to the devel list with data about the koha-common+plack server (tcohen, 14:27:04)
    9. Martin Renvoize - PTFS Europe (ashimema, 14:32:46)
    10. feature slush is October 26th (tcohen, 14:50:26)

  3. RESTful API Implementation (tcohen, 14:53:13)
    1. Jonathan worked on his own REST implementation test-drive on bug 14974, please, Mojo/Swagger/REST experts take a look and provide feedback (tcohen, 15:00:20)
    2. ACTION: Kyle volunteers to start a wiki page for the REST guidelines (tcohen, 15:06:10)
    3. ACTION: Martin volunteers to polish some Controller / Swagger guidelines for the REST implementation (tcohen, 15:06:10)
    4. ACTION: pianohacker volunteers to take a look and comment on 14974 (tcohen, 15:08:49)

  4. 'Big stuff we are working on' (tcohen, 15:17:26)
  5. Specific bugs that need feedback (tcohen, 15:20:34)
    1. please take a look at tests failing on jenkins, specially if your patches might be guilty (tcohen, 15:21:14)
    2. 14778 is very important and needs urgent feedback (tcohen, 15:33:13)

  6. Set time of next meeting (tcohen, 15:35:51)
    1. there will be at least one more dev meeting, tcohen might call for a topic-specific dev meeting if there is something urgent that needs feedback (tcohen, 15:36:30)
    2. please communicate fluently regarding bugs and things that might hit the next release (tcohen, 15:36:57)


Meeting ended at 15:38:05 UTC (full logs).

Action items

  1. tcohen volunteers to help people set a suitable test environment for anywant willing to spend a couple minutes testing plack
  2. tcohen will send an email to the devel list with data about the koha-common+plack server
  3. Kyle volunteers to start a wiki page for the REST guidelines
  4. Martin volunteers to polish some Controller / Swagger guidelines for the REST implementation
  5. pianohacker volunteers to take a look and comment on 14974


Action items, by person

  1. pianohacker
    1. pianohacker volunteers to take a look and comment on 14974
  2. tcohen
    1. tcohen volunteers to help people set a suitable test environment for anywant willing to spend a couple minutes testing plack
    2. tcohen will send an email to the devel list with data about the koha-common+plack server
  3. UNASSIGNED
    1. Kyle volunteers to start a wiki page for the REST guidelines
    2. Martin volunteers to polish some Controller / Swagger guidelines for the REST implementation


People present (lines said)

  1. tcohen (145)
  2. Joubu (49)
  3. ashimema (48)
  4. pianohacker (20)
  5. khall (13)
  6. bag (13)
  7. huginn (13)
  8. nengard (9)
  9. marcelr (7)
  10. cait (5)
  11. wahanui (5)
  12. brendan-bag (4)
  13. barton (3)
  14. andreashm (2)
  15. John (2)
  16. ColinC (1)
  17. reiveune (1)
  18. jajm (1)
  19. Brooke (1)


Generated by MeetBot 0.1.4.