#koha: Development IRC meeting 24 June 2015

Meeting started by cait at 15:04:31 UTC (full logs).

Meeting summary

  1. Introductions (cait, 15:04:36)
    1. wahanui, a bot that has become sentient (wahanui, 15:04:37)
    2. Martin Renvoize, PTFS-Europe (ashimema, 15:04:38)
    3. Mirko Tietgen, Berlin, Germany (drojf, 15:04:46)
    4. Tomás Cohen Arazi (tcohen, 15:04:47)
    5. Katrin Fischer, BSZ, Germany (cait, 15:04:56)
    6. Bernardo Gonzalez Kriegel (bgkriegel, 15:04:57)
    7. Julian Maurice (jajm, 15:04:58)
    8. Nicole Engard, ByWater (nengard, 15:05:06)
    9. Jonathan Druart (Joubu, 15:05:13)
    10. Alex Arnaud, Biblibre (alex_a, 15:05:15)
    11. http://wiki.koha-community.org/wiki/Development_IRC_meeting_24_June_2015 (cait, 15:05:37)
    12. Kyle M Hall, ByWater Solutions (khall, 15:05:51)
    13. Olli-Antti Kivilahti, Vaara-kirjastot (kivilahtio_, 15:06:30)

  2. RM 3.22 comments (cait, 15:07:07)
    1. Carmen Hernandez, Bywater Solutions (carmen, 15:07:22)
    2. the RM considers 'normal' for patches on the PQA list to stay there for more than 2 weeks, if you think something needs to be pushed faster, please contact the RM personally (tcohen, 15:11:47)

  3. RESTful API implementation (cait, 15:15:27)
    1. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13799 (cait, 15:15:38)
    2. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13920 (cait, 15:15:56)
    3. http://wiki.koha-community.org/wiki/New_REST_API_RFC (cait, 15:16:30)
    4. 2 packages are needed: mojolicious and swagger2 (cait, 15:32:51)
    5. Question: should we include the client side of swagger in Koha (for now) (cait, 15:35:27)
    6. IDEA: only keep the spec file in Koha so it can be used with different tools (cait, 15:35:41)
    7. client side = Swagger Ui (cait, 15:36:14)
    8. IDEA: add instroctions on how to bundle Swagger UI but don't bundle it (cait, 15:44:47)
    9. IDEA: add a wiki page with different alternative UIs (cait, 15:46:31)
    10. Swagger UI has been changed for authentication (cait, 15:47:28)
    11. the documentation is in the swagger specs - can be inspected using tools (cait, 15:47:58)
    12. Mojolicious is moving fact, need to keep an eye on new versions (cait, 15:53:08)
    13. 2 versions for authentication rightnow (cait, 15:55:45)
    14. http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=40592 (kivilahtio_, 15:56:45)
    15. ACTION: kivilahtio_ will initiate a wiki page as an overview of the REST work (Joubu, 16:35:34)


Meeting ended at 16:36:28 UTC (full logs).

Action items

  1. kivilahtio_ will initiate a wiki page as an overview of the REST work


Action items, by person

  1. kivilahtio_
    1. kivilahtio_ will initiate a wiki page as an overview of the REST work


People present (lines said)

  1. kivilahtio_ (208)
  2. ashimema (154)
  3. cait (80)
  4. tcohen (60)
  5. Joubu (47)
  6. jajm (33)
  7. huginn` (16)
  8. khall (15)
  9. pianohacker (12)
  10. drojf (8)
  11. wahanui (6)
  12. nengard (6)
  13. TGoat (1)
  14. gaetan_B (1)
  15. carmen (1)
  16. alex_a (1)
  17. indradg (1)
  18. bgkriegel (1)


Generated by MeetBot 0.1.4.