#koha: Development IRC meeting 26 August 2015 - part 2

Meeting started by pianohacker at 21:34:19 UTC (full logs).

Meeting summary

  1. Introductions (pianohacker, 21:34:41)
    1. wahanui, a bot that has become sentient (wahanui, 21:34:41)
    2. Jesse Weaver, ByWater Solutions (pianohacker, 21:35:17)
    3. barton, bws, Louisville Ky, USA (barton, 21:35:35)
    4. Tomas Cohen Arazi, Theke Solutions (tcohen, 21:35:43)
    5. Liz Rea, Catalyst IT (wizzyrea, 21:38:22)
    6. brendan gallagher bywater (bag, 21:41:08)

  2. Summary from part 1 (pianohacker, 21:41:27)
    1. http://meetings.koha-community.org/2015/development_irc_meeting_26_august_2015___part_1.2015-08-26-14.14.html (pianohacker, 21:41:41)

  3. RM 3.22 comments (pianohacker, 21:47:03)
    1. Current proposed method for integrating Plack into packages requires a version of Apache only present in Ubuntu 14.10 and wheezy-backports (pianohacker, 21:49:38)
    2. addition to above: also included in Debian 8 (Jessie) (pianohacker, 21:50:54)

  4. RESTful API Implementation (pianohacker, 21:54:01)
    1. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13799 (pianohacker, 21:55:15)
    2. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13920 (pianohacker, 21:55:27)
    3. ACTION: pianohacker will investigate feasibility of running API as CGI script (pianohacker, 22:08:22)
    4. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12272 (pianohacker, 22:14:23)
    5. http://wiki.koha-community.org/wiki/New_REST_API_RFC (pianohacker, 22:19:24)
    6. http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=37413 (pianohacker, 22:26:21)
    7. see above for an example of adding the necessary objects, API endpoints and tests for a new API piece (pianohacker, 22:26:54)
    8. https://docs.google.com/document/d/1rWP0RAcYmdlukdacFHremN9TmaKQVtkuEaqpv2i8OHw/edit?usp=sharing (bag, 22:30:03)
    9. http://stefanorodighiero.net/posts/2014-03-30-managing_multiple_mojolicious_app_with_plack.html ? (pianohacker, 22:34:12)
    10. Plenty of reservations about the REST API functions, but we can't make any decisions yet because work is still in progress (wizzyrea, 22:36:47)
    11. https://algonquincollegesocialmedia.files.wordpress.com/2014/04/tumblr_m7gj9qivt51rxdvy7o1_500.gif (wizzyrea, 22:37:47)
    12. the API will need at least 4 weeks testing (wizzyrea, 22:38:29)
    13. we need at least 4 weeks to really test this - so time really inmportant… I can help with funds - if needed (bag, 22:38:32)

  5. Big stuff we are working on (pianohacker, 22:39:23)
    1. https://www.elastic.co/webinars/get-started-with-elasticsearch <-- in fact, they do (eythian, 22:43:27)
    2. ACTION: eythian to make a writeup showing how he's using ElasticSearch (pianohacker, 22:48:07)
    3. https://twitter.com/ZacharyTong < here's the guy who does the webinars #imhelping (wizzyrea, 22:48:17)
    4. ElasticSearch is moving forward, the basics are working. Just needs some refining (pianohacker, 22:58:45)
    5. ByWater have a circ rules revamp on their roadmap (wizzyrea, 22:59:10)

  6. 3.18 RMaint comments (pianohacker, 23:01:24)
    1. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13618 (pianohacker, 23:03:31)
    2. the above is preventing progress on the following bugs; please comment with any ideas (pianohacker, 23:03:52)
    3. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14691 (pianohacker, 23:03:58)
    4. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14505 (pianohacker, 23:04:04)

  7. GBSD (pianohacker, 23:04:26)
    1. Bug 13618 would be a great one for global bug squashing day, it is vitally important (wizzyrea, 23:06:18)
    2. Reminder, there is a Global Bug Squashing Day on Thursday, September 3 (pianohacker, 23:06:36)
    3. http://wiki.koha-community.org/wiki/2015-09-03_Global_bug_squashing_day (pianohacker, 23:06:43)
    4. Please add any bugs/topics of interest to that page (pianohacker, 23:06:58)
    5. ACTION: pianohacker to post google doc to allow per-test-plan-item feedback for Rancor (bug 11559) (pianohacker, 23:09:09)
    6. http://staff-bz11559.bwsdev.bywatersolutions.com/ (login bywater / bywater) (pianohacker, 23:10:02)


Meeting ended at 23:16:01 UTC (full logs).

Action items

  1. pianohacker will investigate feasibility of running API as CGI script
  2. eythian to make a writeup showing how he's using ElasticSearch
  3. pianohacker to post google doc to allow per-test-plan-item feedback for Rancor (bug 11559)


Action items, by person

  1. eythian
    1. eythian to make a writeup showing how he's using ElasticSearch
  2. pianohacker
    1. pianohacker will investigate feasibility of running API as CGI script
    2. pianohacker to post google doc to allow per-test-plan-item feedback for Rancor (bug 11559)


People present (lines said)

  1. pianohacker (134)
  2. wizzyrea (64)
  3. bag (54)
  4. tcohen (25)
  5. eythian (21)
  6. cait (16)
  7. huginn (13)
  8. rangi (11)
  9. wahanui (6)
  10. barton (2)


Generated by MeetBot 0.1.4.