#koha: Development IRC meeting, 21 January 2015

Meeting started by tcohen at 15:09:34 UTC (full logs).

Meeting summary

    1. Katrin Fischer, BSZ, Germany (cait, 15:09:42)

  1. Introductions (tcohen, 15:09:59)
    1. Martin Renvoize, PTFS Europe (ashimema_, 15:10:00)
    2. Kyle Hall, ByWater Solutions (khall, 15:10:04)
    3. Colin Campbell, PTFS Europe (ColinC, 15:10:10)
    4. Barton Chittenden, Bywater, Louisville, KY, USA (barton, 15:10:13)
    5. Tomas Cohen Arazi, Universidad Nacional de Cordoba (tcohen, 15:10:16)
    6. Olli-Antti Kivilahti Vaara-kirjastot (kivilahtio, 15:10:21)
    7. Owen Leonard, Athens County Public Libraries, OH, USA (oleonard, 15:10:31)
    8. Nicole Engard, ByWater Solutions (nengard, 15:10:40)
    9. Marcel de Rooy (marcelr, 15:10:57)
    10. http://wiki.koha-community.org/wiki/Development_IRC_meeting_21_January_2015 (cait, 15:11:35)
    11. Jonathan Druart, BibLibre (Joubu, 15:12:02)

  2. RM 3.18 comments / catching up after vacation (tcohen, 15:13:01)
    1. Paul Poulain, BibLibre (paul_p, 15:14:53)

  3. Out of the box Plack support (tcohen, 15:21:08)
    1. ashimema_ has left (ashimema_, 15:24:20)
    2. plack: known problems with syspref caching (cait, 15:26:32)
    3. several approaches: Plack for developers' pushed (bug 7844), 'Plack with nginx for production' in testing (bug 9316), at least two koha-plackify scripts: Plackify-koha-common, koha-plack. (cait, 15:26:59)
    4. ACTION: tcohen to ask eythian for a status report about plack (cait, 15:30:18)
    5. ACTION: ashimema will check if his implementatin of bug 12904 works with plack ;) (cait, 15:36:03)

  4. non-XSLT view deprecation (tcohen, 15:36:43)
    1. bug 12561: Omnibus: Deprecate non-XSLT detail and result views (cait, 15:38:51)
    2. ACTION: cait to update the list of depending bugs on the omnibus bug for deprecating non-XSLT views (cait, 15:48:25)
    3. keep different marc flavours in mind for deprecation (cait, 15:58:40)
    4. discussion to be continued (cait, 16:00:53)

  5. GRS-1 removal - comments only, no vote today (cait, 16:01:07)
    1. grs-1 was already deprecated, this is about removing the code for it (cait, 16:04:05)
    2. ACTION: all think about problems with removing grs-1 - especially if you are using UNIMARC (cait, 16:08:56)

  6. tarball vs. packages installations - how to keep them in sync, workflow discussion (cait, 16:09:27)
    1. Brendan Gallagher - ByWater (bag, 16:13:32)
    2. Fridolin Somers - Biblire (fridolin, 16:15:47)
    3. ACTION: tcohen will update the wiki so it mentions that patches touching configuration files should cover both install methods (tcohen, 16:23:44)

  7. Testing SIP (tcohen, 16:23:59)
    1. http://openncip.cvs.sourceforge.net/viewvc/openncip/src/ (Joubu, 16:29:30)
    2. bug 7904 needs a sign off and might help getting better sip tests (cait, 16:31:40)
    3. ACTION: khall to test bug 7904 (cait, 16:34:06)

  8. Bugs (cait, 16:34:19)
    1. ACTION: cait will try to keep working on the tax patche as they come into the qa queue (cait, 16:41:09)

  9. big stuff we are working on (cait, 16:45:38)
    1. http://lists.koha-community.org/pipermail/koha-devel/2014-December/041040.html (cait, 16:48:08)
    2. Hea: please think about adding your library/libraries (cait, 16:54:44)
    3. ACTION: tcohen to set the time for the next meeting, suggestion is wednesday 4th (cait, 16:56:56)
    4. ACTION: tcohen to think about another date for the meeting to not collide with Joubu's birthday :) (cait, 16:57:30)


Meeting ended at 16:57:32 UTC (full logs).

Action items

  1. tcohen to ask eythian for a status report about plack
  2. ashimema will check if his implementatin of bug 12904 works with plack ;)
  3. cait to update the list of depending bugs on the omnibus bug for deprecating non-XSLT views
  4. all think about problems with removing grs-1 - especially if you are using UNIMARC
  5. tcohen will update the wiki so it mentions that patches touching configuration files should cover both install methods
  6. khall to test bug 7904
  7. cait will try to keep working on the tax patche as they come into the qa queue
  8. tcohen to set the time for the next meeting, suggestion is wednesday 4th
  9. tcohen to think about another date for the meeting to not collide with Joubu's birthday :)


Action items, by person

  1. cait
    1. cait to update the list of depending bugs on the omnibus bug for deprecating non-XSLT views
    2. cait will try to keep working on the tax patche as they come into the qa queue
  2. Joubu
    1. tcohen to think about another date for the meeting to not collide with Joubu's birthday :)
  3. khall
    1. khall to test bug 7904
  4. tcohen
    1. tcohen to ask eythian for a status report about plack
    2. tcohen will update the wiki so it mentions that patches touching configuration files should cover both install methods
    3. tcohen to set the time for the next meeting, suggestion is wednesday 4th
    4. tcohen to think about another date for the meeting to not collide with Joubu's birthday :)
  5. UNASSIGNED
    1. ashimema will check if his implementatin of bug 12904 works with plack ;)
    2. all think about problems with removing grs-1 - especially if you are using UNIMARC


People present (lines said)

  1. cait (156)
  2. tcohen (90)
  3. kivilahtio (58)
  4. Joubu (55)
  5. ashimema_ (42)
  6. huginn (37)
  7. jenkins_koha (29)
  8. marcelr (12)
  9. ColinC (11)
  10. barton (11)
  11. oleonard (10)
  12. fridolin (10)
  13. bag (9)
  14. paul_p (8)
  15. khall (5)
  16. gaetan_B (3)
  17. nengard (3)
  18. jcamins (2)
  19. reiveune (1)
  20. marcelr_afk (1)


Generated by MeetBot 0.1.4.