#koha: Development IRC meeting 13 April 2016

Meeting started by cait at 19:11:38 UTC (full logs).

Meeting summary

  1. Introductions (cait, 19:11:57)
    1. wahanui, a bot that has become sentient (wahanui, 19:11:57)
    2. Mirko Tietgen, Berlin, Germany (drojf, 19:12:04)
    3. https://wiki.koha-community.org/wiki/Development_IRC_meeting_13_April_2016 (cait, 19:12:13)
    4. Katrin Fischer, BSZ, Germany (cait, 19:12:20)
    5. Brendan Gallagher, ByWater (bag, 19:12:35)
    6. Barton Chittenden, Bywater (barton, 19:12:45)
    7. Nick CLemens, ByWater Solutiojns (kidclamp, 19:15:05)
    8. Nick Clemens, ByWater Solutions (kidclamp, 19:15:15)

  2. Review coding guidelines (cait, 19:15:49)
    1. [oleonard] Proposal: Add a coding guideline discouraging the use of the "onclick" attribute in favor of defining click handlers in separate JavaScript blocks or files. (cait, 19:17:06)
    2. VOTE: Voted on "Should we add oleonards proposed guideline to the coding guidelines?" Results are, yes: 4 (cait, 19:22:51)
    3. AGREED: Proposed guideline will be added. (cait, 19:23:20)
    4. ACTION: oleonard to add his proposed coding guideline, maybe with an example, to the coding guidelines page (cait, 19:23:44)

  3. Any bugs that are in discussion (cait, 19:23:54)
  4. General development discussion (cait, 19:25:26)
    1. bug 15930 for 16.05 and backport (cait, 19:38:35)
    2. feature freeze is on April 28 (cait, 19:38:47)
    3. bug 15303 needs a tester to help it moving forward (cait, 19:39:04)

  5. Updates from the QA team (cait, 19:39:17)
    1. [kfischer] proposal to have an 'exception rule' for SIP2 and LDAP related patches being able to pass QA with 2 sign offs. (cait, 19:39:59)

  6. Set time of next meeting (cait, 19:50:07)
    1. AGREED: Next meeting will be on April 20, 15 UTC (cait, 19:56:31)


Meeting ended at 19:56:38 UTC (full logs).

Action items

  1. oleonard to add his proposed coding guideline, maybe with an example, to the coding guidelines page


People present (lines said)

  1. cait (107)
  2. barton (19)
  3. drojf (19)
  4. kidclamp (17)
  5. huginn (14)
  6. beatsforthemind (4)
  7. bag (3)
  8. wahanui (1)
  9. eythian (1)


Generated by MeetBot 0.1.4.