#koha: Development IRC meeting 11 October 2017

Meeting started by kidclamp at 14:00:56 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 14:01:04)
    1. Jon Knight, Loughborough University (greenjimll, 14:01:14)
    2. Nick Clemens, ByWater Solutions (kidclamp, 14:01:24)
    3. Marcel de Rooy, Rijksmuseum (marcelr, 14:01:29)
    4. Owen Leonard, Athens County Public Libraries, USA (oleonard, 14:01:40)
    5. Thomas Dukleth, Agogme, New York, NY (thd, 14:02:22)
    6. Jonathan Druart (Joubu, 14:02:26)
    7. MJ Ray, software.coop, England (slef, 14:02:31)
    8. Tomas Cohen Arazi (tcohen, 14:03:12)
    9. Katrin Fischer, BSZ, Germany (cait, 14:03:34)
    10. Fridolin Somers, Biblibre, France (fridolin, 14:03:39)

  2. Announcements (kidclamp, 14:04:42)
    1. Jesse Maseto, BWS (JesseM, 14:05:11)
    2. soon all stable releases are expected to be stable (according to jenkins) (kidclamp, 14:06:53)
    3. mtj has provided a third node for dockerized jenkins runs (kidclamp, 14:07:21)

  3. Update from the Release manager (17.11) (kidclamp, 14:09:40)
    1. release dates were published, give him more things to push! (kidclamp, 14:11:12)

  4. Updates from the Release Maintainers (kidclamp, 14:11:25)
    1. 16.11 - String freeze is planned for 15th - we will have lots of bug fixes in 16.11.13 (kidclamp, 14:12:49)
    2. October 15th is string freeze for both stable (kidclamp, 14:15:06)
    3. please work on translations (and manual and bugs, please) (kidclamp, 14:15:34)
    4. poke Frido if you want something backported (kidclamp, 14:16:56)

  5. Updates from the QA team (kidclamp, 14:17:53)
    1. please QA and SO - queues are big, possible sprint soon (kidclamp, 14:22:14)

  6. General development discussion (trends, ideas, ...) (kidclamp, 14:22:19)
    1. ACTION: kidclamp will file a bug to move rancor out of the 'labs' section (kidclamp, 14:30:14)

  7. Review of coding guidelines (kidclamp, 14:32:12)
    1. https://github.com/digibib/kohadevbox/commit/6ab941382df8cad7f66c1daf4fbe97b732af1d5b (tcohen, 14:33:56)
    2. https://wiki.koha-community.org/w/index.php?title=Tips_and_tricks&action=historysubmit&diff=19340&oldid=10188 (Joubu, 14:34:28)
    3. VOTE: Voted on "Should we stop adding [SIGNED_OFF] labels when signing off patches?" Results are (kidclamp, 14:41:07)
    4. results are unanimous yes (with one vote for partial signoff exception) (kidclamp, 14:42:13)

  8. Open roles for 18.05 (kidclamp, 14:42:22)
    1. https://wiki.koha-community.org/wiki/Roles_for_18.05 Roles for 18.05 (kidclamp, 14:43:17)
    2. once there is a page, add your name / proposal (kidclamp, 14:43:41)
    3. ACTION: Joubu is creating the page (kidclamp, 14:43:49)

  9. Koha Agenda (kidclamp, 14:46:24)
    1. you can add the calendar at koha-community.org to your local calender (kidclamp, 14:47:55)
    2. https://koha-community.org/calendar Community calendar (kidclamp, 14:48:14)
    3. a new role for 18.05 - scheduler? chair? something to kee porganized (kidclamp, 14:51:28)

  10. Set time of next meeting (kidclamp, 14:51:42)
    1. ACTION: marcelr let's encourage people to contribute (Joubu, 14:53:18)
    2. Next meeting October 25th, 2017 21 UTC (kidclamp, 14:54:35)


Meeting ended at 14:57:15 UTC (full logs).

Action items

  1. kidclamp will file a bug to move rancor out of the 'labs' section
  2. Joubu is creating the page
  3. marcelr let's encourage people to contribute


Action items, by person

  1. Joubu
    1. Joubu is creating the page
  2. kidclamp
    1. kidclamp will file a bug to move rancor out of the 'labs' section
  3. marcelr
    1. marcelr let's encourage people to contribute


People present (lines said)

  1. Joubu (77)
  2. kidclamp (76)
  3. marcelr (32)
  4. cait (17)
  5. thd (14)
  6. tcohen (11)
  7. oleonard (10)
  8. fridolin (9)
  9. huginn` (9)
  10. greenjimll (7)
  11. slef (3)
  12. JesseM (2)
  13. khall (1)
  14. jenkins (1)


Generated by MeetBot 0.1.4.