#koha: Development IRC meeting 13 September 2017

Meeting started by kidclamp at 14:03:13 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 14:03:27)
    1. wahanui, a bot that has become sentient (wahanui, 14:03:28)
    2. Nick Clemens, ByWater Solutions (kidclamp, 14:03:36)
    3. Jonathan Druart (Joubu, 14:03:41)
    4. https://wiki.koha-community.org/wiki/Development_IRC_meeting_13_September_2017 #empty (Joubu, 14:03:58)
    5. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:04:27)
    6. Jesse Maseto, BWS (JesseM, 14:04:44)
    7. Marc Véron Switzerland (mveron, 14:05:07)
    8. Michael Cabus, BWS (caboose, 14:05:10)
    9. Barton Chittenden, BWS (barton, 14:05:36)
    10. Owen Leonard, Athens County Public Library, Ohio (oleonard, 14:06:52)

  2. Announcements (kidclamp, 14:07:01)
    1. Danielle Elder, BWS (dani, 14:08:05)
    2. Dockerizing jenkins is almost done, anyone with Docker experienced is welcome to help (kidclamp, 14:10:31)

  3. Update from the Release manager (17.11) (kidclamp, 14:10:47)
    1. Fridolin Somers, Franche, Biblibre (fridolin, 14:10:58)
    2. QA sprint went well, will organise another as queue grows (kidclamp, 14:12:00)
    3. early feature freeze, so get enhancements in before 10/25 (kidclamp, 14:12:24)
    4. REST patches awaiting docker/Jenkins completion (kidclamp, 14:12:45)
    5. Joubu working on bug 19297 too (kidclamp, 14:13:55)

  4. Updates from the Release Maintainers (kidclamp, 14:14:06)
    1. security releases last month and upcoming (kidclamp, 14:16:18)
    2. frido was away but now catchign up and pushing (kidclamp, 14:16:45)

  5. Updates from the QA team (kidclamp, 14:17:57)
    1. Joubu will send a poll for next QA sprint (kidclamp, 14:21:24)
    2. remember to set yourself as qa contact when looking at a bug (kidclamp, 14:21:35)

  6. General development discussion (trends, ideas, ...) (kidclamp, 14:22:40)
    1. http://lists.koha-community.org/pipermail/koha-devel/2017-August/043991.html Commit messages and bug titles guidelines (kidclamp, 14:23:52)
    2. https://wiki.koha-community.org/wiki/Commit_messages (mveron, 14:24:38)
    3. http://lists.koha-community.org/pipermail/koha-devel/2017-August/043910.html (oleonard, 14:28:52)
    4. Joubu will draft a coding guideline for commit messages to be voted on next meeting (kidclamp, 14:32:46)
    5. ACTION: Joubu will draft a coding guideline for commit messages to be voted on next meeting (kidclamp, 14:32:51)
    6. http://lists.koha-community.org/pipermail/koha-devel/2017-August/043910.html (oleonard, 14:33:38)
    7. ACTION: pianohacker should write a wiki page for compiling assets in the release process (kidclamp, 14:39:19)
    8. release process is suggested as proper time to compile assets, put onus on developers (kidclamp, 14:41:16)

  7. Review of coding guidelines (kidclamp, 14:41:49)
    1. QAers, please QA all the things (kidclamp, 14:45:42)

  8. Set time of next meeting (kidclamp, 14:45:52)
    1. Next meeting: September 27th, 21 UTC (kidclamp, 14:49:08)


Meeting ended at 14:49:49 UTC (full logs).

Action items

  1. Joubu will draft a coding guideline for commit messages to be voted on next meeting
  2. pianohacker should write a wiki page for compiling assets in the release process


Action items, by person

  1. Joubu
    1. Joubu will draft a coding guideline for commit messages to be voted on next meeting


People present (lines said)

  1. kidclamp (53)
  2. Joubu (45)
  3. tcohen (31)
  4. oleonard (22)
  5. fridolin (16)
  6. huginn (6)
  7. wahanui (4)
  8. ashimema (4)
  9. mveron (4)
  10. JesseM (1)
  11. caboose (1)
  12. barton (1)
  13. dani (1)


Generated by MeetBot 0.1.4.