#koha: Development IRC meeting 9 August 2017

Meeting started by cait at 22:00:43 UTC (full logs).

Meeting summary

  1. Introductions (cait, 22:00:48)
    1. wahanui, a bot that has become sentient (wahanui, 22:00:49)
    2. Tomas Cohen Arazi, Theke Solutions (tcohen, 22:00:51)
    3. Jesse Weaver (pianohacker, 22:00:58)
    4. Liz Rea, Catalyst IT (wizzyrea, 22:01:06)
    5. Chris Cormack, Catalyst IT (rangi, 22:01:07)
    6. Katrin Fischer, BSZ, Germany (cait, 22:01:13)
    7. Bob Birchall, Calyx (BobB, 22:01:14)
    8. Alex Sassmannshausen, PTFS Europe, UK (atheia, 22:01:23)
    9. Josef Moravec, Municipal LIbrary Usti nad Orlici, Czech Republic (josef_moravec, 22:01:30)
    10. https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_August_2017 today's agenda (cait, 22:01:36)
    11. Lee Jamison, Marywood University (LeeJ, 22:01:41)
    12. Mason James, NZ (mtj, 22:02:12)

  2. Announcements (cait, 22:02:58)
    1. We just added a section on how to add screenshots to the manual with gitlab (cait, 22:03:43)
    2. https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_August_2017 (cait, 22:03:46)
    3. https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual#Normal_-_Adding_screenshots_with_gitlab right link (cait, 22:04:02)
    4. Bag Brendan gallagher (bag, 22:04:16)
    5. tcohen is doing QA full time this week, please help him notice things you consider important besides the ones the RM notes (tcohen, 22:04:42)
    6. Michael Cabus, caboose (caboose, 22:04:43)
    7. bug 19016 - Add a script to fix corrupted data needs attention and testers (cait, 22:07:35)
    8. Koha-US Conference is taking place this week, it's broadcasted http://koha-us.net/index.php/2017_Koha-US_Conference (cait, 22:08:57)
    9. tcohen and Joubu are exploring ways of containerizing jenkins tasks (tcohen, 22:11:14)
    10. ByWater is handing the community another jenkins node in the meantime (tcohen, 22:12:03)

  3. Update from the Release manager (17.11) (cait, 22:13:22)
    1. Joubu left his apologies (cait, 22:13:42)
    2. https://koha-community.org/whats-on-in-koha-devel-14/ for recent information about urgent topics and new things (cait, 22:14:08)
    3. We will need help updating the manual and especially the help pages prior to 17.11 release in order to be able to switch it over to the Sphinx based one (cait, 22:15:10)

  4. Updates from the Release maintainers (cait, 22:16:20)
    1. 16.11.11 will be the next 16.11.x release, planned on schedule, string freeze on the 15th, release on 22nd (cait, 22:17:08)
    2. 16.05.16 should be on schedule this month too (mtj, 22:17:56)

  5. Updates from the QA team (cait, 22:19:00)
    1. Owen Leonard, late. (oleonard, 22:19:13)
    2. QA team members are urged to spend some time on blockers and major bugs (tcohen, 22:19:56)

  6. General development discussion (trends, ideas...) (cait, 22:23:13)
    1. https://scotch.io/tutorials/javascript-transpilers-what-they-are-why-we-need-them - we discussed about adding a trnaspiler / preprocessing stuff (cait, 22:35:40)
    2. https://www.microsoft.com/en-us/windowsforbusiness/end-of-ie-support (rangi, 22:39:34)
    3. https://www.microsoft.com/en-us/windowsforbusiness/end-of-ie-support (tcohen, 22:41:24)
    4. ACTION: pianohacker and oleonard are going to work out a proposal for adding a transpiler into our workflow (cait, 22:46:21)

  7. Review of coding guidelines (cait, 22:46:22)
  8. Review of coding guidelines (cait, 22:46:22)
  9. Set time of next meeting (cait, 22:47:01)
    1. https://wiki.koha-community.org/wiki/IRC_Meetings (cait, 22:47:49)
    2. AGREED: Next meeting will be on August 23, 14 UTC (cait, 22:49:21)


Meeting ended at 22:49:32 UTC (full logs).

Action items

  1. pianohacker and oleonard are going to work out a proposal for adding a transpiler into our workflow


Action items, by person

  1. oleonard
    1. pianohacker and oleonard are going to work out a proposal for adding a transpiler into our workflow
  2. pianohacker
    1. pianohacker and oleonard are going to work out a proposal for adding a transpiler into our workflow


People present (lines said)

  1. cait (79)
  2. tcohen (44)
  3. pianohacker (40)
  4. bag (16)
  5. wizzyrea (15)
  6. oleonard (14)
  7. huginn (11)
  8. LeeJ (9)
  9. rangi (9)
  10. wahanui (6)
  11. josef_moravec (5)
  12. jenkins (5)
  13. mtj (3)
  14. BobB (2)
  15. jfowler (2)
  16. caboose (1)
  17. atheia (1)


Generated by MeetBot 0.1.4.