#koha: Development IRC meeting 9 May 2018

Meeting started by kidclamp at 14:01:10 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 14:01:22)
    1. wahanui, a bot that has become sentient (wahanui, 14:01:22)
    2. Owen Leonard, Athens County Public Libraries, USA (oleonard, 14:01:24)
    3. Nick Clemens, ByWater Solutions (kidclamp, 14:01:31)
    4. Jonathan Druart (Joubu, 14:01:36)
    5. https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_May_2018 (Joubu, 14:01:47)
    6. Thomas Dukleth, Agogme, New York City (thd, 14:01:48)
    7. David Bourgault, Solutions InLibro (davbo_, 14:01:52)
    8. Colin Campbell, PTFS Europe Ltd (cc_, 14:01:52)
    9. Marcel de Rooy (marcelr, 14:01:56)
    10. Philippe Blouin, Solutions inLibro (blou, 14:01:58)
    11. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:02:25)
    12. Kyle M Hall, ByWater Solutions (khall, 14:02:43)
    13. Fridolin Somers, Biblibre, France (fridolin, 14:03:56)
    14. Katrin Fischer, BSZ, Germany (cait, 14:04:28)
    15. Victor Grousset, BibLibre, France (tuxayo, 14:04:56)
    16. Claire Gravely, BSZ, Germany (calire, 14:05:11)

  2. Announcements (kidclamp, 14:05:54)
  3. Update from the Release manager (18.05) (kidclamp, 14:07:58)
    1. 18.05 release in string freeze but exception being made for OAuth patches, please focus on bugs and testing (kidclamp, 14:10:08)
    2. please look at bugs 20270 19835 20710 for release (kidclamp, 14:13:11)

  4. Updates from the Release Maintainers (kidclamp, 14:14:23)
    1. Josef Moravec, library Ústí nad Orlicí (josef_moravec, 14:18:32)
    2. kidlcmap will push for 17.11 this week (kidclamp, 14:19:29)
    3. ACTION: ashimema has (been?) volunteered for 18.05 RMaint - he should update the wiki :-D (kidclamp, 14:20:57)

  5. Updates from the QA team (kidclamp, 14:22:12)
    1. QA please focus on bugs, after release there are big patches to look towards (kidclamp, 14:26:05)
    2. Jon Knight, Loughborough University (greenjimll, 14:27:55)
    3. kidclamp will corordinate ES efforts for 18.11 - may tap individuals for help along the way (kidclamp, 14:29:26)
    4. https://annuel2.framapad.org/p/What_s_on_in_koha-devel (Joubu, 14:30:16)

  6. General development discussion (trends, ideas, ...) (kidclamp, 14:30:23)
    1. Martin Renvoize, PTFS Europe (ashimema, 14:30:57)

  7. Way to authenticate patron for REST API - what about Bug 17004 (kidclamp, 14:32:41)
    1. https://annuel2.framapad.org/p/What_s_on_in_koha-devel To contribute for 'What's on in koha devel" (kidclamp, 14:34:43)
    2. Barton Chittenden, BWS (barton, 14:36:42)
    3. bug 17004 may be covered by OAuth developments - involved parties should talk about coordinating :-) (kidclamp, 14:40:43)

  8. Review of coding guidelines (kidclamp, 14:41:06)
  9. HTML8: use Asset TT plugin for linking javascript and css files (kidclamp, 14:41:21)
    1. https://wiki.koha-community.org/wiki/Coding_Guidelines#HTML8:_use_Asset_TT_plugin_for_linking_javascript_and_css_files Use Asset TT plugin for linking js and css files (kidclamp, 14:41:45)
    2. VOTE: Voted on "should we adopt coding guideline HTML8 as written?" Results are (kidclamp, 14:44:18)
    3. 8 yes, unanimous (kidclamp, 14:44:42)

  10. PERL17.1 Unit tests should be grouped into sensible subtests that create their own data. (kidclamp, 14:45:14)
    1. ACTION: tcohen will draft a rule (with examples and qa escape clause) (kidclamp, 14:50:05)

  11. Proposal: Officially apply Perl indentation rules to all file types. 4-space indentation for new/changed templates, JS, CSS, etc. -- oleonard (kidclamp, 14:50:27)
    1. VOTE: Voted on " should we adopt 4-space indentation globally?" Results are (tcohen, 15:05:36)
    2. Yes: 7, No: 2 (tcohen, 15:07:05)

  12. Set time of next meeting (Joubu, 15:07:38)


Meeting ended at 15:12:57 UTC (full logs).

Action items

  1. ashimema has (been?) volunteered for 18.05 RMaint - he should update the wiki :-D
  2. tcohen will draft a rule (with examples and qa escape clause)


Action items, by person

  1. ashimema
    1. ashimema has (been?) volunteered for 18.05 RMaint - he should update the wiki :-D
  2. tcohen
    1. tcohen will draft a rule (with examples and qa escape clause)


People present (lines said)

  1. kidclamp (56)
  2. Joubu (53)
  3. tcohen (42)
  4. cait (37)
  5. tuxayo (20)
  6. huginn (18)
  7. marcelr (16)
  8. fridolin (14)
  9. greenjimll (12)
  10. oleonard (12)
  11. thd (12)
  12. wahanui (10)
  13. josef_moravec (9)
  14. ashimema (9)
  15. khall (4)
  16. calire (3)
  17. cc_ (2)
  18. barton (1)
  19. davbo_ (1)
  20. blou (1)


Generated by MeetBot 0.1.4.