#koha: Development IRC meeting 26 August 2020

Meeting started by Joubu at 14:00:54 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 14:00:58)
    1. Jonathan Druart (Joubu, 14:01:08)
    2. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:01:08)
    3. Nick Clemens, ByWater Solutions (kidclamp, 14:02:21)
    4. Marcel de Rooy (marcelr, 14:02:49)
    5. Joonas Kylmälä (kohaputti, 14:02:56)

  2. Announcements (Joubu, 14:04:26)
    1. the SMTP configuration admin page feature is ready for testing! bug 22343 (Joubu, 14:06:04)
    2. Marcel has patches waiting for signoff! (Joubu, 14:07:20)
    3. Tomas is going to adjust the Koha2Koha ILL backend to have it into Koha core (Joubu, 14:09:21)

  3. Update from the Release Manager 20.11 (Joubu, 14:09:52)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_26_August_2020 (Joubu, 14:09:57)
    2. Katrin Fischer, BSZ, Germany (cait2, 14:13:16)

  4. Updates from the Release Maintainers (Joubu, 14:14:29)
  5. Updates from the QA team (Joubu, 14:14:54)
    1. Stable releases are coming soon! (Joubu, 14:15:28)
    2. QA queue is in pretty good shape right now, but needs work to stay that way, big patches waiting (cait2, 14:15:40)

  6. Actions from last meeting (Joubu, 14:20:58)
  7. ashimema is going to add his stamp on 20168 (Joubu, 14:21:07)
    1. ashimema signed off 20168, thanks! (Joubu, 14:21:24)

  8. ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (Joubu, 14:21:35)
    1. ACTION: ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed) (Joubu, 14:21:48)

  9. ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed) (Joubu, 14:21:57)
    1. A guideline for remove indirect object notation has been written and available at https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL29:_Direct_Object_Notation (Joubu, 14:22:18)
    2. there is a bug ready for testing: Bug 25898 - Prohibit indirect object notation (Joubu, 14:23:02)
    3. tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed) (Joubu, 14:29:44)
    4. ACTION: tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed) (Joubu, 14:29:57)
    5. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed) (Joubu, 14:30:04)
    6. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed) (Joubu, 14:30:34)

  10. General development discussion (trends, ideas, ...) (Joubu, 14:30:59)
    1. (Joubu, 14:41:57)
    2. Please have a look at bug 21260 (Improve the Availability line of OPAC XSLT search results) (Joubu, 14:42:14)

  11. Review of coding guidelines (Joubu, 14:42:41)
    1. Don't use input type "number" in favor of using a pattern check instead (Joubu, 14:42:58)
    2. https://technology.blog.gov.uk/2020/02/24/why-the-gov-uk-design-system-team-changed-the-input-type-for-numbers/ (Joubu, 14:43:06)
    3. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17098 (Joubu, 14:43:13)
    4. ACTION: Joubu open a bug report for the QA script to catch input type number (Joubu, 14:45:33)
    5. ACTION: ashimema write a guideline to forbid usage for type "number" (Joubu, 14:47:52)

  12. Set time of next meeting (Joubu, 14:48:56)
    1. Next meeting: 9 September 2020, 20 UTC (Joubu, 14:49:39)


Meeting ended at 14:50:13 UTC (full logs).

Action items

  1. ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed)
  2. tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
  3. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed)
  4. Joubu open a bug report for the QA script to catch input type number
  5. ashimema write a guideline to forbid usage for type "number"


Action items, by person

  1. Joubu
    1. Joubu open a bug report for the QA script to catch input type number
  2. UNASSIGNED
    1. ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed)
    2. tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
    3. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed)
    4. ashimema write a guideline to forbid usage for type "number"


People present (lines said)

  1. Joubu (126)
  2. marcelr (34)
  3. cait2 (31)
  4. tcohen (20)
  5. huginn (19)
  6. kidclamp (4)
  7. koha-jenkins (4)
  8. wahanui (3)
  9. kohaputti (2)


Generated by MeetBot 0.1.4.