#koha: Development IRC meeting 29 July 2020

Meeting started by Joubu at 19:01:36 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 19:01:47)
    1. Jonathan Druart (Joubu, 19:01:53)
    2. David Nind, Wellington, New Zealand (davidnind, 19:02:29)
    3. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 19:02:57)
    4. Lisette Scheer, Latah County Library District, Idaho, USA (lisettelatah, 19:03:18)
    5. Thomas Dukleth, Agogme, New York City (thd, 19:03:28)
    6. Tomas Cohen Arazi, Theke Solutions (tcohen, 19:04:56)

  2. Announcements (Joubu, 19:05:05)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_29_July_2020 (Joubu, 19:05:13)

  3. Update from the Release Manager (20.11) (Joubu, 19:06:20)
    1. RM is requesting urgent QA on bug 22417 and bug 20271 (Joubu, 19:07:30)

  4. Updates from the Release Maintainers (Joubu, 19:07:56)
    1. Second release (for branch 19.05.x) was a breeze. :D Thanks to the predecessor for the great process. (tuxayo, 19:09:42)

  5. Updates from the QA team (Joubu, 19:10:10)
    1. Katrin Fischer, BSZ, Germany (cait, 19:10:56)
    2. tuxayo/Victor Grousset, France (tuxayo, 19:11:29)

  6. Actions from last meeting (Joubu, 19:15:28)
    1. ACTION: ashimema will get back to qa bug 15522 (Joubu, 19:17:07)
    2. tuxayo wrote a proposal for handing over stable branches (Joubu, 19:17:52)
    3. https://wiki.koha-community.org/wiki/User:Victor_Grousset_-_tuxayo/RMaint-handover-draft (Joubu, 19:17:58)
    4. https://wiki.koha-community.org/wiki/User:Victor_Grousset_-_tuxayo/RMaint-handover-draft (tuxayo, 19:18:00)
    5. talljoy added the guideline as proposed to the official guidelines wiki page - https://wiki.koha-community.org/wiki/Coding_Guidelines#TERM3:_Inclusive_Language (Joubu, 19:19:21)
    6. ACTION: ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed) (Joubu, 19:22:39)
    7. ACTION: tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (tuxayo, 19:23:36)
    8. https://koha-community.org/download-koha/ (Joubu, 19:31:53)
    9. ashimema updated the minimum koha requirements on the website (Joubu, 19:33:15)
    10. The analysis of the state of DB fields and tables comments is done. Needs further work to see where we want to go and propose the changes. (tuxayo, 19:33:45)
    11. about supported browsers - we decided/agreed at the last general meeting that we are not supporting IE for staff, people should be updating to use Edge at least (Joubu, 19:34:20)
    12. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed, still in progress) (Joubu, 19:35:13)

  7. General development discussion (trends, ideas, ...) (Joubu, 19:35:25)
    1. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed, still in progress) (davidnind, 19:35:25)

  8. Set time of next meeting (Joubu, 19:36:33)
    1. Next meeting: 12 August 2020, 14 UTC (Joubu, 19:36:58)


Meeting ended at 19:37:29 UTC (full logs).

Action items

  1. ashimema will get back to qa bug 15522
  2. ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)
  3. tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page
  4. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed, still in progress)
  5. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed, still in progress)


Action items, by person

  1. davidnind
    1. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed, still in progress)
    2. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed, still in progress)
  2. tuxayo
    1. tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page
  3. UNASSIGNED
    1. ashimema will get back to qa bug 15522
    2. ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)


People present (lines said)

  1. Joubu (82)
  2. cait (42)
  3. tuxayo (36)
  4. davidnind (8)
  5. wahanui (8)
  6. huginn (6)
  7. lisettelatah (1)
  8. oleonard (1)
  9. kidclamp (1)
  10. tcohen (1)
  11. thd (1)


Generated by MeetBot 0.1.4.