#koha: Development IRC meeting 2 December 2020

Meeting started by tuxayo at 20:16:47 UTC (full logs).

Meeting summary

  1. Introductions (tuxayo, 20:17:02)
    1. tuxayo/Victor Grousset, France (tuxayo, 20:17:12)
    2. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 20:17:47)
    3. liliputech/Arthur Suzuki, BibLibre, France (liliputech_asu, 20:17:59)

  2. Announcements (tuxayo, 20:19:43)
    1. Alex Buckley, Catalyst IT, Wellington NZ (alexbuckley, 20:21:06)
    2. https://github.com/biblibre/koha-plugin-sip-client-emulator (liliputech_asu, 20:21:35)
    3. during the last camp, christophe croullebois from biblibre has worked on a plugin to emulate an automaton (tuxayo, 20:21:45)
    4. https://github.com/biblibre/koha-plugin-sip-client-emulator (tuxayo, 20:21:51)
    5. https://github.com/biblibre/koha-plugin-linked-data (liliputech_asu, 20:24:17)
    6. claire hernandez has worked on a plugin to retrieve and display informations from wikidata about a work within koha (tuxayo, 20:24:55)
    7. https://github.com/biblibre/koha-plugin-linked-data (tuxayo, 20:25:11)

  3. Update from the Release manager (21.05) (tuxayo, 20:25:42)
    1. 21.05 roadmap, see email on koha-devel - https://lists.koha-community.org/pipermail/koha-devel/2020-November/046157.html (tuxayo, 20:26:07)
    2. There is a collaborative pad, feel free to join the existing topics I've listed and to add your own stuffs in it. (tuxayo, 20:26:15)
    3. git.koha-community.org has been migrated (tuxayo, 20:27:43)
    4. Devs will have to adjust their remote URL with: git remote set-url $remote (tuxayo, 20:28:16)
    5. git remote set-url https://git.koha-community.org/Koha-community/Koha.git (tuxayo, 20:28:48)
    6. 20.11: Some bugs have been found already, and some important ones that should be fixed for .01 are listed there: https://frama.link/koha_bz_rel_21_05_candidate (tuxayo, 20:29:07)
    7. Enforcement of the release notes needed before push to help the documentation team (tuxayo, 20:29:40)

  4. Updates from the Release Maintainers (tuxayo, 20:29:52)
    1. oldoldstable (19.11): handover done, ready to begin backporting :) (tuxayo, 20:30:55)

  5. Updates from the QA team (tuxayo, 20:32:33)
    1. HELP: how should I set a calculated value for a controlfield without any user intervention within a framework? (MarkHofstetter, 20:33:39)
    2. Katrin Fischer, BSZ, Germany (cait, 20:35:10)
    3. Lucas Gass, ByWater Solutions (lukeG1, 20:35:30)

  6. Actions from last meeting (tuxayo, 20:39:44)
    1. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this - feel free to reallocate) (tuxayo, 20:40:33)
    2. ACTION: amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc. (tuxayo, 20:40:48)

  7. General development discussion (trends, ideas, ...) (tuxayo, 20:40:57)
    1. liliputech_asu « would love to raise interest on bz 17314» (tuxayo, 20:41:37)
    2. Routes to create, list and delete a purchase suggestion (tuxayo, 20:41:49)
    3. other patches highlighted by liliputech_asu: (tuxayo, 20:45:46)
    4. 20985 (CanBookBeReserved and CanItemBeReserved should check 'On shelf holds allowed' policy) (tuxayo, 20:45:49)
    5. 15261 (Verify if checkout or hold request periods overlap with existing holds) (tuxayo, 20:45:53)
    6. 23011 (AuthenticatePatron could alert if password is not safe) (tuxayo, 20:46:10)

  8. Set time of next meeting (tuxayo, 20:46:47)
    1. Next meeting: 16 December 2020, 15 UTC (tuxayo, 20:49:06)


Meeting ended at 20:49:27 UTC (full logs).

Action items

  1. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this - feel free to reallocate)
  2. amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.


People present (lines said)

  1. tuxayo (56)
  2. liliputech_asu (19)
  3. cait (16)
  4. huginn (8)
  5. oleonard (7)
  6. ashimema (6)
  7. wahanui (3)
  8. MarkHofstetter (2)
  9. lukeG1 (1)
  10. tcohen (1)
  11. alexbuckley (1)
  12. caroline (1)


Generated by MeetBot 0.1.4.