#koha: Development IRC meeting 7 October 2020

Meeting started by Joubu at 14:01:31 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 14:01:37)
    1. Jonathan Druart (Joubu, 14:01:41)
    2. Martin Renvoize, PTFS Europe (ashimema[m], 14:01:54)
    3. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:02:01)
    4. Julian Maurice, BibLibre (jajm, 14:02:09)
    5. https://wiki.koha-community.org/wiki/Development_IRC_meeting_7_October_2020 (Joubu, 14:02:12)
    6. Agustin Moyano, Theke Solutions (amoyano, 14:02:16)
    7. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:03:27)

  2. Announcements (Joubu, 14:04:03)
    1. Roles for 21.05 are opened https://wiki.koha-community.org/wiki/Roles_for_21.05 (Joubu, 14:04:17)

  3. Update from the Release manager (20.11) (Joubu, 14:06:32)
    1. If you face issues with ktd you certainly need to `docker-compose pull` (Joubu, 14:07:59)
    2. The new git server will be live next month, after the October stable releases (Joubu, 14:09:02)

  4. Updates from the Release Maintainers (Joubu, 14:10:44)
    1. October stable releases will be rolled out on 27th (Joubu, 14:11:36)

  5. Updates from the QA team (Joubu, 14:12:18)
    1. @QA - QA ALL THE THINGS. There are easy ones to boost your name on top of the dashboard :) (Joubu, 14:15:23)
    2. Actions from last meeting (Joubu, 14:16:10)

  6. Actions from last meeting (Joubu, 14:16:18)
  7. ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed) (Joubu, 14:16:30)
    1. ACTION: amoyano Will try to provide a Vue alternative to bug 15522 (Joubu, 14:20:26)
    2. ACTION: ashimema Setup a sandbox with lot of circ rules (ideally from production data) to test 15522. Then ask the list for feedback. (Joubu, 14:22:53)

  8. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed) (Joubu, 14:23:28)
    1. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed) (Joubu, 14:24:46)
    2. ACTION: davidnind to add information about what to backport to the release maintainers role page (as a starting point for further notes and guidance) (Joubu, 14:24:56)

  9. ashimema to write a guideline to forbidding the use of type "number" (Joubu, 14:25:03)
    1. https://gitlab.com/koha-community/qa-test-tools/-/issues/38 (Joubu, 14:27:17)
    2. ACTION: ashimema to write a guideline to forbidding the use of type "number" (postponed) (Joubu, 14:28:30)

  10. tuxayo to collect notes (if any) from past&present RMaints about their backport policies. (Joubu, 14:28:41)
    1. tuxayo collected notes from past and present RMaints about their backport policies at https://wiki.koha-community.org/wiki/User:Victor_Grousset_-_tuxayo/Release_maintenance_tips (Joubu, 14:29:25)

  11. General development discussion (trends, ideas, ...) (Joubu, 14:29:44)
  12. What to do when updatedatabase fails ? (Joubu, 14:31:08)
  13. Set time of next meeting (Joubu, 14:41:39)
    1. Next meeting: 28 October 2020, 20 UTC (Joubu, 14:42:11)


Meeting ended at 14:42:28 UTC (full logs).

Action items

  1. amoyano Will try to provide a Vue alternative to bug 15522
  2. ashimema Setup a sandbox with lot of circ rules (ideally from production data) to test 15522. Then ask the list for feedback.
  3. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed)
  4. davidnind to add information about what to backport to the release maintainers role page (as a starting point for further notes and guidance)
  5. ashimema to write a guideline to forbidding the use of type "number" (postponed)


Action items, by person

  1. amoyano
    1. amoyano Will try to provide a Vue alternative to bug 15522
  2. UNASSIGNED
    1. ashimema Setup a sandbox with lot of circ rules (ideally from production data) to test 15522. Then ask the list for feedback.
    2. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed)
    3. davidnind to add information about what to backport to the release maintainers role page (as a starting point for further notes and guidance)
    4. ashimema to write a guideline to forbidding the use of type "number" (postponed)


People present (lines said)

  1. Joubu (86)
  2. ashimema[m] (46)
  3. huginn (11)
  4. jajm (6)
  5. amoyano (6)
  6. tcohen (5)
  7. wahanui (3)
  8. oleonard (2)
  9. koha-jenkins (2)
  10. matts (1)
  11. fridolin (1)


Generated by MeetBot 0.1.4.