#koha: Development IRC meeting 22 December 2021

Meeting started by tuxayo at 15:01:21 UTC (full logs).

Meeting summary

  1. Introductions (tuxayo, 15:01:52)
    1. Fridolin Somers, Biblibre, Tahiti (fridolin, 15:02:07)
    2. Nick Clemens, ByWater Solutions, US (kidclamp, 15:02:35)
    3. Thomas Dukleth, Agogme, New York City (thd, 15:02:39)
    4. David Nind, New Zealand (davidnind, 15:02:39)
    5. Andrew Nugged, National Library of Finland, HELSINKI (nugged, 15:02:40)
    6. Victor Grousset, Tuxayo LLC, France (tuxayo, 15:02:43)

  2. KohaCon22 (tuxayo, 15:04:22)
    1. Deadline is 8 January 2022 and decision was to be made at General IRC meeting 12 January 2022, so far there are no KohaCon22 proposals (tuxayo, 15:04:37)
    2. https://wiki.koha-community.org/wiki/KohaCon22_Proposals (fridolin, 15:05:52)
    3. ACTION: fridolin asks general ML about the discussed KohaCon22 bidding changes and announcement them at the beginning of January if there was not opposition. (tuxayo, 15:16:27)

  3. Update from the Release manager (22.05) (tuxayo, 15:19:19)
    1. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29652#c1 (tuxayo, 15:19:33)
    2. ACTION: fridolin bring back the topic of keeping or not marcflavour a param for: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29652#c1 (tuxayo, 15:23:33)

  4. Updates from the Release Maintainers (tuxayo, 15:24:03)
    1. Tomas Cohen Arazi, Theke Solutions (tcohen, 15:25:51)
    2. Andrew Fuerste-Henry, ByWater Solutions (AndrewFH, 15:26:07)
    3. https://git.koha-community.org/Koha-community/Koha/tags (tuxayo, 15:27:19)
    4. ACTION: tuxayo inform mtj about the minor release (and no big deal if packages come after, no hurry for this one) (tuxayo, 15:30:32)

  5. Updates from the QA team (tuxayo, 15:31:01)
    1. https://gitlab.com/koha-community/qa-test-tools/-/issues/ (tuxayo, 15:38:49)

  6. Updates from the documentation team (tuxayo, 15:40:28)
    1. First documentation IRC meeting for quite some time held on 16 December 2021 (tuxayo, 15:41:01)
    2. https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_2021-12-16 (tuxayo, 15:41:09)
    3. david: I'm reviewing bugs pushed for 22.05 each week and updating a spreadsheet for documentation changes required for 22.05 - see 29640. As part of this I will: (tuxayo, 15:41:30)
    4. add the Manual keyword to the bug if I think documentation changes are required, and (tuxayo, 15:41:35)
    5. add or update the release notes text where required (tuxayo, 15:41:41)
    6. When we have updated the documentation we will add a note to the bug saying: (tuxayo, 15:42:00)
    7. 1) Changes for this bug are now incorporated into the manual. (tuxayo, 15:42:09)
    8. 2) Here are the changes we have made (a link to the commit and section in the manual). (tuxayo, 15:42:15)
    9. 3. Any feedback or suggestions are welcome. (tuxayo, 15:42:21)
    10. 4) Remove the Manual keyword from the bug, if it was used, and add the new keyword Manual-updated. (tuxayo, 15:42:28)

  7. Status of roadmap projects (tuxayo, 15:46:01)
    1. https://annuel.framapad.org/p/koha_21.11_roadmap (tuxayo, 15:46:07)
    2. ACTION: tuxayo calls for volunteers to work on ES 7 support in the koha-devel mailing list (tuxayo, 15:56:22)

  8. General development discussion (trends, ideas, ...) (tuxayo, 16:00:38)
  9. Review of coding guidelines (tuxayo, 16:02:03)
    1. ACTION: tuxayo put in next agenda the 3 postponed QA guidelines review topic (tuxayo, 16:06:08)

  10. Set time of next meeting (tuxayo, 16:06:16)
    1. Next meeting: 5 January 2022, 15 UTC (tuxayo, 16:07:56)


Meeting ended at 16:08:13 UTC (full logs).

Action items

  1. fridolin asks general ML about the discussed KohaCon22 bidding changes and announcement them at the beginning of January if there was not opposition.
  2. fridolin bring back the topic of keeping or not marcflavour a param for: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29652#c1
  3. tuxayo inform mtj about the minor release (and no big deal if packages come after, no hurry for this one)
  4. tuxayo calls for volunteers to work on ES 7 support in the koha-devel mailing list
  5. tuxayo put in next agenda the 3 postponed QA guidelines review topic


Action items, by person

  1. fridolin
    1. fridolin asks general ML about the discussed KohaCon22 bidding changes and announcement them at the beginning of January if there was not opposition.
    2. fridolin bring back the topic of keeping or not marcflavour a param for: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29652#c1
  2. tuxayo
    1. tuxayo inform mtj about the minor release (and no big deal if packages come after, no hurry for this one)
    2. tuxayo calls for volunteers to work on ES 7 support in the koha-devel mailing list
    3. tuxayo put in next agenda the 3 postponed QA guidelines review topic


People present (lines said)

  1. tuxayo (103)
  2. fridolin (46)
  3. tcohen (16)
  4. koha-jenkins (9)
  5. davidnind (8)
  6. huginn` (8)
  7. nugged (7)
  8. wahanui (5)
  9. thd (5)
  10. AndrewFH (5)
  11. schnydszch (2)
  12. kidclamp (1)


Generated by MeetBot 0.1.4.