#koha: Development IRC meeting 12 October 2022
Meeting started by tuxayo at 14:01:36 UTC
(full logs).
Meeting summary
- 
  - https://wiki.koha-community.org/wiki/Development_IRC_meeting_12_October_2022
    Today's agenda (tuxayo,
    14:01:55)
 
 
- Introductions (tuxayo, 14:02:00)
  - Victor Grousset, Tuxayo Empire (tuxayo,
    14:02:23)
 
  - Martin Renvoize, PTFS Europe (ashimema,
    14:02:32)
 
  - Thomas Dukleth, Agogme, New York City
    (thd,
    14:02:53)
 
  - Andrew Nugged, National Library of Finland,
    HELSINKI (nugged,
    14:04:59)
 
 
- Announcements (tuxayo, 14:05:14)
  - , Nick Clemens, ByWater Solutions (kidclamp,
    14:05:51)
 
  - Kyle M Hall, ByWater Solutions (khall,
    14:06:12)
 
  - , Lucas Gass, ByWater Solutions (lukeg,
    14:06:23)
 
  - Marcel de Rooy, Rijksmuseum (marcelr,
    14:08:57)
 
  - https://bit.ly/PerlKohaCon_welcome
    (nugged,
    14:09:34)
 
 
- Update from the Release manager (22.11) (tuxayo, 14:16:53)
  - Tomas Cohen Arazi (tcohen,
    14:18:21)
 
  - ACTION: khall offered
    to restore progress bars if peple file bugs, depending on bug 31666
    for that (tcohen,
    14:22:53)
 
  - ACTION: tcohen will
    send an email with release dates this week, won't differ from usual
    release dates (tcohen,
    14:27:54)
 
 
- Updates from the Release Maintainers (tuxayo, 14:33:43)
 
- Updates from the QA team (tuxayo, 14:36:02)
 
- Status of roadmap projects (tuxayo, 14:44:25)
  - https://annuel.framapad.org/p/koha_22.11_roadmap
    (tuxayo,
    14:44:30)
 
  - ACTION: tcohen and
    thd will arrange a date in the next few days (tcohen,
    14:48:20)
 
 
- Actions from last meeting (tuxayo, 14:51:59)
  - ACTION: tcohen to
    schedule/call a "CSRF day" to work on related patches
    together (tuxayo,
    14:53:00)
 
  - ACTION: cait /Katrin
    to update LTS wiki page with current information from last dev
    meeting (tuxayo,
    14:54:12)
 
  - ACTION: tcohen [WAIT
    after 21.11 release] draft proposal for master→main change and draft
    of action list (tuxayo,
    15:01:15)
 
 
- General development discussion (trends, ideas, ...) (tuxayo, 15:04:28)
  - ACTION: oleonard
    ashimema draft in the developer handbook how to form our modals.
    With template of a simple case and a case with form inside.
    (tuxayo,
    15:09:59)
 
  - ACTION: tuxayo
    postpone «git-bz is stuck on Python 2 which went end of life on
    January 1st 2020.. should we start to consider alternatives?»
    (tuxayo,
    15:11:15)
 
 
- Review of coding guidelines (tuxayo, 15:15:11)
  - ACTION: tuxayo
    postpone «SQL8 of our coding guidelines state that SQL should not be
    in .pl, but should be in the module in C4 or Koha. This would mean
    that SQL in the Koha namespace is allowed and there is no mention of
    DBIC in the coding guidelines right now.» (tuxayo,
    15:18:15)
 
 
- Set time of next meeting (tuxayo, 15:18:28)
  - Next meeting: 26 October 2022, 22 UTC
    (tuxayo,
    15:22:39)
 
 
Meeting ended at 15:27:48 UTC
(full logs).
Action items
  - khall offered to restore progress bars if peple file bugs, depending on bug 31666 for that
 
  - tcohen will send an email with release dates this week, won't differ from usual release dates
 
  - tcohen and thd will arrange a date in the next few days
 
  - tcohen to schedule/call a "CSRF day" to work on related patches together
 
  - cait /Katrin to update LTS wiki page with current information from last dev meeting
 
  - tcohen [WAIT after 21.11 release] draft proposal for master→main change and draft of action list
 
  - oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.
 
  - tuxayo postpone «git-bz is stuck on Python 2 which went end of life on January 1st 2020.. should we start to consider alternatives?»
 
  - tuxayo postpone «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
 
Action items, by person
  -  ashimema 
    - oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.
 
  
 
  -  khall 
    - khall offered to restore progress bars if peple file bugs, depending on bug 31666 for that
 
  
 
  -  oleonard 
    - oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.
 
  
 
  -  tcohen 
    - tcohen will send an email with release dates this week, won't differ from usual release dates
 
    - tcohen and thd will arrange a date in the next few days
 
    - tcohen to schedule/call a "CSRF day" to work on related patches together
 
    - tcohen [WAIT after 21.11 release] draft proposal for master→main change and draft of action list
 
  
 
  -  thd 
    - tcohen and thd will arrange a date in the next few days
 
  
 
  -  tuxayo 
    - tuxayo postpone «git-bz is stuck on Python 2 which went end of life on January 1st 2020.. should we start to consider alternatives?»
 
    - tuxayo postpone «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
 
  
 
People present (lines said)
  - tuxayo (149)
 
  - ashimema (61)
 
  - tcohen (56)
 
  - nugged (35)
 
  - thd (16)
 
  - huginn` (11)
 
  - wahanui (8)
 
  - oleonard (8)
 
  - marcelr (7)
 
  - kidclamp (3)
 
  - lukeg (1)
 
  - khall (1)
 
Generated by MeetBot 0.1.4.