#koha: Development IRC meeting 14 December 2022

Meeting started by tuxayo at 15:01:37 UTC (full logs).

Meeting summary

    1. Nick Clemens, ByWater Solutions (kidclamp, 15:02:51)
    2. Tomas Cohen Arazi, Theke Solutions (tcohen, 15:02:59)
    3. Martin Renvoize, PTFS-Europe (ashimema, 15:03:09)
    4. Thomas Dukleth, Agogme, New York City (thd, 15:03:53)
    5. Victor Grousset, Tuxayo Ltd., France (tuxayo, 15:04:41)
    6. https://wiki.koha-community.org/wiki/Development_IRC_meeting_14_December_2022 Today's agenda (tuxayo, 15:07:16)

  1. Announcements (tuxayo, 15:07:31)
    1. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 15:08:16)
    2. Katrin Fischer, BSZ, Germany (cait, 15:08:38)

  2. Update from the Release manager (tuxayo, 15:09:04)
    1. ACTION: tuxayo open tickets on ktd for the basic stuff needed to easily work on the non-root user (tuxayo, 15:31:02)

  3. Updates from the Release Maintainers (tuxayo, 15:31:56)
  4. Updates from the QA team (tuxayo, 15:36:39)
  5. KohaCon24 bidding (tuxayo, 15:42:21)
    1. ACTION: tuxayo call for a volunteer on mailing lists to open the bidding for KohaCon24 and confirm the task list for that. (tuxayo, 15:56:34)

  6. Status of roadmap projects (tuxayo, 15:56:49)
  7. Actions from last meeting (tuxayo, 16:03:56)
    1. https://annuel.framapad.org/p/koha-styleguide-draft (tuxayo, 16:06:34)
    2. ACTION: tcohen to schedule/call a "CSRF day" to work on related patches together (tuxayo, 16:07:31)
    3. ACTION: tcohen to draft proposal for master→main change and draft of action list (tuxayo, 16:07:40)
    4. ACTION: oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (tuxayo, 16:08:11)

  8. General development discussion (trends, ideas, ...) (tuxayo, 16:08:42)
  9. Review of coding guidelines (tuxayo, 16:22:25)
    1. ACTION: tuxayo defer "SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. (Deferred from previous meeting(s).)" (tuxayo, 16:23:08)

  10. Set time of next meeting (tuxayo, 16:23:13)
    1. Next meeting: 11 January 2023, 15:00 UTC (tuxayo, 16:27:22)


Meeting ended at 16:27:26 UTC (full logs).

Action items

  1. tuxayo open tickets on ktd for the basic stuff needed to easily work on the non-root user
  2. tuxayo call for a volunteer on mailing lists to open the bidding for KohaCon24 and confirm the task list for that.
  3. tcohen to schedule/call a "CSRF day" to work on related patches together
  4. tcohen to draft proposal for master→main change and draft of action list
  5. oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft
  6. tuxayo defer "SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. (Deferred from previous meeting(s).)"


Action items, by person

  1. ashimema
    1. oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft
  2. oleonard
    1. oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft
  3. tcohen
    1. tcohen to schedule/call a "CSRF day" to work on related patches together
    2. tcohen to draft proposal for master→main change and draft of action list
  4. tuxayo
    1. tuxayo open tickets on ktd for the basic stuff needed to easily work on the non-root user
    2. tuxayo call for a volunteer on mailing lists to open the bidding for KohaCon24 and confirm the task list for that.
    3. tuxayo defer "SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. (Deferred from previous meeting(s).)"


People present (lines said)

  1. tuxayo (122)
  2. tcohen (45)
  3. ashimema (36)
  4. cait (31)
  5. thd (16)
  6. huginn (6)
  7. oleonard (2)
  8. liliputech (1)
  9. reiveune (1)
  10. kidclamp (1)


Generated by MeetBot 0.1.4.