#koha: Development IRC meeting 16 November 2022

Meeting started by tuxayo at 15:07:41 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_16_November_2022 Today's agenda (tuxayo, 15:08:28)

  1. Introductions (tuxayo, 15:08:29)
    1. Katrin Fischer, BSZ, Germany (cait, 15:08:37)
    2. Tomas Cohen Arazi, Theke Solutions, Argentina (tcohen, 15:08:46)
    3. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 15:08:49)
    4. Lucas Gass, ByWater Solutions, Colorado, USA (lukeg, 15:09:32)
    5. Victor Grousset, Tuxayo Limited, France (tuxayo, 15:10:09)

  2. Announcements (tuxayo, 15:10:25)
    1. Wiki upgrade is done! Thanks to thd, mtj and tcohen and everyone involved :) (cait, 15:12:43)

  3. Update from the Release manager (22.11) (tuxayo, 15:12:49)
    1. Last translations update done, minor thing (tcohen, 15:13:13)
    2. Please take care of the Major and Critical bugs in the queue ASAP (tcohen, 15:13:39)
    3. Nick Clemens, ByWater Solutions (kidclamp, 15:13:54)
    4. Martin Renvoize, PTFS-E (ashimema, 15:14:08)
    5. Our CI and KTD tools are being upgraded for the new node.js dependencies introduced by ERM, please keep your KTD updated (tcohen, 15:14:10)
    6. the KTD images have been added the node_modules (tcohen, 15:15:49)
    7. to allow offline working (tcohen, 15:16:02)
    8. Thomas Dukleth, Agogme, New York City (thd, 15:16:57)

  4. Elections: Roles for 23.05 (tuxayo, 15:18:06)
    1. https://wiki.koha-community.org/wiki/Roles_for_23.05 (tuxayo, 15:18:24)
    2. VOTE: Voted on "Do you approve the current proposals for the 23.05 team?" Results are, Yes: 7 (cait, 15:29:29)
    3. AGREED: The release team for 23.05 is elected as stated on the wiki page today :) (cait, 15:29:57)

  5. Updates from the Release Maintainers (cait, 15:31:35)
  6. Updates from the QA team (cait, 15:32:47)
  7. Status of roadmap projects (cait, 15:33:42)
    1. update on road map is postponed to next meeting (cait, 15:34:32)

  8. Actions form last meeting (cait, 15:34:41)
    1. ACTION: cait Update wiki page for LTS (cait, 15:35:04)
    2. ACTION: tcohen to schedule/call a "CSRF day" to work on related patches together - deferred until after the 22.11 release (cait, 15:35:53)
    3. ACTION: tcohen to draft proposal for master→main change and draft of action list (cait, 15:36:10)
    4. ACTION: oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the draft style guide (WIP) (cait, 15:36:21)

  9. General development discussion (cait, 15:36:47)
    1. Question: Can we claim ES7 support now? (cait, 15:37:09)
    2. Topics postponed to next meeting (after release) (cait, 15:39:20)

  10. Set time of next meeting (cait, 15:39:35)
    1. Next meeting: 30 November 2022, 15 UTC (cait, 15:41:54)


Meeting ended at 15:42:08 UTC (full logs).

Action items

  1. cait Update wiki page for LTS
  2. tcohen to schedule/call a "CSRF day" to work on related patches together - deferred until after the 22.11 release
  3. tcohen to draft proposal for master→main change and draft of action list
  4. oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the draft style guide (WIP)


Action items, by person

  1. ashimema
    1. oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the draft style guide (WIP)
  2. cait
    1. cait Update wiki page for LTS
  3. oleonard
    1. oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.: focus is currently on staff interface redesign changes, see the draft style guide (WIP)
  4. tcohen
    1. tcohen to schedule/call a "CSRF day" to work on related patches together - deferred until after the 22.11 release
    2. tcohen to draft proposal for master→main change and draft of action list


People present (lines said)

  1. cait (67)
  2. tuxayo (43)
  3. ashimema (35)
  4. tcohen (29)
  5. huginn` (8)
  6. thd (8)
  7. oleonard (7)
  8. lukeg (4)
  9. khall (2)
  10. kidclamp (2)


Generated by MeetBot 0.1.4.