#koha: Development IRC meeting 17 August 2022

Meeting started by cait1 at 14:14:28 UTC (full logs).

Meeting summary

  1. Introductions (cait1, 14:14:34)
    1. Tomas Cohen Arazi (tcohen, 14:14:46)
    2. Nick Clemens, ByWater Solutions (kidclamp, 14:14:55)
    3. Katrin Fischer, BSZ, Konstanz (cait1, 14:15:06)
    4. Martin Renvoize, PTFS Europe (ashimema, 14:15:09)
    5. Jonathan Druart (Joubu, 14:15:11)
    6. Thomas Dukleth, Agogme, New York City (thd, 14:15:19)
    7. https://wiki.koha-community.org/wiki/Development_IRC_meeting_17_August_2022 Meeting agenda for today (cait1, 14:15:20)
    8. Marcel de Rooy (marcelr, 14:16:05)

  2. Announcements (cait1, 14:17:34)
    1. Kyle M Hall, ByWater Solutions (khall, 14:17:45)
    2. Online registrationf or KohaCon22 closes end of August - get registered! (cait1, 14:17:50)
    3. Joubu says thank for helping the complex Bug 27272 along (cait1, 14:19:40)

  3. Update from the release manager (22.05) (cait1, 14:20:34)
    1. RM Tomas will be afk from 5th-10th September (cait1, 14:21:07)
    2. RM assistants will step in if needed (cait1, 14:21:21)
    3. The RM requests more eyes on bug 29697 failing test when run in non-light mode (tcohen, 14:23:37)
    4. ACTION: ashimema needs to remove an introduced warning on bug 28854 tests (or test for its existence) (cait1, 14:24:04)

  4. Updates from the release maintainers (cait1, 14:29:07)
    1. String freeze has been called, translations have been updated, go translate! (cait1, 14:30:39)

  5. Updates from the QA team (cait1, 14:31:15)
    1. Lots of progress on Joubu's bugs before his pendng leave - thanks to the team! (cait1, 14:31:39)
    2. QA and NSO queues are down a little, but we got a bit more bad bugs (cait1, 14:32:17)

  6. Status of roadmap projects (cait1, 14:34:41)
    1. https://annuel.framapad.org/p/koha_22.11_roadmap (tcohen, 14:35:00)
    2. ACTION: Task queue: marcelr willt take on bugs 27421 and 30718 (cait1, 14:39:04)
    3. Wiki update: test run (and maybe more ) scheduled for next Tuesday (2022-08-23) (cait1, 14:39:57)
    4. ACTION: qa_team high priority for bugs 30462 and 30982 (cait1, 14:41:00)
    5. ERM: test the UI (sandbox is provided), read the code, be involved (cait1, 14:44:03)
    6. Staff interface design: Test and give feedback, sandbox also provided (cait1, 14:44:49)
    7. ERM: entry point is Taiga: https://tree.taiga.io/project/joubu-koha-erm/wiki/home (cait1, 14:45:05)

  7. Actions from last meeting (cait1, 14:45:35)
    1. ACTION: liliputech (deferred from previous meeting) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI. (cait1, 14:46:05)

  8. General development discussion (trends, ideas) (cait1, 14:46:17)
    1. First LTS version will be 22.11, maintained for 3 years. Regular releases maintained for 1.5 years. Support for LTS versions will overlap 1.5 years. 4 Rmaints required, but we expect lower load on the older LTS. (cait1, 14:47:28)
    2. ACTION: Katrin to update LTS wiki page with current information from last dev meeting (cait1, 14:48:25)
    3. https://git.koha-community.org/Koha-community/Koha/src/branch/master/Koha/Object.pm#L664 (ashimema, 14:58:53)
    4. ACTION: tcohen will make a counter proposal about public_read_list() (cait1, 15:03:29)
    5. ACTION: Martin will file a bug making Koha::Object::public_read_list throw an exception (tcohen, 15:08:13)
    6. When adding a private attribute to a Koha::Object class, remember to check public_read_list() (tcohen, 15:08:55)

  9. Review of coding guidelines (cait1, 15:09:01)
    1. ACTION: tcohen to add anything relevant to next meeting's agenda (or point out the bugs) (cait1, 15:10:33)

  10. Set time of next meeting (cait1, 15:10:39)
    1. Next meeting: 31 August 2022, 21 UTC (cait1, 15:12:03)


Meeting ended at 15:12:09 UTC (full logs).

Action items

  1. ashimema needs to remove an introduced warning on bug 28854 tests (or test for its existence)
  2. Task queue: marcelr willt take on bugs 27421 and 30718
  3. qa_team high priority for bugs 30462 and 30982
  4. liliputech (deferred from previous meeting) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
  5. Katrin to update LTS wiki page with current information from last dev meeting
  6. tcohen will make a counter proposal about public_read_list()
  7. Martin will file a bug making Koha::Object::public_read_list throw an exception
  8. tcohen to add anything relevant to next meeting's agenda (or point out the bugs)


Action items, by person

  1. ashimema
    1. ashimema needs to remove an introduced warning on bug 28854 tests (or test for its existence)
  2. marcelr
    1. Task queue: marcelr willt take on bugs 27421 and 30718
  3. tcohen
    1. tcohen will make a counter proposal about public_read_list()
    2. tcohen to add anything relevant to next meeting's agenda (or point out the bugs)
  4. UNASSIGNED
    1. qa_team high priority for bugs 30462 and 30982
    2. liliputech (deferred from previous meeting) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
    3. Katrin to update LTS wiki page with current information from last dev meeting
    4. Martin will file a bug making Koha::Object::public_read_list throw an exception


People present (lines said)

  1. cait1 (106)
  2. tcohen (102)
  3. ashimema (41)
  4. Joubu (13)
  5. huginn (13)
  6. wahanui (12)
  7. marcelr (10)
  8. thd (8)
  9. tuxayo (3)
  10. wajasu (3)
  11. kidclamp (1)
  12. anne (1)
  13. khall (1)


Generated by MeetBot 0.1.4.