#koha: Development IRC meeting 20 July 2022

Meeting started by tuxayo at 14:02:10 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_20_July_2022 Today's agenda (tuxayo, 14:02:39)

  1. Introductions (tuxayo, 14:02:48)
    1. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:02:56)
    2. Marcel de Rooy, Rijksmuseum (marcelr, 14:03:06)
    3. Paul Derscheid, LMSCloud GmbH, Munich, Germany (paulderscheid[m], 14:03:12)
    4. Katrin Fischer, BSZ, Germany (cait1, 14:03:14)
    5. Nick Clemens, ByWater Solutions (kidclamp, 14:03:19)
    6. Jonathan Druart (Joubu, 14:03:21)
    7. Thomas Dukleth, Agogme, New York City (thd, 14:03:22)
    8. Victor Grousset, Tuxayo Europe, France (tuxayo, 14:03:47)
    9. Kyle M Hall, ByWater Solutions (khall, 14:03:49)
    10. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:03:54)

  2. Announcements (tuxayo, 14:04:39)
    1. Martin Renvoize (ashimema, 14:05:17)
    2. https://github.com/vector-im/element-web#running-from-docker (tcohen, 14:19:25)
    3. Joubu needs help on bugs 27272, 30718, 30982, 27421 and ERM before going AFK in less than a month. (tuxayo, 14:21:22)

  3. Update from the Release manager (22.05) (tuxayo, 14:26:19)
    1. master has had some small hiccups, but I've managed to push enhancements and new features (tcohen, 14:27:06)
    2. tried to detect possible conflicts with bugfixes as much as possible until last week (tcohen, 14:27:44)

  4. Updates from the Release Maintainers (tuxayo, 14:37:57)
  5. Updates from the QA team (tuxayo, 14:49:41)
  6. Status of roadmap projects (tuxayo, 14:56:29)
    1. https://annuel.framapad.org/p/koha_22.11_roadmap (tcohen, 14:57:18)
    2. ashimema and tcohen have been talking about spending some days on C4::Reserves (tcohen, 14:58:09)
    3. many things in the Roadmap have patches and need eyes/testing (tcohen, 14:59:01)
    4. https://koha-mw-my-test00-upgr.agogme.com/ is not up yet. I just now fixed a manual package override needed for running apt-listbugs for a kfreebsd issue nothing to do. (thd, 15:01:39)
    5. https://koha-mw-my-test01-upgr.agogme.com on Debian 9 is still current at this moment. (thd, 15:03:31)
    6. https://koha-mw-my-test00-upgr.agogme.com should become current anytime now. (thd, 15:03:58)
    7. https://hub.docker.com/_/mediawiki (tcohen, 15:06:04)
    8. https://wiki.koha-community.org/wiki/Special:Version (tuxayo, 15:13:12)
    9. https://koha-mw-my-test01-upgr.agogme.com/wiki/Special:Version (tuxayo, 15:13:16)

  7. Actions from last meeting (tuxayo, 15:18:37)
    1. https://lite.framacalc.org/29o8a7mlwc-9v57 (tuxayo, 15:19:39)
    2. https://koha-mw-my-test01-upgr.agogme.com still works fine and is perfectly good for testing but we might have some different bug with Debian 10. (thd, 15:21:52)
    3. ACTION: davidnind Extended support/LTS release - send notice to mailing list (tuxayo, 15:33:55)
    4. ACTION: Extended support/LTS release - vote at the next meeting with questions added to the agenda, those unable to attend (time zone challenges) can add their votes to the agenda (tuxayo, 15:34:18)
    5. https://wiki.koha-community.org/wiki/KohaCon23_Proposals (tuxayo, 15:34:58)
    6. https://lists.koha-community.org/pipermail/koha-devel/2022-July/047210.html (tuxayo, 15:35:47)
    7. ACTION: liliputech discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI. (tuxayo, 15:38:45)
    8. ACTION: tuxayo postpone Update guidelines with the replacement of jQueryUI Datepicker with flatpickr (tuxayo, 15:39:11)

  8. Set time of next meeting (tuxayo, 15:39:18)
    1. Next meeting: 3 August 2022, 21 UTC (tuxayo, 15:41:37)
    2. meeting after the next one: 17 August 2022, 14 UTC (tuxayo, 15:44:36)
    3. Gitlab approved our Open Source Program status (tuxayo, 15:48:26)


Meeting ended at 15:49:05 UTC (full logs).

Action items

  1. davidnind Extended support/LTS release - send notice to mailing list
  2. Extended support/LTS release - vote at the next meeting with questions added to the agenda, those unable to attend (time zone challenges) can add their votes to the agenda
  3. liliputech discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
  4. tuxayo postpone Update guidelines with the replacement of jQueryUI Datepicker with flatpickr


Action items, by person

  1. tuxayo
    1. tuxayo postpone Update guidelines with the replacement of jQueryUI Datepicker with flatpickr
  2. UNASSIGNED
    1. davidnind Extended support/LTS release - send notice to mailing list
    2. Extended support/LTS release - vote at the next meeting with questions added to the agenda, those unable to attend (time zone challenges) can add their votes to the agenda
    3. liliputech discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.


People present (lines said)

  1. tuxayo (136)
  2. tcohen (109)
  3. cait1 (80)
  4. ashimema (55)
  5. Joubu (52)
  6. thd (29)
  7. koha-jenkins (16)
  8. huginn (14)
  9. wahanui (11)
  10. oleonard (7)
  11. marcelr (4)
  12. paulderscheid[m] (4)
  13. wajasu (3)
  14. alohabot (1)
  15. khall (1)
  16. kidclamp (1)


Generated by MeetBot 0.1.4.