#koha: Development IRC meeting 26 October 2022

Meeting started by davidnind[m] at 22:01:07 UTC (full logs).

Meeting summary

    1. Agenda https://wiki.koha-community.org/wiki/Development_IRC_meeting_26_October_2022 (davidnind[m], 22:01:55)

  1. Introductions (davidnind[m], 22:02:05)
    1. David Nind, New Zealand (davidnind[m], 22:02:14)
    2. David Cook, Australia (dcook, 22:03:05)
    3. Thomas Dukleth, Agogme, New York City [wiki change live but DNS change pending] (thd, 22:03:39)

  2. Announcements (davidnind[m], 22:08:40)
    1. Roles for 23.05 are now open https://wiki.koha-community.org/wiki/Roles_for_23.05 (davidnind[m], 22:09:15)
    2. Lucas Gass, ByWater Solutions (lukeg, 22:09:48)
    3. ACTION: davidnind to send an email to the mailing lists on roles for 23.05 (davidnind[m], 22:11:19)
    4. Wiki upgrade in progress, thd will send a note when DNS changeover is completed and the updated Wiki is available (davidnind[m], 22:12:42)
    5. Updated Wiki available at https://wiki2.test.koha-community.org - there may be a brief outage while DNS is changed (davidnind[m], 22:13:47)

  3. Actions from last meeting (davidnind[m], 22:16:56)
    1. tcohen will send an email with release dates this week, won't differ from usual release dates: Email sent (https://lists.koha-community.org/pipermail/koha-devel/2022-October/047350.html) (davidnind[m], 22:22:21)
    2. tcohen and thd will arrange a date in the next few days: Wiki migration in progress!!! (davidnind[m], 22:23:22)
    3. tcohen to schedule/call a "CSRF day" to work on related patches together: the CSRF day didn't have much attention on it, might defer post-release unless people speak up (davidnind[m], 22:24:42)
    4. ACTION: tcohen to schedule/call a "CSRF day" to work on related patches together - deferred until after the 22.11 release (davidnind[m], 22:27:07)
    5. cait to update LTS wiki page with current information from last dev meeting - volunteer required as cait is crazy busy! (davidnind[m], 22:28:28)
    6. volunteers required for updating info LTS wiki page with info from last meeting (davidnind[m], 22:29:29)
    7. ACTION: davdnind to send a request to the mailing list for someone to update LTS wiki page (will do if no one else is available) (davidnind[m], 22:30:25)
    8. ACTION: tcohen [WAIT until after 21.11 release] to draft proposal for master→main change and draft of action list (davidnind[m], 22:31:26)
    9. ACTION: oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. (davidnind[m], 22:32:01)
    10. ashimema has started a draft of the style guide (https://annuel.framapad.org/p/koha-styleguide-draft), oleonard will probably be focusing on template fixes until the release (davidnind[m], 22:32:40)
    11. khall offered to restore progress bars if people file bugs depending on bug 31666 for that (davidnind[m], 22:33:22)

  4. General development discussion (davidnind[m], 22:34:32)
  5. Review of coding guidelines (davidnind[m], 22:43:37)
    1. Agenda item about SQL8 coding guideline deferred until the next meeting (davidnind[m], 22:45:47)
    2. When using the new MediaWiki VisualEditor, it is best to save any changes before switching to the source code editor or vice a versa (davidnind[m], 22:50:03)
    3. Please log any Wiki upgrade issues in Bugzilla (davidnind[m], 22:53:16)

  6. Set time of next meeting (davidnind[m], 22:53:31)
    1. Next meeting: 9 November 2022, 15:00 UTC (davidnind[m], 22:53:53)


Meeting ended at 22:59:37 UTC (full logs).

Action items

  1. davidnind to send an email to the mailing lists on roles for 23.05
  2. tcohen to schedule/call a "CSRF day" to work on related patches together - deferred until after the 22.11 release
  3. davdnind to send a request to the mailing list for someone to update LTS wiki page (will do if no one else is available)
  4. tcohen [WAIT until after 21.11 release] to draft proposal for master→main change and draft of action list
  5. oleonard ashimema draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside.


People present (lines said)

  1. davidnind[m] (74)
  2. thd (26)
  3. dcook (10)
  4. lukeg (4)
  5. huginn` (4)
  6. wahanui (2)
  7. aleisha (2)
  8. dcook_ (1)


Generated by MeetBot 0.1.4.