#koha: Development IRC meeting 28 September 2022

Meeting started by tuxayo_ at 21:08:15 UTC (full logs).

Meeting summary

  1. Introductions (tuxayo_, 21:08:20)
    1. Alex Buckley, Catalyst IT, NZ (alexbuckley, 21:08:40)
    2. https://wiki.koha-community.org/wiki/Development_IRC_meeting_28_September_2022#Agenda Today's agenda (tuxayo_, 21:08:50)
    3. David Nind, NZ (davidnind[m], 21:09:01)
    4. Thomas Dukleth, Agogme, New York City (thd, 21:09:02)
    5. Victor Grousset, Tuxayo Empire, France (tuxayo_, 21:10:03)
    6. Fridolin Somers, Biblibre, France (fridolin, 21:10:14)

  2. Announcements (tuxayo_, 21:13:06)
    1. Individual videos and slides (where available) are now online! https://koha-us.org/2022/09/27/kohacon22-slides-recordings/ (davidnind[m], 21:13:54)
    2. Thanks to koha-US for organising KohaCon22 (davidnind[m], 21:14:22)
    3. Brendan Gallagher ByWater (bag, 21:15:25)

  3. Update from the Release manager (22.11) (tuxayo_, 21:18:25)
  4. Updates from the Release Maintainers (tuxayo_, 21:19:11)
  5. Updates from the QA team (tuxayo_, 21:20:42)
    1. support companies: please relay patch testing sessions to your customers that would be keen to test patch. (announcement in the koha general list) (tuxayo_, 21:25:38)

  6. Status of roadmap projects (tuxayo_, 21:28:05)
    1. https://annuel.framapad.org/p/koha_22.11_roadmap (tuxayo_, 21:28:30)
    2. Andrew Nugged, National Library of Finland, HELSINKI (nugged, 21:28:44)
    3. https://bit.ly/PerlKohaCon_welcome (nugged, 21:31:06)
    4. https://intro.perlkohacon.fi/ (nugged, 21:31:11)

  7. Actions from last meeting (tuxayo_, 21:45:43)
    1. ACTION: tcohen to schedule/call a "CSRF day" to work on related patches together (tuxayo_, 21:46:03)
    2. ACTION: cait /Katrin to update LTS wiki page with current information from last dev meeting (tuxayo_, 21:48:51)
    3. ACTION: ashimema will file a bug making Koha::Object::public_read_list throw an exception (tuxayo_, 21:49:08)
    4. ACTION: tcohen draft proposal for master→main change and draft of action list (tuxayo_, 21:49:38)

  8. General development discussion (trends, ideas, ...) (tuxayo_, 21:50:18)
    1. ACTION: thd (tuxayo_, 21:53:52)
    2. ACTION: thd give their two cents on bug 31150 in order to tilt the scale to on side. (tuxayo_, 21:54:58)
    3. ACTION: tuxayo ask on the mailing list « are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master. » (tuxayo_, 21:57:31)
    4. ACTION: tuxayo postpone «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. » (tuxayo_, 22:04:59)
    5. ACTION: tuxayo can for volunteers on the mailing list to «Update coding guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki. cc Aleisha who had trouble with using flatpickr for the detail of what is missing» (tuxayo_, 22:07:19)
    6. ACTION: tuxayo maybe create a ticket for updating the guidelines about flatpickr (tuxayo_, 22:10:10)

  9. Set time of next meeting (tuxayo_, 22:10:24)
    1. Bug 31645 created for updating coding guidelines for flatpickr (davidnind[m], 22:15:44)
    2. Next meeting: 12 October 2022, 14 UTC (tuxayo_, 22:22:08)


Meeting ended at 22:22:49 UTC (full logs).

Action items

  1. tcohen to schedule/call a "CSRF day" to work on related patches together
  2. cait /Katrin to update LTS wiki page with current information from last dev meeting
  3. ashimema will file a bug making Koha::Object::public_read_list throw an exception
  4. tcohen draft proposal for master→main change and draft of action list
  5. thd
  6. thd give their two cents on bug 31150 in order to tilt the scale to on side.
  7. tuxayo ask on the mailing list « are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master. »
  8. tuxayo postpone «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. »
  9. tuxayo can for volunteers on the mailing list to «Update coding guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki. cc Aleisha who had trouble with using flatpickr for the detail of what is missing»
  10. tuxayo maybe create a ticket for updating the guidelines about flatpickr


Action items, by person

  1. thd
    1. thd
    2. thd give their two cents on bug 31150 in order to tilt the scale to on side.
  2. UNASSIGNED
    1. tcohen to schedule/call a "CSRF day" to work on related patches together
    2. cait /Katrin to update LTS wiki page with current information from last dev meeting
    3. ashimema will file a bug making Koha::Object::public_read_list throw an exception
    4. tcohen draft proposal for master→main change and draft of action list
    5. tuxayo ask on the mailing list « are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master. »
    6. tuxayo postpone «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. »
    7. tuxayo can for volunteers on the mailing list to «Update coding guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki. cc Aleisha who had trouble with using flatpickr for the detail of what is missing»
    8. tuxayo maybe create a ticket for updating the guidelines about flatpickr


People present (lines said)

  1. tuxayo_ (130)
  2. thd (33)
  3. davidnind[m] (30)
  4. nugged (19)
  5. fridolin (19)
  6. huginn` (9)
  7. wahanui (4)
  8. alexbuckley (2)
  9. bag (1)


Generated by MeetBot 0.1.4.