#koha: Development IRC meeting 31 August 2022
Meeting started by tuxayo at 21:00:28 UTC
(full logs).
Meeting summary
- Introductions (tuxayo, 21:00:42)
  - Victor Grousset, Tuxayo Spa Pty, France
    (tuxayo,
    21:00:46)
- Alex Buckley, Catalyst IT, NZ (alexbuckley,
    21:01:28)
- Fridolin Somers, Biblibre, France (fridolin,
    21:05:08)
- Thomas Dukleth, Agogme, New York City
    (thd,
    21:07:20)
- Aleisha Amohia, Catalyst IT, Wellington New
    Zealand (aleisha,
    21:07:37)
- https://wiki.koha-community.org/wiki/Development_IRC_meeting_31_August_2022
    Today's agenda (tuxayo,
    21:11:44)
 
 
- Announcements (tuxayo, 21:12:28)
 
- Update from the Release manager (22.05) (tuxayo, 21:13:31)
 
- Updates from the Release Maintainers (tuxayo, 21:15:39)
 
- Updates from the QA team (tuxayo, 21:17:04)
  - lots of old bugs that need shifting
    (aleisha,
    21:18:04)
- many of the team are on holiday (or will be
    soon) so community help to clear some old and bad bugs from the list
    would be much appreciated! (aleisha,
    21:19:00)
 
 
- Status of roadmap projects (tuxayo, 21:21:46)
  - https://annuel.framapad.org/p/koha_22.11_roadmap
    Roadmap (tuxayo,
    21:22:07)
 
 
- Actions from last meeting (tuxayo, 21:32:27)
  - ACTION: ashimema
    needs to remove an introduced warning on bug 28854 tests (or test
    for its existence) (tuxayo,
    21:33:00)
- ACTION: liliputech
    (deferred from previous meetingx2) discuss koha CI (docker image
    built + manual build) hosting on gitlab instance provided by
    BibLibre's partner AFI. (tuxayo,
    21:34:30)
- ACTION: Katrin to
    update LTS wiki page with current information from last dev
    meeting (tuxayo,
    21:35:51)
- ACTION: tcohen will
    make a counter proposal about public_read_list() (tuxayo,
    21:36:15)
- ACTION: ashimema will
    file a bug making Koha::Object::public_read_list throw an
    exception (tuxayo,
    21:37:03)
- ACTION: rename the
    master branch to 'main' (aleisha,
    21:37:54)
- ACTION: document the
    use of flatpickr in the koha community wiki (aleisha,
    21:38:17)
 
 
- General development discussion (trends, ideas, ...) (tuxayo, 21:39:37)
  - ACTION: tuxayo
    propose change from master branch in the other meeting slot
    (EU-AM) (tuxayo,
    22:02:03)
- ACTION: tuxayo defer
    «Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL
    8 on main/master.» (tuxayo,
    22:22:33)
- ACTION: tuxayo defer
    «Can we claim ES7 support now?» (tuxayo,
    22:31:25)
 
 
- Review of coding guidelines (tuxayo, 22:37:13)
  - using and configuring flatpickr needs to be
    documented (aleisha,
    22:37:52)
- ACTION: defer coding
    guideline «SQL8 of our coding guidelines state that SQL should not
    be in .pl, but should be in the module in C4 or Koha. This would
    mean that SQL in the Koha namespace is allowed and there is no
    mention of DBIC in the coding guidelines right now.» (tuxayo,
    22:41:32)
- ACTION: tuxayo defer
    coding guideline «SQL8 of our coding guidelines state that SQL
    should not be in .pl, but should be in the module in C4 or Koha.
    This would mean that SQL in the Koha namespace is allowed and there
    is no mention of DBIC in the coding guidelines right now.»
    (tuxayo,
    22:41:40)
- ACTION: tuxayo defer
    QA guidelines: «Update guidelines with the replacement of jQueryUI
    Datepicker with flatpickr - introduced in bug 29239» (tuxayo,
    22:51:30)
 
 
- Set time of next meeting (tuxayo, 22:51:53)
  - Next meeting: 14 September 2022, 14 UTC
    (tuxayo,
    22:53:39)
- Next Oceania-Americas meeting: 29 September
    2022, 21 UTC (tuxayo,
    22:54:22)
 
Meeting ended at 22:54:30 UTC
(full logs).
Action items
  - ashimema needs to remove an introduced warning on bug 28854 tests (or test for its existence)
- liliputech (deferred from previous meetingx2) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
- Katrin to update LTS wiki page with current information from last dev meeting
- tcohen will make a counter proposal about public_read_list()
- ashimema will file a bug making Koha::Object::public_read_list throw an exception
- rename the master branch to 'main'
- document the use of flatpickr in the koha community wiki
- tuxayo propose change from master branch in the other meeting slot (EU-AM)
- tuxayo defer «Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master.»
- tuxayo defer «Can we claim ES7 support now?»
- defer coding guideline «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
- tuxayo defer coding guideline «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
- tuxayo defer QA guidelines: «Update guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239»
Action items, by person
  -  tuxayo 
    - tuxayo propose change from master branch in the other meeting slot (EU-AM)
- tuxayo defer «Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master.»
- tuxayo defer «Can we claim ES7 support now?»
- tuxayo defer coding guideline «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
- tuxayo defer QA guidelines: «Update guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239»
 
- UNASSIGNED
    - ashimema needs to remove an introduced warning on bug 28854 tests (or test for its existence)
- liliputech (deferred from previous meetingx2) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.
- Katrin to update LTS wiki page with current information from last dev meeting
- tcohen will make a counter proposal about public_read_list()
- ashimema will file a bug making Koha::Object::public_read_list throw an exception
- rename the master branch to 'main'
- document the use of flatpickr in the koha community wiki
- defer coding guideline «SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now.»
 
People present (lines said)
  - tuxayo (177)
- thd (28)
- aleisha (28)
- alexbuckley (23)
- huginn` (16)
- fridolin (11)
- wahanui (2)
Generated by MeetBot 0.1.4.