#koha: Development IRC meeting 3 August 2022

Meeting started by davidnind[m] at 21:09:54 UTC (full logs).

Meeting summary

  1. Introductions (davidnind[m], 21:10:18)
    1. David Nind, New Zealand (davidnind[m], 21:10:36)
    2. Alex Buckley, Catalyst IT NZ (alexbuckley, 21:10:45)
    3. Aleisha Amohia, Catalyst IT NZ (aleisha, 21:10:47)
    4. Thomas Dukleth, Agogme, New York City (thd, 21:10:53)
    5. Chris Cormack, Catalyst IT NZ (rangi[m], 21:10:56)

  2. Announcements (davidnind[m], 21:15:43)
    1. Katrin Fischer, BSZ, Germany (cait, 21:17:02)
    2. Closing date for registrations for KohaCon22 is 31 August 2022 (davidnind[m], 21:17:26)
    3. https://koha-us.org/events/conferences/kohacon22/ (davidnind[m], 21:17:36)
    4. Closing date for KohaCon23 proposals is 6 September 2022 (none yet) https://wiki.koha-community.org/wiki/KohaCon23_Proposals (davidnind[m], 21:18:16)

  3. Update from the Release manager (22.05) (davidnind[m], 21:19:00)
  4. Updates from the Release Maintainers (davidnind[m], 21:24:20)
    1. Maintenance releases were released for all supported versions, was also a security release as well (davidnind[m], 21:26:30)

  5. Updates from the QA team (davidnind[m], 21:27:08)
  6. Status of roadmap projects (davidnind[m], 21:32:49)
    1. https://koha-mw-pg-test02.agogme.com/wiki/Main_Page Postgres restore in Debian 8 pg_restore no errors. (thd, 21:36:24)
    2. https://koha-mw-my-test02.agogme.com/wiki/Main_Page MySQL migration in Debian 8 (thd, 21:36:24)
    3. https://koha-mw-my-test00-upgr.agogme.com/wiki/Main_Page Upgraded to LTS Debian 10 but not currently built from error free pg_restore. (thd, 21:37:20)
    4. https://github.com/CanastaWiki/Canasta/blob/master/Dockerfile (thd, 21:38:51)
    5. Victor Grousset, Tuxayo IT, France (tuxayo, 21:39:06)
    6. dedicated sandbox to view the staff interface redesign: https://sandboxes.biblibre.eu/ (tuxayo, 21:43:20)
    7. https://staff-bug30952.sandboxes.biblibre.eu/ (davidnind[m], 21:43:21)
    8. Thanks for those reviewing the staff interface redesign, please continue to provide feedback on bug 30952 and can preview at https://staff-bug30952.sandboxes.biblibre.eu/ (davidnind[m], 21:46:02)

  7. Actions from last meeting (davidnind[m], 21:46:13)
    1. ACTION: liliputech (deferred from previous meeting) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI. (davidnind[m], 21:48:20)

  8. General development discussion (trends, ideas, ...) (davidnind[m], 21:49:50)
  9. Vote on LTS version (davidnind[m], 21:50:12)
    1. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31008#c1 (tuxayo, 21:51:43)
    2. graph of LTS proposal https://lite.framacalc.org/29o8a7mlwc-9v57 (tuxayo, 21:52:23)
    3. VOTE: Voted on "Which Koha version will be the first LTS version?" Results are (davidnind[m], 21:59:02)
    4. Fridolin Somers, Biblibre, Tahiti (fridolin, 22:01:07)
    5. VOTE: Voted on "Which Koha version will be the first LTS version?" Results are, 22-11: 6 (davidnind[m], 22:05:12)
    6. AGREED: The first LTS/extended support version will be 22.11 (davidnind[m], 22:05:39)
    7. Option 3 for voting = 4 RMaints constantly, 1.5 years maintenance for regular releases, 3.5 years maintenance for LTS release, 1.5 year overlap between LTS releases (davidnind[m], 22:25:18)
    8. AGREED: To use option 3 (see details in comments) as the maintenance model for the LTS/extended support version of Koha (see https://lite.framacalc.org/29o8a7mlwc-9v57 for details) (davidnind[m], 22:28:26)
    9. All other agenda items deferred to the next meeting (davidnind[m], 22:28:53)

  10. Set time of next meeting (davidnind[m], 22:28:58)
    1. see bug 31008 for other details about how the LTS should be handled (scope of what to include, regularity of releases) (tuxayo, 22:30:05)
    2. Next meeting: 17 August 2022, 14 UTC (tuxayo, 22:30:52)


Meeting ended at 22:31:22 UTC (full logs).

Action items

  1. liliputech (deferred from previous meeting) discuss koha CI (docker image built + manual build) hosting on gitlab instance provided by BibLibre's partner AFI.


People present (lines said)

  1. cait (101)
  2. davidnind[m] (70)
  3. tuxayo (58)
  4. thd (20)
  5. rangi[m] (19)
  6. huginn` (15)
  7. fridolin (12)
  8. aleisha (6)
  9. alexbuckley (4)
  10. wahanui (2)


Generated by MeetBot 0.1.4.