#koha: Development IRC meeting 5 January 2022

Meeting started by tuxayo at 15:00:52 UTC (full logs).

Meeting summary

  1. Introductions (tuxayo, 15:01:10)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_5_January_2022 Today's agenda (tuxayo, 15:01:28)
    2. Katrin Fischer, BSZ, Germany (cait1, 15:01:37)
    3. Victor Grousset, Tuxayo GmbH, France (tuxayo, 15:01:52)
    4. Fridolin Somers, Biblibre, France (fridolin, 15:01:57)
    5. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 15:02:09)
    6. Jonathan Druart (Joubu, 15:02:21)
    7. Andrew Fuerste-Henry, ByWater Solutions (AndrewFH, 15:02:35)
    8. Thomas Dukleth, Agogme, New York City [major COVID-19 centre take care] (thd, 15:02:37)
    9. , Nick Clemens, ByWater Solutions (kidclamp, 15:03:28)

  2. Announcements (tuxayo, 15:03:56)
    1. Enjoy 2022! (Joubu, 15:04:16)

  3. Update from the Release manager (21.11) (tuxayo, 15:06:13)
  4. Updates from the Release Maintainers (tuxayo, 15:08:53)
    1. Andrew Nugged, National Library of Finland, HELSINKI (nugged, 15:08:53)

  5. Status of roadmap projects (tuxayo, 15:14:57)
  6. Actions from last meeting (tuxayo, 15:18:54)
    1. https://wiki.koha-community.org/wiki/Processes_for_KohaCons#Continent_rotation (fridolin, 15:32:07)
    2. ACTION: fridolin announces timeframe extension (end of feb) and for this one allow proposals outside eligible continents, keeping priority to actual ones (tuxayo, 15:37:06)
    3. ACTION: fridolin chances wiki page with "An online conference bid will not make a continent ineligible for hosting an in-person conference the following year". And announcement de change (tuxayo, 15:37:12)
    4. ACTION: fridolin open ticket about removing marcflavour as a param in context of bug 29652. Add it a dependency of bug 27268. (tuxayo, 15:44:17)
    5. https://gitlab.com/koha-community/qa-test-tools/-/issues/55 (tuxayo, 15:45:13)
    6. https://gitlab.com/koha-community/qa-test-tools/-/issues/55 (fridolin, 15:45:31)

  7. General development discussion (trends, ideas, ...) (tuxayo, 15:48:17)
  8. Review of coding guidelines (tuxayo, 15:57:32)
    1. https://wiki.koha-community.org/wiki/Coding_Guidelines#JS5:_Enabling_translation_of_language_strings_in_linked_JavaScript (tuxayo, 15:58:03)
    2. ACTION: tuxayo Update coding guideline JS5 to removed everything from DEPRECATED to the end of JS5. (tuxayo, 16:03:06)
    3. http://perltidy.sourceforge.net/ (tuxayo, 16:08:54)
    4. https://perldoc.perl.org/perlstyle.html (tuxayo, 16:09:00)
    5. ACTION: tuxayo check if xt/perltidyrc is used to see if we currently rely on it's values (tuxayo, 16:14:02)
    6. https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128698 (Joubu, 16:17:04)
    7. ACTION: tuxayo postpone "Avoid formatting single words within sentences to ease translation (example: Bug 29589)" to wait for test results (tuxayo, 16:26:02)

  9. Set time of next meeting (tuxayo, 16:26:16)
    1. Next meeting: 19 January 2022, 15 UTC (tuxayo, 16:27:35)


Meeting ended at 16:27:46 UTC (full logs).

Action items

  1. fridolin announces timeframe extension (end of feb) and for this one allow proposals outside eligible continents, keeping priority to actual ones
  2. fridolin chances wiki page with "An online conference bid will not make a continent ineligible for hosting an in-person conference the following year". And announcement de change
  3. fridolin open ticket about removing marcflavour as a param in context of bug 29652. Add it a dependency of bug 27268.
  4. tuxayo Update coding guideline JS5 to removed everything from DEPRECATED to the end of JS5.
  5. tuxayo check if xt/perltidyrc is used to see if we currently rely on it's values
  6. tuxayo postpone "Avoid formatting single words within sentences to ease translation (example: Bug 29589)" to wait for test results


Action items, by person

  1. fridolin
    1. fridolin announces timeframe extension (end of feb) and for this one allow proposals outside eligible continents, keeping priority to actual ones
    2. fridolin chances wiki page with "An online conference bid will not make a continent ineligible for hosting an in-person conference the following year". And announcement de change
    3. fridolin open ticket about removing marcflavour as a param in context of bug 29652. Add it a dependency of bug 27268.
  2. tuxayo
    1. tuxayo Update coding guideline JS5 to removed everything from DEPRECATED to the end of JS5.
    2. tuxayo check if xt/perltidyrc is used to see if we currently rely on it's values
    3. tuxayo postpone "Avoid formatting single words within sentences to ease translation (example: Bug 29589)" to wait for test results


People present (lines said)

  1. cait1 (87)
  2. tuxayo (80)
  3. fridolin (69)
  4. Joubu (38)
  5. huginn` (12)
  6. oleonard (8)
  7. thd (7)
  8. AndrewFH (4)
  9. wahanui (3)
  10. kidclamp (2)
  11. nugged (1)
  12. koha-jenkins (1)


Generated by MeetBot 0.1.4.