#koha: Documentation IRC meeting 2022-12-09

Meeting started by caroline at 15:04:07 UTC (full logs).

Meeting summary

  1. Introductions (caroline, 15:04:20)
    1. Caroline Cyr La Rose, inLibro, Quebec, Canada (caroline, 15:04:42)
    2. Marie-Luce Laflamme, inLibro, Montreal (marie-luce, 15:04:49)
    3. David Nind, New Zealand (davidnind, 15:05:26)
    4. Katrin Fischer, BSZ, Germany (cait1, 15:06:15)

  2. Review of action points (caroline, 15:08:52)
    1. No action points, starting over! (caroline, 15:09:50)

  3. Project updates (caroline, 15:10:07)
    1. Caroline is moving cataloging tools from the tools chapter to the cataloging chapter (caroline, 15:11:30)
    2. David is working on automated screenshots (caroline, 15:13:19)
    3. David is also working on a manual reorganization (caroline, 15:13:58)
    4. https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=144530 (davidnind, 15:17:19)
    5. ACTION: David to finish work on reorganizing the manual and adding a landing page - send out to the mailing list for feedback (expect it to be iterative) (caroline, 15:26:36)
    6. https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_2022-12-09 (caroline, 15:30:00)
    7. lucy vaux-harvey PTFS Europe (lucyvh, 15:30:03)

  4. What's been done so far (caroline, 15:30:14)
    1. Aude Charillon, PTFS Europe (aude_c, 15:32:18)
    2. links to system preferences have been changed in the manual (caroline, 15:39:19)
    3. links to system preferences must now have the same format as links to everything else :ref:`SysPrefName <sysprefname-label>` (caroline, 15:39:59)
    4. this change, related to gitlab issue 18, resolved a lot of errors when building the manual (caroline, 15:40:37)
    5. Martin added Documentation leaderboard to https://dashboard.koha-community.org/ (caroline, 15:49:43)
    6. to appear on the board, you need to change the status from Needs Documenting to RESOLVED (caroline, 15:51:43)

  5. Content development guidelines (caroline, 15:53:18)
    1. ACTION: davidnind to check scripts and translations tweaks for a switch to markdown and report back (caroline, 16:06:55)
    2. The problem in bug 29063 is that while in Koha strings for each syspref are separate and can be translated differently, in the manual, they are all bunched together (caroline, 16:14:51)
    3. https://koha-community.org/manual/22.11/en/html/accountspreferences.html for an example (cait, 16:15:18)
    4. current options 1) write the system preference descriptions as "[Use|Don't use] blah blah" 2) somehow add context to the strings like we do in Koha 3) somehow change how the strings are extracted so that each syspref is extracted individually like in Koha (caroline, 16:17:22)
    5. ACTION: add manual translations on agenda for next meeting (caroline, 16:28:50)
    6. AGREED: branching for 23.05 will happen in January 2023 (caroline, 16:32:30)
    7. ACTION: caroline needs to branch manual in january (caroline, 16:32:51)

  6. Next steps (caroline, 16:33:53)
    1. General documentation tasks https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=NEW&bug_status=REOPENED&bug_status=ASSIGNED&f1=keywords&f2=component&j_top=OR&known_name=Documentation%20To-do&list_id=394372&o1=allwords&o2=equals&query_based_on=Documentation%20To-do&query_format=advanced&v1=Manual&v2=Documentation (caroline, 16:34:12)
    2. Needs documenting https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=Needs%20documenting&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_status%2Cshort_desc%2Cchangeddate%2Cbug_severity&known_name=Needs%20documenting&list_id=434435&query_based_on=Needs%20documenting&query_format=advanced (caroline, 16:34:28)
    3. priority should be on the "needs documenting" status for bugs pushed in 22.1 (caroline, 16:34:59)

  7. Set time of next meeting (caroline, 16:36:39)
    1. Next meeting: 19 January 2023, 15 UTC (caroline, 16:42:17)


Meeting ended at 16:42:55 UTC (full logs).

Action items

  1. David to finish work on reorganizing the manual and adding a landing page - send out to the mailing list for feedback (expect it to be iterative)
  2. davidnind to check scripts and translations tweaks for a switch to markdown and report back
  3. add manual translations on agenda for next meeting
  4. caroline needs to branch manual in january


Action items, by person

  1. caroline
    1. caroline needs to branch manual in january
  2. davidnind
    1. davidnind to check scripts and translations tweaks for a switch to markdown and report back
  3. UNASSIGNED
    1. David to finish work on reorganizing the manual and adding a landing page - send out to the mailing list for feedback (expect it to be iterative)
    2. add manual translations on agenda for next meeting


People present (lines said)

  1. caroline (132)
  2. cait (79)
  3. ashimema (56)
  4. cait1 (52)
  5. davidnind (48)
  6. aude_c (10)
  7. huginn (7)
  8. marie-luce (3)
  9. wahanui (2)
  10. luvyvh (2)
  11. lucyvh (2)
  12. reiveune (1)


Generated by MeetBot 0.1.4.