#koha: Development IRC Meeting 1 November 2023

Meeting started by tcohen[m] at 13:04:05 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_Meeting_1_November_2023 (tcohen[m], 13:04:33)

  1. Introductions (tcohen[m], 13:04:47)
    1. Katrin Fischer, BSZ, Germany (cait1, 13:04:51)
    2. Magnus Enger, Libriotech/imCode (magnuse, 13:04:53)
    3. Alex Buckley - Catalyst IT, New Zealand (alexbuckley, 13:04:54)
    4. Marcel de Rooy, Rijksmuseum (marcelr, 13:05:05)
    5. Emmi Takkinen, Koha-Suomi Oy (EmmiTakkinen[m], 13:05:10)
    6. Aude Charillon, PTFS Europe, UK (aude_c[m], 13:05:13)
    7. Tomas Cohen Arazi (tcohen[m], 13:05:15)
    8. Matt Blenkinsop, PTFS Europe, UK (MatthewBlenkinsop[m], 13:05:37)
    9. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 13:05:44)
    10. Lari Strand, Koha-Suomi Oy (lmstrand, 13:06:05)
    11. Thomas Dukleth, Agogme, New York City (thd, 13:06:11)

  2. Announcements (tcohen[m], 13:06:57)
  3. Update from the Release manager (23.11) (tcohen[m], 13:07:29)
    1. almost all big things are pushed for 23.11, tcohen is going to test 'bookings' today (cait, 13:08:03)
    2. only random test failures by now (selenium) (cait, 13:08:39)
    3. hurry if you want to have something pushed that includes strings (cait, 13:09:16)

  4. Updates from the Release Maintainers (tcohen[m], 13:09:23)
    1. 22.11 waiting for a failing cypress test to be resolved (cait, 13:09:47)

  5. Updates from the QA Team (tcohen[m], 13:12:27)
    1. QA queue is a bit fuller than we'd want it to be at this point, 5 bugs from September in the back log, please look at these (cait, 13:13:42)

  6. Status of roadmap projects (tcohen[m], 13:14:00)
    1. ACTION: tochen to update status on some items (cait, 13:14:26)
    2. not all the big items were resolved this cycl (cait, 13:14:38)

  7. KohaCon24 update (tcohen[m], 13:15:13)
    1. there is a KohaCon24 website up now and it includes a survey to help the organizers, please fill it out: https://sondagebiblio.org/index.php/828663. (cait, 13:16:14)
    2. https://2024.kohacon.org/ (cait, 13:16:37)

  8. Roles for 24.05 - Elections (tcohen[m], 13:17:01)
    1. https://wiki.koha-community.org/wiki/Roles_for_24.05 (tcohen[m], 13:17:12)
    2. VOTE: Voted on "Please vote on the Release Team for 24.05 as listed on the wiki. Vote?" Results are, yes: 11 (cait, 13:25:46)
    3. Absent vote yes from ashimema and Joubu (cait, 13:26:02)

  9. Actions from the previous meetings (cait, 13:28:32)
    1. Manual translations have been moved to the Weblate server (cait, 13:29:08)
    2. DMARC see email to the mailing list, thd has been reaching out to mailing list hosts (cait, 13:32:50)
    3. Phython2 is going away, so that will push us to move to mailman3 or something else at some point (cait, 13:38:39)
    4. Update of the git server to Forgejo after the release (tcohen) (cait, 13:39:44)

  10. General development discussion (trends, ideas, ...) (tcohen[m], 13:40:15)
    1. moved to next meeting (cait, 13:41:11)

  11. Set time of next meeting (cait, 13:42:37)


Meeting ended at 13:44:12 UTC (full logs).

Action items

  1. tochen to update status on some items


People present (lines said)

  1. cait (25)
  2. tcohen[m] (20)
  3. huginn` (9)
  4. magnuse (4)
  5. aude_c[m] (4)
  6. cait1 (3)
  7. alexbuckley (3)
  8. thd (2)
  9. oleonard (2)
  10. MatthewBlenkinsop[m] (2)
  11. marcelr (2)
  12. lmstrand (2)
  13. EmmiTakkinen[m] (2)
  14. angelic (1)
  15. caroline (1)


Generated by MeetBot 0.1.4.