#koha: Development IRC meeting 22 February 2023

Meeting started by davidnind at 22:03:33 UTC (full logs).

Meeting summary

    1. Agenda https://wiki.koha-community.org/wiki/Development_IRC_meeting_22_February_2023 (davidnind, 22:03:53)

  1. Introductions (davidnind, 22:04:44)
    1. David Nind, New Zealand (davidnind, 22:04:45)
    2. Katrin Fischer, BSZ, Germany (cait, 22:04:45)
    3. Tomas Cohen Arazi, Theke Solutions (tcohen, 22:04:46)
    4. Victor Grousset, Tuxayo-Bibliotheksservice-Zentrum, France (tuxayo, 22:05:26)

  2. Announcements (davidnind, 22:07:05)
    1. Swedish Koha network user meeting 28-30 March 2023 https://koha.se/koha-i-sverige/inbjudan-till-svenska-kohanatverkets-tionde-anvandarmote-28-mars-30-mars-2023-i-vasteras-med-biblioteken-i-vastmanland/ (davidnind, 22:08:13)

  3. Update from the Release manager (22.11) (davidnind, 22:09:42)
    1. there are failing selenium tests in master. Please take a look and help fixing them. I've exhausted my bandwidth and I'm (tcohen, 22:10:37)
    2. behind my schedules with all the things :-D (tcohen, 22:10:50)
    3. There's been a recent push of breaking changes in how we handle compiled assets (tcohen, 22:11:12)
    4. it includes both the koha codebase, but also koha-misc4dev and ktd (tcohen, 22:11:34)
    5. khall put together some cool stuff we published as koha-dpkg-docker (tcohen, 22:12:45)
    6. mtj is looking and working towards integrating package building in the test pipeline (tcohen, 22:13:07)
    7. ACTION: There are failing Selenium tests in master, please take a look at fixing (davidnind, 22:13:36)
    8. koha-dpkg-docker https://gitlab.com/koha-community/koha-dpkg-docker (davidnind, 22:14:19)

  4. Updates from the Release Maintainers (davidnind, 22:15:02)
  5. Updates from the QA team (davidnind, 22:15:48)
    1. behind my schedules with all the things (cait, 22:17:20)
    2. queues are full, we need to find the time to process and test (cait, 22:17:32)
    3. queues are full, please all hands on deck - do QA! (cait, 22:18:57)

  6. KohaCon 2024 - start bidding process (davidnind, 22:20:18)
    1. ACTION: tuxayo to post request for volunteer to organise the call for bids for KohaCon 2024 (davidnind, 22:24:05)

  7. Status of roadmap projects (davidnind, 22:24:27)
    1. https://annuel.framapad.org/p/Roadmap_for_Koha_v23.05 (cait, 22:24:57)

  8. Actions from last meeting (davidnind, 22:25:30)
    1. ACTION: cait add info about the 'important' tag to RMaint documentation (davidnind, 22:26:46)
    2. ACTION: tcohen To schedule/call a "CSRF day" to work on related patches together (davidnind, 22:29:50)
    3. ACTION: tcohen To draft proposal for master→main change and draft of action list (davidnind, 22:32:11)
    4. ACTION: oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release). (tuxayo, 22:32:26)
    5. ACTION: tuxayo postpone to next meeting "Joubu we need to vote on forgejo move at some point" (tuxayo, 22:32:50)

  9. General development discussion (davidnind, 22:33:25)
    1. mtj to add security builds to Jenkins so that the full test suite is run, to help avoid regressions and issues with security releases - to work through details with tcohen, Release Maintainers, and others interested (davidnind, 22:41:46)
    2. ACTION: tuxayo postpone perltidy agenda item and mention bug 30002 for context (tuxayo, 22:44:43)
    3. Perltidy - need to resolve conflicting information about what to do and put in guidelines (davidnind, 22:45:46)
    4. ACTION: caroline Update/add terminology guidelines for usgage of charges and fees as discussed (davidnind, 22:53:26)

  10. Set time of next meeting (davidnind, 22:54:28)
    1. Next meeting: 09 March 2023, 15 UTC (tuxayo, 22:55:36)


Meeting ended at 22:58:56 UTC (full logs).

Action items

  1. There are failing Selenium tests in master, please take a look at fixing
  2. tuxayo to post request for volunteer to organise the call for bids for KohaCon 2024
  3. cait add info about the 'important' tag to RMaint documentation
  4. tcohen To schedule/call a "CSRF day" to work on related patches together
  5. tcohen To draft proposal for master→main change and draft of action list
  6. oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).
  7. tuxayo postpone to next meeting "Joubu we need to vote on forgejo move at some point"
  8. tuxayo postpone perltidy agenda item and mention bug 30002 for context
  9. caroline Update/add terminology guidelines for usgage of charges and fees as discussed


Action items, by person

  1. cait
    1. cait add info about the 'important' tag to RMaint documentation
  2. caroline
    1. caroline Update/add terminology guidelines for usgage of charges and fees as discussed
  3. tcohen
    1. tcohen To schedule/call a "CSRF day" to work on related patches together
    2. tcohen To draft proposal for master→main change and draft of action list
  4. tuxayo
    1. tuxayo to post request for volunteer to organise the call for bids for KohaCon 2024
    2. tuxayo postpone to next meeting "Joubu we need to vote on forgejo move at some point"
    3. tuxayo postpone perltidy agenda item and mention bug 30002 for context
  5. UNASSIGNED
    1. There are failing Selenium tests in master, please take a look at fixing
    2. oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).


People present (lines said)

  1. davidnind (64)
  2. cait (47)
  3. tcohen (39)
  4. tuxayo (34)
  5. caroline (11)
  6. huginn (6)
  7. wahanui (2)


Generated by MeetBot 0.1.4.