#koha: Development IRC Meeting 26 April 2023

Meeting started by tcohen at 14:31:28 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_26_April_2023 Today's agenda (tcohen, 14:31:47)

  1. Introductions (tcohen, 14:32:01)
    1. Tomas Cohen Arazi (tcohen, 14:32:07)
    2. Katrin Fischer, BSZ, Germany (cait, 14:32:14)
    3. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:32:24)
    4. Thomas Dukleth, Agogme, New York City (thd, 14:32:38)
    5. Martin Renvoize, PTFS Europe (ashimema, 14:32:57)

  2. Announcements (tcohen, 14:33:34)
    1. KohaCon23 Update: (tcohen, 14:33:52)
    2. Call for talks closes April 30th (tcohen, 14:34:19)
    3. Andrii sent a reminder to the lists (tcohen, 14:36:23)
    4. ACTION: tcohen will reinforce it tomorrow (tcohen, 14:36:32)
    5. 'Spring into Fitness: Koha Community Challenge 2023 (koha-US and ByWater Solutions)' (tcohen, 14:37:19)
    6. Join at https://koha-us.org/2023/04/06/spring-into-fitness-koha-community-challenge-2023/ (tcohen, 14:37:29)

  3. Update from the Release Manager (23.05) (tcohen, 14:37:46)
    1. Lots of things pushed, several interesting ones to get in in the next weeks. Hurry! (tcohen, 14:38:16)
    2. Looking closely to a design discussion on Vue-land (tcohen, 14:38:35)
    3. Contact tcohen if you really want your stuff pushed, so we have a clear understanding of the steps that follow and the chances they have to get pushed (tcohen, 14:39:14)
    4. tcohen asked the Translation Manager to hand us the commands that are used in Pootle to update things, so we have more hands able to do it (tcohen, 14:40:15)
    5. Email sent to koha-translate to start the conversation about switching to another tool begining next cycle (tcohen, 14:40:49)

  4. Updates from the Release Maintainers (tcohen, 14:41:08)
  5. Updates from the QA Team (tcohen, 14:41:38)
    1. 22.11.x is behind on this months release whilst we try to get strings sorted (ashimema, 14:41:38)

  6. Status of roadmap projects (tcohen, 14:42:54)
    1. https://annuel.framapad.org/p/Roadmap_for_Koha_v23.05 (tcohen, 14:43:07)
    2. Lots of things done or almost done (tcohen, 14:43:37)
    3. Generic solution for CSRF delayed for early next cycle, unfortunately (tcohen, 14:44:00)
    4. Kyle M Hall, ByWater Solutions (khall, 14:44:05)
    5. ILL backends into core delayed for next cycle (tcohen, 14:44:33)
    6. Great work from PedroAmorim[m] to speed up the ILL requests page (tcohen, 14:44:58)
    7. kudos to oleonard for his intensive work on streamlining the UI and normalizing the way we do things (tcohen, 14:45:35)

  7. Updates from the QA Team (tcohen, 14:46:48)
    1. Need more action from the whole QA team to fix the QA queue (cait, 14:47:30)
    2. Numbers are constantly above 100, I hope we can push down some more, lots of bugs (faulty behaviour) ones too (cait, 14:48:46)

  8. Actions from last meeting (tcohen, 14:50:07)
    1. Selenium and Cypress tests are passing already (tcohen, 14:50:45)
    2. CSRF day postponed for after the release (tcohen, 14:51:05)

  9. General development discussion (trends, ideas, .. (tcohen, 14:51:45)
    1. Roles for 23.11 are open. Please put your name here: https://wiki.koha-community.org/wiki/Roles_for_23.11 (tcohen, 14:52:15)
    2. ACTION: tcohen to send email about roles for 23.11 (tcohen, 14:52:51)
    3. We need to agree on a default Perltidy configuration. See bug 30002. To be voted next meeting. (tcohen, 14:54:49)
    4. We need to upgrade Gitea, and move to Forgejo. Anyone willing to spend time on that please contact tcohen (tcohen, 14:55:24)
    5. perldoc.k-c is outdated, we need to investigate and have it update more frecquently (tcohen, 14:58:51)
    6. Development documentation (from the hackfest): nothing to discuss here. People do their best. If you want to spend time on documenting the listed things, and need guidance, contact us by any means (tcohen, 14:59:48)
    7. ACTION: cait and ashimema will put together the TODO notes from the hackfest on the Wiki (tcohen, 15:02:03)

  10. Set time of next meeting (tcohen, 15:02:11)
    1. Next meeting: 10 May 2023, 14:00 UTC (tcohen, 15:07:00)


Meeting ended at 15:08:16 UTC (full logs).

Action items

  1. tcohen will reinforce it tomorrow
  2. tcohen to send email about roles for 23.11
  3. cait and ashimema will put together the TODO notes from the hackfest on the Wiki


Action items, by person

  1. ashimema
    1. cait and ashimema will put together the TODO notes from the hackfest on the Wiki
  2. cait
    1. cait and ashimema will put together the TODO notes from the hackfest on the Wiki
  3. tcohen
    1. tcohen will reinforce it tomorrow
    2. tcohen to send email about roles for 23.11


People present (lines said)

  1. tcohen (69)
  2. cait (35)
  3. ashimema (8)
  4. thd (8)
  5. huginn (4)
  6. oleonard (2)
  7. reiveune (1)
  8. khall (1)


Generated by MeetBot 0.1.4.