#koha: Development IRC Meeting 7 June 2023

Meeting started by tcohen at 14:02:49 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_7_June_2023 (tcohen, 14:03:09)
    2. Katrin Fischer, BSZ Germany (cait, 14:03:17)

  1. Introductions (tcohen, 14:03:19)
    1. Tomas Cohen Arazi (tcohen, 14:03:26)
    2. Katrin Fischer, BSZ Germany (tcohen, 14:03:39)
    3. Nick Clemens, ByWaterSolutions (kidclamp, 14:04:14)
    4. Thomas Dukleth, Agogme, New York City (thd, 14:04:25)
    5. Jonathan Druart (Joubu, 14:04:43)
    6. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:05:54)
    7. Laura Escamilla, ByWaterSolutions (lauraesca[m], 14:06:00)
    8. Martin Renvoize, PTFS Europe (Half here and in another meeting) (ashimema, 14:08:46)

  2. Announcements (tcohen, 14:08:53)
    1. German speaking Koha user meeting is scheduled for December 5th - CfP is open (see Koha calendar and koha-dach.eu) (cait, 14:11:42)

  3. Update from the Release Manager (23.11) (tcohen, 14:13:53)
    1. ACTION: tcohen will send a roadmap page for 23.11 today (tcohen, 14:14:23)
    2. ACTION: tcohen will send a call for testing CSRF fixes (tcohen, 14:14:38)

  4. Updates from the Release Maintainers (tcohen, 14:19:39)
    1. https://tree.taiga.io/project/koha-ils/us/19 (Joubu, 14:24:04)

  5. Updates from the QA Team (tcohen, 14:29:29)
  6. Actions from last meeting (tcohen, 14:33:54)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_7_June_2023 (tcohen, 14:35:20)

  7. KohaCon24 (tcohen, 14:36:33)
    1. The 'different continent' rule for KohaCon24 is lifted as there were no elegible proposals (tcohen, 14:44:10)

  8. Roles for 23.11 (tcohen, 14:45:46)
    1. https://wiki.koha-community.org/wiki/Roles_for_23.11 (tcohen, 14:46:26)
    2. https://wiki.koha-community.org/wiki/KohaCon24_Proposals updated the wiki page with a note, please check (cait, 14:47:01)
    3. https://wiki.koha-community.org/wiki/Release_Teams will need further updates (and the bug too) if we change the team more (ashimema, 14:48:13)
    4. ACTION: everyone should sign for 23.11 roles (tcohen, 14:49:40)
    5. https://wiki.koha-community.org/wiki/Roles_for_23.11 (cait, 14:50:45)

  9. Review of coding guidelines (tcohen, 15:02:53)
    1. ACTION: Joubu will document on the wiki how to set the perltidyrc on vim (tcohen, 15:05:01)
    2. https://wiki.koha-community.org/wiki/Perltidy (cait, 15:05:04)
    3. ACTION: tcohen will document on the wiki how to set perltidyrc on vscode (tcohen, 15:05:15)
    4. https://wiki.koha-community.org/wiki/Perltidy (tcohen, 15:05:34)

  10. Set time of next meeting (tcohen, 15:10:13)
    1. Next meeting: 21 Jun 2023, 14:00 UTC (tcohen, 15:13:58)


Meeting ended at 15:14:12 UTC (full logs).

Action items

  1. tcohen will send a roadmap page for 23.11 today
  2. tcohen will send a call for testing CSRF fixes
  3. everyone should sign for 23.11 roles
  4. Joubu will document on the wiki how to set the perltidyrc on vim
  5. tcohen will document on the wiki how to set perltidyrc on vscode


Action items, by person

  1. Joubu
    1. Joubu will document on the wiki how to set the perltidyrc on vim
  2. tcohen
    1. tcohen will send a roadmap page for 23.11 today
    2. tcohen will send a call for testing CSRF fixes
    3. tcohen will document on the wiki how to set perltidyrc on vscode


People present (lines said)

  1. tcohen (129)
  2. cait (80)
  3. Joubu (34)
  4. ashimema (25)
  5. oleonard (14)
  6. wahanui (13)
  7. huginn (7)
  8. thd (6)
  9. caroline (4)
  10. gmcharlt (2)
  11. lauraesca[m] (1)
  12. kidclamp (1)
  13. caroline_crazycatlady (1)


Generated by MeetBot 0.1.4.