#koha: Development IRC meeting 8 February 2023

Meeting started by tuxayo at 15:01:29 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_8_February_2023 Today's agenda (tuxayo, 15:01:47)

  1. Introductions (tuxayo, 15:01:52)
    1. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 15:02:11)
    2. Tomas Cohen Arazi (tcohen, 15:02:19)
    3. Agustin Moyano (AgustinMoyano[m], 15:02:39)
    4. Jonathan Druart (Joubu, 15:02:47)
    5. Kyle Hall, ByWater Solutions (khall_, 15:02:48)
    6. Paul Derscheid, LMSCloud GmbH, Germany (paulderscheid[m], 15:02:49)
    7. Martin Renoize, PTFS Europe, UK (ashimema, 15:02:57)
    8. Laura Escamilla, ByWater Solutions (lauraesca[m], 15:03:20)
    9. Thomas Dukleth, Agogme, New York City (thd, 15:03:32)
    10. Katrin Fischer, BSZ, Germany (cait, 15:03:38)
    11. Victor Grousset, Tuxayo Antartica, France (tuxayo, 15:03:43)
    12. Emily Lamancusa, MCPL, USA (emlam, 15:04:05)

  2. Announcements (tuxayo, 15:06:22)
  3. Update from the Release manager (22.11) (tuxayo, 15:07:52)
  4. Updates from the Release Maintainers (tuxayo, 15:09:52)
  5. Updates from the QA team (tuxayo, 15:18:21)
  6. Status of roadmap projects (tuxayo, 15:24:36)
    1. https://gitlab.com/koha-community/koha-testing-docker/-/issues/320 https://gitlab.com/koha-community/koha-misc4dev/-/issues/58 (Joubu, 15:31:41)

  7. Actions from last meeting (tuxayo, 15:35:23)
    1. ACTION: cait add info about the 'important' tag to RMaint documentation (Joubu, 15:40:42)
    2. ACTION: tcohen To schedule/call a "CSRF day" to work on related patches together (previously deferred until after the 22.11 release). (tuxayo, 15:41:22)
    3. ACTION: tcohen To draft proposal for master→main change and draft of action list (previously deferred until after the 22.11 release). (tuxayo, 15:41:29)
    4. https://annuel.framapad.org/p/koha-styleguide-draft (ashimema, 15:42:32)
    5. ACTION: oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release). (tuxayo, 15:42:37)
    6. ACTION: Joubu we need to vote on forgejo move at some point (Joubu, 15:47:08)
    7. opinions needed to decide the future of our git hosting https://lists.koha-community.org/pipermail/koha-devel/2023-February/thread.html (tuxayo, 15:50:23)

  8. General development discussion (trends, ideas, ...) (tuxayo, 15:50:48)
    1. https://gitlab.com/thekesolutions/Koha.git (AgustinMoyano[m], 15:57:28)
    2. https://savannah.gnu.org/bugs/?50920 (Joubu, 16:00:10)

  9. Set time of next meeting (tuxayo, 16:02:57)
    1. Next meeting: 22 February 2023, 22 UTC (tuxayo, 16:02:58)
    2. for this time slot, next meeting is: 09 March 2023, 15 UTC (tuxayo, 16:05:31)


Meeting ended at 16:05:34 UTC (full logs).

Action items

  1. cait add info about the 'important' tag to RMaint documentation
  2. tcohen To schedule/call a "CSRF day" to work on related patches together (previously deferred until after the 22.11 release).
  3. tcohen To draft proposal for master→main change and draft of action list (previously deferred until after the 22.11 release).
  4. oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).
  5. Joubu we need to vote on forgejo move at some point


Action items, by person

  1. ashimema
    1. oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).
  2. cait
    1. cait add info about the 'important' tag to RMaint documentation
  3. Joubu
    1. Joubu we need to vote on forgejo move at some point
  4. oleonard
    1. oleonard ashimema Draft in the developer handbook how to form our modals. With template of a simple case and a case with form inside. Update: focus is currently on staff interface redesign changes, see the draft style guide: https://annuel.framapad.org/p/koha-styleguide-draft (previously deferred until after the 22.11 release).
  5. tcohen
    1. tcohen To schedule/call a "CSRF day" to work on related patches together (previously deferred until after the 22.11 release).
    2. tcohen To draft proposal for master→main change and draft of action list (previously deferred until after the 22.11 release).


People present (lines said)

  1. tuxayo (73)
  2. Joubu (67)
  3. ashimema (26)
  4. cait (21)
  5. tcohen (21)
  6. AgustinMoyano[m] (14)
  7. paulderscheid[m] (13)
  8. huginn (12)
  9. emlam (7)
  10. wahanui (5)
  11. oleonard (3)
  12. thd (3)
  13. khall_ (2)
  14. lauraesca[m] (1)


Generated by MeetBot 0.1.4.