#koha: Development Meeting 13 September 2023

Meeting started by tcohen[m] at 14:06:43 UTC (full logs).

Meeting summary

  1. Introductions (tcohen[m], 14:06:59)
    1. Nick Clemens, ByWater Solutions (kidclamp, 14:07:01)
    2. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:07:12)
    3. Tomas Cohen Arazi (tcohen[m], 14:07:19)
    4. Katrin Fischer, BSZ (cait, 14:07:26)
    5. Emily Lamancusa, Montgomery County Public Libraries, Maryland, USA (emlam, 14:07:36)
    6. Caroline Cyr La Rose, inlibro, QC, Canada (caroline, 14:07:39)
    7. https://meet.jit.si/KohaDevelopmentMeeting (tcohen[m], 14:07:50)

  2. Announcements (tcohen[m], 14:10:44)
    1. https://wiki.koha-community.org/wiki/Development_Meeting_13_September_2023 agenda (cait, 14:10:48)

  3. Update from the Release manager (23.11) (tcohen[m], 14:11:03)
  4. Updates from the Release Maintainers (tcohen[m], 14:12:43)
  5. Updates from the QA Team (tcohen[m], 14:13:36)
    1. too many things in the queue, nasty bugs that need backporting (tcohen[m], 14:14:06)
    2. some big features moved the last weeks (tcohen[m], 14:14:23)
    3. Please do more QA! :) (cait, 14:15:40)

  6. Status of roadmap projects (tcohen[m], 14:15:44)
    1. https://wiki.koha-community.org/wiki/Roadmap_for_23.11 (tcohen[m], 14:15:54)
    2. bookings has been updated to latest fedback and the sandbox is ready for testing (kidclamp, 14:18:46)
    3. BugĀ 17427 - Replace CGI::Session with Data::Session - needs input, maybe altenrative solution? (cait, 14:23:06)
    4. please take a look at the roadmap items, help devs keep the pace (tcohen[m], 14:25:21)

  7. KohaCon23 thank you! (tcohen[m], 14:28:04)
    1. Po files for 22.11 manual are available now! (cait, 14:28:21)

  8. KohaCon24 update (tcohen[m], 14:28:34)
    1. Looking for a venue, exact dates and location to come (cait, 14:28:59)
    2. There are plans to book two rooms, to have a technical track, if there's enough interest on it (tcohen[m], 14:35:11)
    3. Aiming for September (tcohen[m], 14:37:11)

  9. Actions from last meeting (tcohen[m], 14:37:46)
    1. tcohen tested update to forgejo (cait, 14:41:36)
    2. DMARC need to get in touch with list admins to discuss changes to mailman configuration (cait, 14:46:39)
    3. Weblate needs more work, maybe wiating on new version to improve possibilities for better organizing our files/versions (cait, 14:52:55)
    4. ACTION: tcohen to have a look at renaming master branch to main (cait, 14:54:41)
    5. Next meeting: 27 September 2023, 12 UTC (cait, 14:59:06)


Meeting ended at 14:59:22 UTC (full logs).

Action items

  1. tcohen to have a look at renaming master branch to main


People present (lines said)

  1. cait (22)
  2. tcohen[m] (22)
  3. kidclamp (4)
  4. ashimema (3)
  5. huginn (3)
  6. thd (2)
  7. lukeg (1)
  8. oleonard (1)
  9. emlam (1)
  10. caroline (1)


Generated by MeetBot 0.1.4.