#koha: Development Meeting 18 October 2023

Meeting started by cait at 12:07:50 UTC (full logs).

Meeting summary

    1. Introductions (cait, 12:08:04)

  1. Introductions (cait, 12:08:28)
    1. Tomas Cohen Arazi (tcohen[m], 12:08:35)
    2. Thomas Dukleth, Agogme, New York City (thd, 12:08:54)
    3. Katrin Fischer, BSZ, Germany (cait, 12:09:03)
    4. Paul Derscheid, LMSCloud GmbH, Germany (paulderscheid[m], 12:09:14)
    5. Marcel de Rooy, Rijksmuseum (marcelr, 12:09:17)
    6. Matt Blenkinsop, PTFS Europe, UK (MatthewBlenkinsop[m], 12:09:24)

  2. Announcements (cait, 12:10:08)
    1. User meeting for German speaking Koha users on 5th December, see https://koha-dach.eu (cait, 12:11:04)

  3. Update from the Release Manager (cait, 12:11:16)
    1. QA has been filling up RM's queue - tcohen is trying to catch up. (cait, 12:11:42)
    2. Please react fast if there are any questions, doesn't apply, follow-ups required etc. (cait, 12:11:57)
    3. deadlines are approaching fast (cait, 12:12:09)
    4. Preservation module and ERM usage were also mentioned explicitly (cait, 12:15:31)
    5. discussed possible transcription of meetings, resurrecting the meeting factilitator as a Release Team role (cait, 12:18:19)

  4. Update from the Release Maintainers (cait, 12:19:13)
    1. 22.11 in string freeze now (cait, 12:20:16)
    2. ACTION: MatthewBlenkinsop to get in touch with bgkriegel (cait, 12:20:46)
    3. ACTION: tcohen to publish freeze dates via mailing list (cait, 12:21:05)
    4. there was an error in 21.11 that was fixed by tcohen (update issue) (cait, 12:24:08)

  5. Update from the QA team (cait, 12:24:33)
    1. Martin Renvoize, PTFS Europe (ashimema, 12:24:56)
    2. QA queue is shrinking, but still too big - hopefully we will be able to shrink it some more and get the older bugs out soon (cait, 12:28:59)

  6. Status of the roadmap projects (cait, 12:29:10)
    1. https://wiki.koha-community.org/wiki/Roadmap_for_23.11 Rodmap in the wiki (cait, 12:29:44)
    2. bug 17427 (cait, 12:30:09)
    3. bug 33537 is waiting for QA (cait, 12:31:11)
    4. bug 17427 will need to be postponed to next cycle, but would be great to have (cait, 12:32:02)
    5. most of the roadmap is on the way for release (cait, 12:33:05)

  7. KohaCon25 update (cait, 12:36:52)
    1. postponed! (cait, 12:37:02)

  8. Roles for 24.05 (cait, 12:37:41)
    1. https://wiki.koha-community.org/wiki/Roles_for_24.05 (cait, 12:38:05)
    2. Elections will be held next Dev Meeting (cait, 12:38:57)
    3. ACTION: tcohen will send an email about the roles to the mailing list (cait, 12:39:12)

  9. Actions from previous meetings (cait, 12:39:48)
    1. perldoc still needs updating, need the script to run (cait, 12:46:32)
    2. ACTION: paulderscheid[m] to share his script for perldocs (cait, 12:47:58)
    3. Move from Gitea to Forgejo moved to beginning of next cycle (cait, 12:48:36)

  10. General development discussion (cait, 12:49:56)
    1. DMARC: thd got in touch with Rachel for Koha main list, they would be happy for someone to take over hosting (cait, 12:51:23)
    2. Joubu could change settings on the Bblibre hosted lists (cait, 12:51:31)
    3. bug 34927 (cait, 12:53:02)
    4. koha-devel is in testing now with the DMARC improved configuration (cait, 12:58:20)
    5. ACTION: thd to inform mailing list (cait, 12:58:30)
    6. moving master to main to be done next cycle (cait, 12:59:02)
    7. Draft style guide is still pending, modals info should be added (cait, 12:59:57)
    8. https://wiki.koha-community.org/wiki/Translation_server_migration_weblate (cait, 13:00:41)

  11. Review of Coding guidelines (cait, 13:01:32)
    1. no topics on agenda (cait, 13:01:49)
    2. koha-manual will move from master to main in a couple of weeks (cait, 13:02:05)
    3. Next meeting: 1 November 2023, 13 UTC (cait, 13:05:02)


Meeting ended at 13:13:45 UTC (full logs).

Action items

  1. MatthewBlenkinsop to get in touch with bgkriegel
  2. tcohen to publish freeze dates via mailing list
  3. tcohen will send an email about the roles to the mailing list
  4. paulderscheid[m] to share his script for perldocs
  5. thd to inform mailing list


Action items, by person

  1. tcohen
    1. tcohen to publish freeze dates via mailing list
    2. tcohen will send an email about the roles to the mailing list
  2. thd
    1. thd to inform mailing list
  3. UNASSIGNED
    1. MatthewBlenkinsop to get in touch with bgkriegel
    2. paulderscheid[m] to share his script for perldocs


People present (lines said)

  1. cait (56)
  2. huginn (12)
  3. Joubu (6)
  4. marcelr (3)
  5. ashimema (1)
  6. MatthewBlenkinsop[m] (1)
  7. thd (1)
  8. paulderscheid[m] (1)
  9. tcohen[m] (1)
  10. tcohen (0)


Generated by MeetBot 0.1.4.