#koha: Development IRC meeting 15 May 2024

Meeting started by paulderscheid[m] at 14:00:25 UTC (full logs).

Meeting summary

  1. Introductions (paulderscheid[m], 14:00:52)
    1. Paul Derscheid, LMSCloud GmbH, Germany (paulderscheid[m], 14:01:36)
    2. Katrin Fischer, BSZ, Germany (cait, 14:02:35)
    3. Matt Blenkinsop, PTFS Europe, UK (MatthewBlenkinsop[m], 14:02:40)
    4. , Nick Clemens, BWS (kidclamp, 14:03:07)
    5. Thomas Dukleth, Agogme, New York City (thd, 14:03:12)
    6. Lisette Scheer, BWS (cait, 14:04:21)
    7. David Cook, Prosentient Systems (dcook, 14:04:30)
    8. David Cook, Prosentient Systems (cait, 14:04:30)
    9. Evelyn Hartline, BWS (cait, 14:04:44)
    10. Brendan Gallagher ByWater (cait, 14:04:58)
    11. Tomas Cohen Arazi (tcohen, 14:04:58)
    12. Martin Renvoize, PTFS Europe (ashimema, 14:05:04)
    13. Tomas Cohen Arazi (cait, 14:05:07)
    14. Caroline Cyr La Rose, inlibro, Québec, Canada (caroline, 14:05:12)
    15. Paul Poulain, Biblibre (cait, 14:05:51)
    16. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:06:16)

  2. Announcements (paulderscheid[m], 14:06:20)
    1. Frédéric Demians, Tamil (fredericd, 14:06:24)
    2. bag is going to send a poll to the foundation proposal after this meeting (paulderscheid[m], 14:06:58)
    3. Michael Kuhn added for newsletter role, domm for QA team (paulderscheid[m], 14:08:43)

  3. Update from the Release manager (24.05) (paulderscheid[m], 14:10:17)
    1. on schedule for 24.05 release (paulderscheid[m], 14:10:37)
    2. proper string freeze this friday (17th) (paulderscheid[m], 14:11:15)
    3. release scheduled for May 28 (paulderscheid[m], 14:11:30)

  4. Updates from the Release Maintainers (paulderscheid[m], 14:12:01)
    1. a security release was released on monday, please consider updating (paulderscheid[m], 14:13:15)

  5. Updates from the QA team (paulderscheid[m], 14:13:25)
    1. couple of busy weeks (paulderscheid[m], 14:14:03)

  6. Status of roadmap projects (paulderscheid[m], 14:14:48)
    1. new roadmap pages will be created next week, one for community projects, one for advertising (email will be sent to koha-devel) (paulderscheid[m], 14:15:34)
    2. interlibrary loans rethink: bits have been pushed (paulderscheid[m], 14:17:02)
    3. OAI-PMH harvester: currently in failed QA (paulderscheid[m], 14:18:23)
    4. bookings: bits have been pushed (paulderscheid[m], 14:18:39)
    5. plugins (discovery, authenticity): still in discussion, no patches yet (paulderscheid[m], 14:19:14)
    6. geo-search: has been pushed, geo-search UI as plugin, will be shared (paulderscheid[m], 14:19:32)
    7. using REST API to display items in biblio detail view: pushed to main (paulderscheid[m], 14:19:54)
    8. moving patron search to a modal: pushed to main (paulderscheid[m], 14:20:18)
    9. move C4 to Koha: not much progress this cycle (paulderscheid[m], 14:20:32)
    10. cities on vue: admin app missing to properly build navigation column on the left (LeftMenu), needed for other views as well (paulderscheid[m], 14:22:12)
    11. shifting slips and notices to Template Toolkit: bits have been pushed (paulderscheid[m], 14:22:53)
    12. move domain limits from koha-conf to staff SMTP config: failed QA (paulderscheid[m], 14:23:28)
    13. merge reserves and old_reserves: postponed to beginning of next cycle (paulderscheid[m], 14:23:51)
    14. improving tests for koha plugins: pushed to oldstable (paulderscheid[m], 14:24:14)
    15. performance improvements: some progress by BibLibre, byWater (paulderscheid[m], 14:24:47)
    16. job queue, rabbitMQ bugfixes and improvements: needs more work, some bugfixes available (paulderscheid[m], 14:25:33)
    17. move from master to main: done! (paulderscheid[m], 14:25:44)
    18. discourse: not much progress, currently stuck at getting mailing list contents scraped (paulderscheid[m], 14:27:41)
    19. debian packages, share the load: tcohen made solid progress with koha-dpkg-docker (paulderscheid[m], 14:28:32)
    20. https://gitlab.com/koha-community/koha-dpkg-docker (tcohen, 14:29:52)
    21. prevent pushing to main if jenkins fails: postponed to next cycle (paulderscheid[m], 14:30:22)
    22. automated screenshots: wip (paulderscheid[m], 14:30:32)
    23. template toolkit reference guide: doc in drafting phase (paulderscheid[m], 14:30:51)

  7. Actions from last meeting (paulderscheid[m], 14:31:10)
    1. ACTION: paulderscheid[m] file an issue for integrating JS15 into QA scripts (paulderscheid[m], 14:37:56)

  8. Foundation Proposal (paulderscheid[m], 14:38:42)
    1. https://ptfs-europe.com/koha-foundation-proposal/ (paulderscheid[m], 14:39:04)
    2. a poll will be shared on mattermost, irc, and via the mailing list, duration of the vote will be 4 weeks (paulderscheid[m], 14:41:59)

  9. General development discussion (trends, ideas, ...) (paulderscheid[m], 14:44:33)
    1. using carton instead of debian packages for koha's dependencies? (paulderscheid[m], 14:57:53)
    2. debian packages save us from a lot of manual maintenance (paulderscheid[m], 14:59:17)
    3. ashimema initially suggested to just use carton for dependencies we maintain ourselves (paulderscheid[m], 15:00:10)
    4. bugzilla moved from debian packages to carton which sparked the discussion (paulderscheid[m], 15:01:51)
    5. https://chat.koha-community.org/koha-community/pl/tz5pfoonsigz8nr7pr54aiqwrr (paulderscheid[m], 15:02:23)
    6. katrin added a workflow for adding new dependencies (paulderscheid[m], 15:03:40)
    7. https://wiki.koha-community.org/wiki/Release_management#Dependency_changes (paulderscheid[m], 15:03:57)
    8. ACTION: tcohen to check if any steps for adding new dependencies are missing for koha-testing-docker in the linked document (paulderscheid[m], 15:05:10)
    9. we average adding 8-10 changes to the cpanfile a year (paulderscheid[m], 15:05:37)
    10. marcelr added a new table for deleted authorities, discussion about whether this is a pattern we should favor (paulderscheid[m], 15:08:22)
    11. ACTION: put tombstone table pattern on the roadmap for discussion for next cycle (paulderscheid[m], 15:17:37)

  10. Review of coding guidelines (paulderscheid[m], 15:21:53)
    1. concerning a coding guideline on adding new perl dependencies: postponed to next meeting (paulderscheid[m], 15:22:50)
    2. ACTION: ashimema to add a qa script check for NOTICE1 in the coding guidelines (paulderscheid[m], 15:23:50)

  11. Any other business (paulderscheid[m], 15:24:01)
  12. Set time of next meeting (paulderscheid[m], 15:24:18)
    1. Next meeting: 29 May 2024, 14 UTC (paulderscheid[m], 15:27:00)


Meeting ended at 15:27:23 UTC (full logs).

Action items

  1. paulderscheid[m] file an issue for integrating JS15 into QA scripts
  2. tcohen to check if any steps for adding new dependencies are missing for koha-testing-docker in the linked document
  3. put tombstone table pattern on the roadmap for discussion for next cycle
  4. ashimema to add a qa script check for NOTICE1 in the coding guidelines


Action items, by person

  1. ashimema
    1. ashimema to add a qa script check for NOTICE1 in the coding guidelines
  2. tcohen
    1. tcohen to check if any steps for adding new dependencies are missing for koha-testing-docker in the linked document
  3. UNASSIGNED
    1. paulderscheid[m] file an issue for integrating JS15 into QA scripts
    2. put tombstone table pattern on the roadmap for discussion for next cycle


People present (lines said)

  1. paulderscheid[m] (62)
  2. mbridge (10)
  3. cait (8)
  4. huginn` (4)
  5. dcook (4)
  6. kidclamp (2)
  7. tcohen (2)
  8. oleonard (1)
  9. ashimema (1)
  10. MatthewBlenkinsop[m] (1)
  11. fredericd (1)
  12. caroline (1)
  13. thd (1)


Generated by MeetBot 0.1.4.