#koha: Development IRC meeting 17 April 2024

Meeting started by paulderscheid[m] at 12:00:42 UTC (full logs).

Meeting summary

    1. Marcel de Rooy (marcelr, 12:01:32)

  1. Introductions (paulderscheid[m], 12:01:43)
    1. Katrin Fischer, BSZ, Germany (cait, 12:02:10)
    2. Paul Derscheid, LMSCloud GmbH, Germany (paulderscheid[m], 12:02:13)
    3. Brendan Gallagher, ByWater (bag, 12:02:19)
    4. Emmi Takkinen, Koha-Suomi Oy, Finland (EmmiTakkinen[m], 12:02:29)
    5. Thomas Dukleth, Agogme, New York City (thd, 12:02:36)
    6. Aude Charillon, PTFS Europe, UK (aude_c[m], 12:02:45)

  2. announcements (paulderscheid[m], 12:04:21)
    1. https://wiki.koha-community.org/wiki/Roles_for_24.11 Roles page on the wiki (cait, 12:04:24)
    2. Mattermost chat is live and available at https://chat.koha-community.org - please sign-up! (cait, 12:05:37)
    3. Anneli Österman, Koha-Suomi Oy, Finland (Annelisterman[m], 12:09:10)

  3. Update from the Release manager (paulderscheid[m], 12:12:16)
    1. https://lists.koha-community.org/pipermail/koha-devel/2024-April/048606.html Release dates are out! (cait, 12:12:19)
    2. Goal is to go through current list by the end of the week (cait, 12:14:37)

  4. Updates from the Release Maintainers (paulderscheid[m], 12:15:23)
    1. On track (paulderscheid[m], 12:15:58)

  5. Updates from the QA team (paulderscheid[m], 12:16:15)
    1. Still a big backlog on enh, keeping up with bugs, lots of effort went into CSRF explaining that (cait, 12:17:23)

  6. Status if roadmap projects (paulderscheid[m], 12:19:29)
    1. ACTION: cait to send an email to koha-devel announcing the change of the default branch from master to main (paulderscheid[m], 12:25:00)
    2. ACTION: change master > main is going to happen this Friday, April 19 2024 (cait, 12:25:36)
    3. change master > main is going to happen this Friday, April 19 2024 (cait, 12:25:46)
    4. Interlibrary Loans Rethink is moving forward, attention would be appreciated (paulderscheid[m], 12:26:17)
    5. OAI-PMH harvester is moving along (paulderscheid[m], 12:26:58)
    6. https://wiki.koha-community.org/wiki/Road_map_24.05 Road map 24.11 (cait, 12:27:05)
    7. Bookings moving forward reasonably well, lead-in periods need attention (paulderscheid[m], 12:27:49)
    8. Plugins - Discovery, Authenticity was discussed at hackfest, next steps also in discussion (paulderscheid[m], 12:29:25)
    9. Geo-Search is passed QA (paulderscheid[m], 12:30:11)
    10. Using the REST API to display items on the biblio detail view has been pushed to master (paulderscheid[m], 12:31:41)
    11. Move patron searches to a modal has been pushed to master, needs documentation (paulderscheid[m], 12:32:18)
    12. Refactoring C4 to Koha is postponed because the next release is too close already, needs more attention in next cycle (paulderscheid[m], 12:32:48)
    13. ACTION: everyone please mark your roadmap projects as done if they are (paulderscheid[m], 12:33:29)
    14. matt is working on isolated vue components, ready for show-and-tell soon (paulderscheid[m], 12:34:27)
    15. foundational work made for deprecation of bespoke syntax in slips and notices (move to TT), still long way to go, though (paulderscheid[m], 12:36:24)
    16. Move domain limits from koha-conf to staff SMTP config, moved to next cycle (paulderscheid[m], 12:37:03)
    17. Improving tests for koha plugins has been pushed to master - oldoldstable (paulderscheid[m], 12:37:47)
    18. Performance improvements still in discussion in a pad (paulderscheid[m], 12:38:46)
    19. https://annuel.framapad.org/p/koha_optimisations (paulderscheid[m], 12:39:04)
    20. Job queue/RabbitMQ bugfixes and improvements, update from KIT would be great, bugs under that umbrella should be worked on next cycle (paulderscheid[m], 12:40:14)
    21. ACTION: joubu please send for retrieval of mailing list content (paulderscheid[m], 12:41:02)
    22. debian package packaging needs to be automated next month (paulderscheid[m], 12:41:44)
    23. cait needs help with fixing jenkins (paulderscheid[m], 12:43:12)
    24. automated screenshots has been presented at the hackfest, offer from joubu to show developers the process (paulderscheid[m], 12:43:58)
    25. template toolkit reference guide, contact to david nind needs to be established (paulderscheid[m], 12:45:00)
    26. we need to have a discussion of separating community efforts which should go in the roadmap to more individual projects that should also be announced in some way close to the roadmap (paulderscheid[m], 12:48:00)

  7. Actions from last meeting (paulderscheid[m], 12:48:23)
    1. explore email solution for discourse that was discussed for wiki: rangi updated the DNS now, portainer setup is next step (cait, 12:52:48)
    2. ACTION: thd to inquire about a test-server for testing email-relay (paulderscheid[m], 12:52:50)
    3. ACTION: tcohen to write a guideline for the API returns when work has gone through QA (paulderscheid[m], 12:53:50)

  8. General development discussion (paulderscheid[m], 12:54:51)
    1. In Marseille, there was some talk about reorganizing extended attributes in general, to simplify code and maybe unify the storage of them. Bug 35508 is proposing to update the patron row *updated_on* column when extended attributes get modified. I think this needs to be discussed by the team and a decision made. > please see dicussion on Mattermost (cait, 12:56:04)

  9. Review of coding guidelines (paulderscheid[m], 12:57:29)
    1. ACTION: paulderscheid[m] to add a section about JSDoc to the coding guidelines(JS) (paulderscheid[m], 13:00:54)

  10. Any other business (paulderscheid[m], 13:01:45)
    1. trying out starting the meeting one hour later :) (cait, 13:03:52)
    2. ping @bag in mmost for help with anything community related (paulderscheid[m], 13:05:46)

  11. Set time of next meeting (paulderscheid[m], 13:06:07)
    1. Next meeting: 02 May 2024, 13 UTC (paulderscheid[m], 13:09:27)


Meeting ended at 13:10:38 UTC (full logs).

Action items

  1. cait to send an email to koha-devel announcing the change of the default branch from master to main
  2. change master > main is going to happen this Friday, April 19 2024
  3. everyone please mark your roadmap projects as done if they are
  4. joubu please send for retrieval of mailing list content
  5. thd to inquire about a test-server for testing email-relay
  6. tcohen to write a guideline for the API returns when work has gone through QA
  7. paulderscheid[m] to add a section about JSDoc to the coding guidelines(JS)


Action items, by person

  1. cait
    1. cait to send an email to koha-devel announcing the change of the default branch from master to main
  2. thd
    1. thd to inquire about a test-server for testing email-relay
  3. UNASSIGNED
    1. change master > main is going to happen this Friday, April 19 2024
    2. everyone please mark your roadmap projects as done if they are
    3. joubu please send for retrieval of mailing list content
    4. tcohen to write a guideline for the API returns when work has gone through QA
    5. paulderscheid[m] to add a section about JSDoc to the coding guidelines(JS)


People present (lines said)

  1. paulderscheid[m] (44)
  2. cait (14)
  3. mmost (12)
  4. huginn` (7)
  5. marcelr (4)
  6. aude_c[m] (1)
  7. bag (1)
  8. Annelisterman[m] (1)
  9. thd (1)
  10. EmmiTakkinen[m] (1)


Generated by MeetBot 0.1.4.