#koha: Development IRC meeting 28 February 2024

Meeting started by cait at 12:07:37 UTC (full logs).

Meeting summary

  1. Introductions (cait, 12:07:45)
    1. Katrin Fischer, BSZ, Germany (cait, 12:07:52)
    2. Tomas Cohen Arazi (tcohen, 12:08:41)
    3. Nick Clemens, ByWater Solutions (kidclamp, 12:08:53)
    4. Thomas Dukleth, Agogme, New York City (thd, 12:09:21)

  2. Announcements (cait, 12:10:35)
    1. https://annuel.framapad.org/p/koha_34478_remaining (kidclamp, 12:11:44)
    2. Patches for bug 34478 will be pushed soon - be prepared to have some breakages, report bugs and help with fixing. (cait, 12:11:58)
    3. Register for hackfest in Marseille if you plan on coming! (second week of April) (cait, 12:12:38)

  3. Updates from the Release manager (24.05) (cait, 12:12:54)
    1. No big updates apart from bug 34478 (cait, 12:13:42)
    2. Updates to Jenkins: including takss for the security branches, cleaned up all users and permissions etc. (cait, 12:14:41)
    3. Jenkins deployment issues with the nodes have been resolved - hopefully giving us less failures (cait, 12:15:21)

  4. Updates from Release Maintainers (cait, 12:16:11)
    1. We will have a coordinated security release this month, stay tuned (cait, 12:16:38)

  5. Updates from the QA team (cait, 12:16:51)
    1. QA has been delayed, because of the master freeze and work on the big bug - working to resolve that soon (cait, 12:17:17)

  6. Status of roadmap proejcts (cait, 12:17:36)
    1. tcohen: work continues on record locking and sources (cait, 12:18:36)
    2. cait: master to main has been discussed and we have a list wit todos - need to agree on a date, lots of scripts will need to be adjusted as well (cait, 12:20:19)
    3. kidclamp: bookings and REST API for item display are next (cait, 12:21:54)
    4. thd/paulderscheid: work on test instances happened (cait, 12:23:58)
    5. paulderscheid: still working on cities on Vue, work on Discourse instance (cait, 12:26:35)

  7. Actions from last meeting (cait, 12:28:57)
    1. No actions from last meeting (cait, 12:29:03)
    2. Paul Derscheid, LMSCloud GmbH, Germany (paulderscheid[m], 12:29:05)

  8. General development discussion (cait, 12:29:16)
    1. No comments (cait, 12:29:58)

  9. Review of coding guidelines (cait, 12:30:10)
    1. ACTION: thd to add task about testing discourse backups to Taiga (cait, 12:30:44)
    2. ACTION: all add coding guideline for CSRF protection on forms (cait, 12:31:16)

  10. Set time of next meeting (cait, 12:31:50)
    1. Next meeting: 6 March 2024, 13 UTC (cait, 12:33:38)


Meeting ended at 12:34:04 UTC (full logs).

Action items

  1. thd to add task about testing discourse backups to Taiga
  2. all add coding guideline for CSRF protection on forms


Action items, by person

  1. thd
    1. thd to add task about testing discourse backups to Taiga


People present (lines said)

  1. cait (33)
  2. huginn` (5)
  3. kidclamp (2)
  4. tcohen (2)
  5. ashimema (1)
  6. thd (1)
  7. paulderscheid[m] (1)


Generated by MeetBot 0.1.4.